Posts created by callielee

 
 
 posted in Mystery Trackers: Memories of Shadowfield on Jul 27, 17 3:28 PM
Hint button not working. I have a Mac, so it isn't a permission problem. I will wait to play after an update with a patch is available.
 
 
I also have a mac that does not play the videos. Annoying pink screen. I deleted the game. If this can be fixed, I will buy it.
 
 
 posted in Lost Lands: The Wanderer Collector's Edition on Nov 9, 16 8:15 AM
the runes are not working. I took a pic of them to be sure, and the first on the left funally worked, but the others will not. I guess I will have to quit and not finish, serious bummer.
 
 
 posted in Westward IV: All Aboard on Aug 28, 16 1:41 PM
I have tried to repair the tracks damaged in the main town, no go. My cursor lights it up, but the repair hammer refuses to light and no repair.
 
 
 posted in Mystery Tales: Her Own Eyes Collector's Edition on Feb 24, 16 9:45 AM
I have a different issue. Playing on a Mac running El Capitan . The game itself ran well, but there is a glitch in the bonus that will not allow me to pick up the other half of the shears. I am going to try some things and will post IF they work. If not, this is it.
No go. Do not want to start over to get to the Bonus Game. oh well/ i enjoyed it to here!
 
 
 posted in Beyond: Light Advent Collector's Edition on Jul 31, 15 8:26 AM
Mine said that too. I waited and the Sundae came up, or moved the mouse to the right side. I do not remember now. It is there I hope. Look harder.
 
 
 posted in Beyond: Light Advent Collector's Edition on Jul 31, 15 8:21 AM
I just kept trying the hat. It eventually accepted it.
 
 
 posted in Beyond: Light Advent Collector's Edition on Jul 29, 15 5:47 PM
Mute and unmute after starting did the trick with my iMac
 
 
 posted in Beyond: Light Advent Collector's Edition on Jul 29, 15 4:58 PM
belamba wrote:I've no sound on this game? And once I open game it kills the sound on my laptop and I have to reboot it. Everything up to date. I've uninstalled and reinstalled but still the game is silent. Have checked all the sound options, turned them up to max but still nothing...
I've a Macbook Pro OS X 10.10.4 running Yosemite.
Really disappointing :-(


I have the same problem, no sound on my iMac running Yosemite 10.10.4
 
 
I think that i must have missed something, because i found one piece of glass and nothing else is findable. They must be in the drawers, behind doors etc., but I cannot find any way to open them. Help please! nevermind
Got it!!

Now I cannot get the scissors to cut the pillow,
 
 
Unfortunately, i have a Mac, and the video will not play. I am stuck in the clock tower, and cannot solve the HOP in the cupboard. I picked up 1 piece of glass, but nothing else works! sigh
 
 
 posted in Rite of Passage: The Lost Tides Collector's Edition on May 6, 15 2:01 PM
Lilly214 wrote:NFLYNN and VAMPYRLADY - I too am stuck in bonus chapter - inside plane - did not get the ruler inside tavern BEFORE entering the plane. Now cannot leave - have to restart game.


i am here, also. Restarting the game.
 
 
 posted in Rite of Passage: The Lost Tides Collector's Edition on May 6, 15 12:09 PM
I failed to get the nautical ruler and have no coordinates for the map, so I can't take off. I can"t I get out of the plane to go do it either. I will have to replay the main game to get to the bonus on another profile!!
Be sure you have everything before you return the key to the pilot!!!!
 
 
 posted in Rite of Passage: The Lost Tides Collector's Edition on May 6, 15 12:04 PM
the plank is on the bench. You need a screw driver
 
 
 posted in Ancient Rome 2 on Aug 27, 14 6:14 PM
Also stuck. I found that 28 soldiers is pretty good. 21 is not enough. And if you do not connect to the road, the brigands find you anyway, and there are fires.
I had been building around a square, with the houses in two rows on either side and the other stuff in the center with gardens, etc. That way all the houses "see" everything. But this level with "improved roads" doesn't seem to work. I improve the houses slowly, 3 at a time. They accept the roads at level 10 and 11, but reject them at 12 when I add the Forum to go to 13. Getting pretty good at getting money and building stuff. I do not use the whole area, but I've never made it to level 13 with the houses! Stumped>
 
 
 posted in Ancient Rome 2 on Aug 27, 14 6:00 PM
getting ready for my 4th time. It accepts the roads at level 10 and 11, then rejects them at level 12 and goes no further. I put my houses around a square that contains all the other stuff, and fancy all the roads. no dice. I guess this is as far as i can go with this game.I will try putting them in a block.
 
 
 posted in Ancient Rome 2 on Aug 21, 14 12:40 PM
figured it out, gotta use both
 
 
 posted in Nearwood Collector's Edition on Jun 24, 14 7:59 AM
This game played beautifully but I have one problem: Wallpaper: it doesn't work. I am on a Mac with everything updated. It says that it is set, but it is not there and I cannot find it.
 
 
 posted in Ancient Rome 2 on Jun 2, 14 3:08 PM
I love these games, but I am not very good playing. I have not been able to get the houses to recognize a reservoir and they keep asking for a well. I am told at the beginning that I need one, but everything else was done and the houses did not think they had water! I put roads all over the place, around it and to each house and even around each house! no go
i am ready to
 
 
 posted in Legends of Atlantis: Exodus on May 30, 14 12:45 PM
I have a Mac, everything is up to date, I have uninstalled and reinstalled it. It still crashes repeatedly, much more often now that I am in Crystal Caves. It is now unplayable, and I really like the game!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator