Posts created by Poof11

 
 
 posted in Deadtime Stories on May 2, 10 7:10 PM
I've used the hint potion several times, and it seems to form a "V" in the top right corner of the screen. I've clicked everywhere within that area, and also in the area where the two streams crossed, but with no luck.


I had the same problem....but I knew one of you wonderful fishies would help me out. Never did I think to look for a marble gravestone. It was so close to the hint area I actually thought it was part of that book and all.

Really enjoying this game. Thanks again for the help ......here you deserve a piece of . Many thanks.
 
 
 posted in Eternity on May 1, 10 3:34 AM
I just finished the demo and the game was okay. The graphics during the adventure part are very nice but why is it when it came to the hidden object parts they were terrible? I did like the use of the different rooms and the check mark when all was complete. Some of the objective could have been more clear, like finding the coal.
Also, when a developer is going to give you puzzles that need to be rotated why can't they just make the right mouse button the rotate button? It becomes very annoying when you keep left clicking to rotate the item and you keep dropping it, moves once, drop it, etc.
I may have bought it but for now maybe it will go in my list for DD.
I hope the rest of you fishies who have bought it have hours of fun. Enjoy your weekend all.
 
 
 posted in Cruise Clues: Caribbean Adventure on Apr 28, 10 9:03 AM
I had gotten to her cabin and had to put the picture back together and it will not rotate no matter what. I got so frustrated that I quit the game. Just the kind of day I am having and was hoping for some kind of relief.
 
 
 posted in Unsolved Mystery Club™: Amelia Earhart™ on Apr 25, 10 12:15 AM
ember89 wrote:so it looked nice enough, and the plot was definitely great - i mean, who doesn't wonder what really happened to her? - but i just couldn't get sucked in enough to say, wow! what a really great game?! i didn't like the professor-dude with all his popping in and out of the game... at every step i felt interrupted... so while i stuck it out through the demo, it didn't seem worthwhile to pine over lost time... for real aviation buffs and true crime stories hangers' on, this could be a real find... for me, not so much!

happy flying!


I have to say, I whole heartedy agree with you. I also did not like the fact that the menu and inventory buttons were so close together (I kept getting the menu whenever I wanted to click the inventory).
 
 
 posted in Pathfinders: Lost at Sea on Apr 9, 10 7:49 PM
This puzzle was driving me crazy...it should have had a lock mechanism for each correct ring. I knew if I came to the forums, someone would have an answer as to how to get this thing to work. After trying for over 30minutes, I gave in. Followed the instruction to exit out and go back into game and viola......It worked on the first try.
Thank you fishies once again for bringing a completely frustrating situation to a happy ending .
Have a Great Weekend!
 
 
 posted in Mind's Eye: Secrets of the Forgotten on Apr 7, 10 1:25 PM
After collecting the chess pieces and moving back to the news room I was going to pick up one of the masks and received an access violation error and the game closed out. I still have time left in the trial and will try again but wanted to let all of the fishes know
 
 
 posted in Escape from Lost Island on Mar 25, 10 11:59 PM
"Played the game again got to where you get arthritis from clicking on a gold coin to get it up some air bubbles when it just closed itself completely. I went back to the game and guess what.....THE DAMN GAME DID NOT SAVE!!!"

grrrr...I had the same exact problem except I had saved it earlier at the point where you had to fit the pieces into the images (pyramids, boxes, etc.). I went back in and picked it up from there but boy was I mad when I found out that I was actually at the end of the game after getting to that same point and just skipping that puzzle. It showed you the black and white story screen then it pretty much took you right back to the sign in screen. I could have gone to bed an hour ago. Now to go get some sleep. .

I should alway follow my gut instinct and check the forums first. Thanks fishies!
 
 
 posted in Millennium Secrets: Emerald Curse on Mar 20, 10 11:12 PM
Just finished the game (regular mode) and it took me approximately 6 hours, with a few breaks, and reading/listening to the story line. I normally skip all of that but this game had me interested enough to want to know more about the story.

As many have said, after the hour demo flew by I had to purchase to continue on. I really didn't think this game would last as long as it did but am quite delighted that it had. I did take this slower than I nomally do but for a very boring Saturday night....this really hit the spot.

I'll give the adventure mode a try tomorrow to see if there is much of a difference.

Looking forward to the next chapter of the adventure. Jazz hands up !

Enjoy your weekend everyone.....particularly since we finally have a bright and warmth.
 
 
 posted in Eden's Quest: The Hunt for Akua on Mar 5, 10 7:34 PM
I downloaded the game and the C++ thing began to play the game, everything was fine. I was in Chapter 2, spoke with Octavia and did the two totems, and when I pressed the arrow to go towards Palm Grove....boom....black screen. At first I thought maybe I have just finished my demo, then I noticed I could vaguely see the screen. Nothing worked, cursor, key to windows,Cntrl-Alt-Del. So I figured let me wait, trials got to be almost done...well 15 min later....nothing. You could see the harddrive was trying to do something but finally had to shut the whole thing down. I am running Win7 x64 premium with all drivers up to date and plenty of memory. There's definately something up with this game.
 
 
 posted in 3 Cards to Dead Time on Feb 27, 10 4:01 PM
I also had a problem exiting out of the game and had to use the task manager to end it. Game exited to icon (minimiized) but could still hear the music playing, checked and game no longer responding.
I really wish the developer would have given you the option to turn off the music, since I never listen to it. Why give me an options section if you're only given me full or windowed mode?
I also agree with the others about the dialogue...could have been done much better. Too much and set at the wrong parts of the game. Put at the beginning or end of the chapters.
I do find the game more challenging with the word association, much different approach from other HOG games.I did purhase the first game but am on the fence with this one. I guess I'll see what tomorrow brings.
Happy Saturday fishies!
 
 
 posted in Escape from Lost Island on Feb 25, 10 4:28 AM
Well after demoing Treasure Seekers, this game was a bust. Although the mode of finding objects is similar to TS this game just didn't do it for me. The graphics were very grainy. Found myself getting frustrated and using hints (which I hate to do). My hour seemed to drag. Definately a no buy for me
 
 
Well since I couldn't , I was delighted to find Treasure Seekers. I came very close to finishing the 2nd Chapter of 6 and the game is very much like the other two, in the sense of finding objects. Clear graphics, no technical issues,etc. If you liked the first two then I think you're gonna like this one.
Since it is the end of the month and money is tight, not sure if I will purchase the CE, and the fact that the game can probably be competed in 3 hours or so (looking for something to get me through the snowstorm). Will wait for other reviews to see how long it took. If this were the regular version I would be buying it right now.
 
 
 posted in Empress of the Deep: The Darkest Secret on Feb 20, 10 9:34 PM
amahaf2 wrote:Is this the puzzel where you are supposed to enter the numbers 787, 34 & 775?
If so I can't get the first one to enter the 787. The 1st 7 keeps changing, it won't stay. Can anyone help with this?


Try inputting the 775 on the right first, then 34 in the middle and it should let you type in 787. I had the same problem and this is what worked for me. I hope this helps.
 
 
 posted in Empress of the Deep: The Darkest Secret on Feb 20, 10 9:29 PM
I found that starting with the 775 number on the right and moving to the middle and inputing 34 and then the last number 787 was immediately excepted. If I did it from left to right, I could not get the correct number.
I hope this helps you and others. Happy gaming!
 
 
 posted in Romancing the Seven Wonders: Taj Mahal on Feb 19, 10 2:03 AM
This game really has me on the fence. Plenty of great info about the Taj Mahal but not enough info in what you're supposed to do. Wasn't keen on having to find two of the same items before you could continue with your search. Also, you really didn't need a list in some of the hidden object areas since it was fairly easy to pick out what did not belong. Also, why give you a map if you cannot click on it to move from room to room. At times the arrows to move between scenes was iffy. I don't think this one is for me ..I'm off to . Have a great weekend fishies! Maybe tomorrows game will float my boat.
 
 
 posted in Shutter Island on Feb 13, 10 6:13 AM
This game had so much potential but truly fell flat. For those who do not like dark scenes, small objects....this game is not for you. Also, those who are affected by flashing lights, please be warned. There is one section of 5 or more rooms, so far, where it could affect you.
Instead of picking items up and then put in your toolbox, the creators could have done the hot spot where you hit it, see what is needed in the circle and then the item is put in automatically. I thnk it was a waste of time to keep opening up the toolbox to put these items in the needed area.
What was with all the alcohol in the nut house? Did the docs need to bevy up before seeing patients...haha? I thought it was odd.
This game should have been beta tested more and really could have been so much better. Definately not a buy for me.....maybe when it hits $2.99....maybe.
 
 
 posted in Nightfall Mysteries: Curse of the Opera on Feb 7, 10 11:34 PM
I had no problems until I got to the tower puzzle. I was in windowed mode and clicked on the game icon a few times and after about 40 seconds the game minimized and began to play the ending. Prior to that my game cursor was frozen and I was just about to hit cntrl, alt, del when the game began to run again. Maybe the end scene is just a large file that it takes awhile for it to load...I don't know.
I really did enjoy this game. Major ! The game took me about 8 hours with breaks in between.
Thanks for another great game.
 
 
 posted in Epic Adventures: La Jangada on Feb 5, 10 9:16 AM
It looks as though I am in the minority here, I was bored to tears. Anyone with visual problems will have a problem finding some objects, since many are very small and very well hidden. I am also not too keen on game makers that insist on putting objects at the very edge where you can only see a little part of it. I had to do alot of guessing of objects due to their size. Sorry folks, I won't be buying. Off to find a game to get me through the incoming snow storm. Stay warm fishies and enjoy your weekend!
 
 
 posted in Big City Adventure: Vancouver Collector's Edition on Jan 29, 10 12:55 PM
The question mark is there it is just integrated into one of items.
I had come on to see if there was something special with the ? marks and . I had noticed that there were a few in each scene and wondered if this was an extra bonus which only is available when you purchase the game. Anyone know?
Thanks for another great game! Have a Great Weekend Fishies!
 
 
 posted in 1001 Nights: The Adventures of Sindbad on Jan 27, 10 2:25 AM
I must agree with you all, including the insomnia. You didn't even get time to read the list, or finish picking up an item before it began twinkling. Why bother with a hint system?
I have my fingers crossed that will be getting "Marooned" soon. Seemed like a really good game.
Well other fishes, I think maybe that one will finally send me off to . Good Night All. Have a wonderful Day.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator