Posts created by Sullivan1818

 posted in Chimeras: Blinding Love Collector's Edition on Nov 13, 17 3:25 PM
Thank you for that explanation, like SullysDragons, I was feeling pretty dumb. I have gone to the Secret Room twice and became so frustrated I had to leave it. Now, that I know that they've changed the game, I will go back and try again, as the saying goes, third time is the charm . . . I hope!

 posted in Midnight Calling: Wise Dragon Collector's Edition on Nov 6, 17 1:26 PM
I have the same sentiments, I also can not get to the Secret Room and that is usually one of the reasons I pay the extra for the Collectors Editions. Not good BF!
 posted in Spirit of Revenge: A Test of Fire Collector's Edition on Mar 24, 17 10:14 PM
Having the same issues, main game play complete, get the black screen with falling leaves and nothing more. DEVS, please get us a solution.
I can add my name to the list re: The Smoking Pipe. It is so frustrating to get almost to the end of the game and then have a glitch, that hasn't been fixed get in your way. I hope BFG does something pretty quick about this.
 posted in Dark Realm: Lord of the Winds Collector's Edition on Nov 2, 16 10:32 PM
There are those of us that are not as good at the games as other fishies in the pond, but we most certainly enjoy playing anyway. We rely on the reviews to help us play through. I for one, appreciate the time the reviews take to post some of the game points. If you DO NOT want the spoilers, then please don't complain and spoil it for the rest of us that do use them, just don't read them.
I'm curious, has anyone been able to download and complete the game? I know many can't get past the sick man and we were told that as of May 16, 2016 there was a new download with the fixes. I downloaded and still get the "sick man", so I still am unable to complete the game. I have even created the additional Dr. Felix report, however, Big Fish has so far has not even responded to my inquires. This game has really become a real pain in the ha-ha!
to Obol: Thank you so much for your tip, that was just what I needed to continue on with my game. I have tried so many times I thought I had a glitch and was going to have do to an uninstall/reinstall to be able to continue. So again, thank you for your help. I wish you a great rest of your evening.

Hi Fishies, I'm wondering if anyone else has found a solution? I have the broken cane, the cane handle and the roll of tape, but it will not let me tape the handle to the cane. If anyone of you has a solution I would appreciate knowing how to move on. Thank you. Game on!
I could sure use some help from the fishies that play smarter than I do. I've placed the Crystals and the Magic Apple and I am trying to restore the 2 pictures. The game seems to be frozen, I've even uninstalled and reinstalled and still nothing. I can't figure out what I've done wrong or if I've missed a step somewhere along the way. The game won't even let me SKIP the puzzle and I also can't SKIP LVL, and the only buttons that I can click is to get to the main menu, nothing else works. Any help you can offer sure would be appreciated.

I have all of the other Witches Legacy and really want this one as well, but it sure would be nice if I could play it.

Belated Merry Christmas, I hope all wishes were granted. Have a fun, safe and Happy New Year.

If there is another solution to the hint button, I would appreciate knowing. I am having the same problem as hangel1, the pink button says "Hint", when I click on that all it does is recharge and goes back to "Hint." The skip option is never offered and I have uninstalled and reinstalled and am still having the same problem. Any help? Thank you everyone.
 posted in Haunted Legends: The Dark Wishes Collector's Edition on May 24, 15 9:15 AM
I have completed the game and am on my second time through. According to the SG, there are 14 Pigeons to collect. I have gotten those however, when I go to the "Pigeon Room", it looks like there is still 2 more to be found. Are there maybe 2 extra ones hiding in the bonus game as an added something to the game? Thanks to anyone of you fishies that can offer me any help or knowledge.

Wishing everyone a fun, safe Memorial Day.
 posted in Reflections of Life: Equilibrium Collector's Edition on Apr 29, 15 12:35 PM
Is anyone else having this problem? Since there were a couple of shards I missed I went in to collect them. One of them is the one on the corner of the bed in the Princess' room, however when I open this scene, the picture of the Princess (that is one the right), has now "jumped" to the center of the scene and no amount of clicking will make it disappear, because of course the last shard I need is behind that picture. Any help you smarter fishies can offer would sure be appreciated. Thanks ya'all, have a great rest of your afternoon.
 posted in Reveries: Soul Collector Collector's Edition on Mar 23, 15 10:20 PM
I have finished the whole game, collected all the feathers but now can not find a way to go back and place the feathers on the eagle. Can someone please tell me how to get back to that part of the bonus. With this being the SHORTEST game I think BFG has ever produced, and I did buy the Collectors Edition, (only because it was on a BOGO sale). I'd still like to be able to play the whole game. Thanks Fishies, have a good week.
Thank you katucci for your response. I will give that a try the next time I open the game. I think I got frustrated enough to lay off for a day.

NOTE TO PLAYERS: Those of us who are not the greatest players would appreciate it you would PLEASE stop speaking for us. If you don't want all the help and all the hand holding, then don't look at the hints or use the SG, but ya all have b______ so much about it, the devs have started listening.

NOTE TO DEVS: As a player, I appreciate the help offered in the SG when I get stuck. The better players ARE NOT speaking for all of us and I would appreciate the SG going back to offering a little handholding for those of us who are less than great players. It gets very frustrating when you get to a point where you just can't solve the problem and you can not move past that point until you find the answer, go to the SG, oh, no help there either.
I couldn't get the 6 matches, best for me was 5 and the last match for me was the pipe, I found the first one but then the game freezes, I did a restart several times with no success. I have uninstalled and as we speak, am reinstalling the game. Not sure what the issue is, however, in my game manager it continues to show me as having 90 minutes left in the trial even though I bought the game 11/28/14, I'm just hoping this reinstall fixes the glitch.
If there are any other solutions, I would appreciate hearing them. I have tried all that are listed here, the only thing I haven't done is uninstall-install again. It is getting really frustrating, I play for the relaxation, not the headaches thrown at me. In my experience, it is rare for me to have problems with Elephant Games and I really like this series, so if any help is out there I sure would appreciate it. I am not the greatest player and I know there are many fishies with better abilities than mine with a solution. Thanks, have a great night.
 posted in Awakening: The Golden Age Collector's Edition on Nov 9, 14 10:14 PM
Has anyone found the Boomzap Logo in the game? I have played twice so far and haven't found it yet? Any spoilers you'd like to share? Have a good night and thank you for any help offered.
 posted in Shrouded Tales: The Spellbound Land Collector's Edition on Sep 22, 14 10:05 AM
Same here, black screen, when I c.a.d., instead of rebooting, click cancel. My screen came back with the game logo, right click to close the game and it will take you back to your game manager where you can go right back to the game. That's what worked for me, hope it helps you too. Happy gaming fishies!
 posted in Spirit of Revenge: Cursed Castle Collector's Edition on Sep 18, 14 8:32 PM
Wow, thanks for the list. By my count, you have found 46 M.O., and I thought I had done pretty good by finding 28. I got everything else OK, I knew you had to stay in a scene for a few minutes and just watch until something morphed but there were some scenes that it took so long for that to happen that I moved on thinking there was nothing there, boy did I miss a bunch. Looks like I will definitely have to play this one again. Thanks for the help JulieJay, I had looked everywhere but could not find help. As for the list of the collectable in the SG, if you will jump ahead to about page 50 or so, the list is there, unfortunately it is for the puzzle pieces only, not the Morphing. Looks like Vendal Games is making us work hard for our entertainment this time!
 posted in Fierce Tales: Feline Sight Collector's Edition on Sep 14, 14 10:03 PM
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator