Posts created by ruralbabe

 
 
Oops just accidentally reported myself for being offensive
 
 
So do we have any answers to the downloading problem? It would be nice to get an update to our queries or at the very least acknowledgment and a possible ETA for a fix.
 
 
I have downloaded it 3 times and every time it won't complete and starts from the beginning again. I live in rural australia and I have a very expensive 16 gig per month, this has just eaten nearly six and I still don't have the game. This is on a mac with yosemite

Ive rebooted, Ive checked the help pages, Ive reloaded the game manager, Ive deleted and downloaded game manager, Ive rebooted the modem and now Im tearing my hair out.

HELP
 
 
 posted in Echoes of the Past: Wolf Healer Collector's Edition on Oct 21, 14 11:10 PM
Kayen59 wrote:I have no idea how to start this game since I don't have a start button or options or exit button when I open up the game. The only way I can get out of it is to Crtl, Alt Del. What is going on, gonna try to unistall and re install the game hope that works. If not I will be asking for a refund


i also have this problem and I have a mac, I don't want to download again as I live in a rural area an have limited download (16gb/month) and very expensive if I go over the limit.

Id rather have my money back than risk it not working again!!! >:-(
 
 
Has anyone had problems with the grid puzzle in the town square? I can place pieces that are the correct way around but can't rotate the ones that need rotating. I am using the Mac version
 
 
 posted in Spirit of Revenge: Cursed Castle Collector's Edition on Aug 12, 14 5:13 AM
Im another mac user with the cushion frozen in the screen has there been a fix for this yet?
 
 
 posted in Spirit of Revenge: Cursed Castle Collector's Edition on Aug 12, 14 5:11 AM
WilJul wrote:
lmhagood wrote:So far, lots of glitches in this game and now I'm stuck, again. The first glitch is when you have to do a "spot the difference" on the painting of the man in the book. I had to restart under a new player because it would not let me pick the last difference which was the curtain. After restarting under a new name, I was able to pick all 10 differences without issue. Now I am stuck in the girl's room. After replacing the torn pictures from the girl's book, you get a cut scene, but now there is just a frozen picture of the chair cushion that the book was laying on. I can't exit the picture. Even we I leave the room, and return, the cushion picture is still there. It obstructs the painting so I cannot replace the frame pieces and do the safe puzzle with the mother's name, which is "Michelle". I'm not restating under another profile...too frustrating! I would suggest waiting to buy this game until some of these glitches are worked out. This could be a great game when they fix these issues.

I'm on a MacBook Pro. 10.9.4

MacBook Pro 10.8.5
I am also having the chair cushion picture frozen and in the way of grabbing the locket from the safe. Slightly different in that I have completed the safe combo and opened it, but the cushion window appeared in the way. Have left the room and exited the game, the window remains in the way. Have uninstalled and am in the process of reinstalling. I will update when finished with the results.
UPDATE: Well, as another player already reported, uninstalling and reinstalling does not clear the cushion. Progress is halted. It appears most of the tech issues on here are MAC-related. I will send a report to customer support and I advise all to do the same. We need a fix here.
Btw, I love how the glitch occurs about 5 minutes after purchasing the game!
 
 
 posted in Riddles of Fate: Wild Hunt Collector's Edition on Sep 13, 13 12:34 AM
I had the same problem, just went to menu and then resumed the game and there they were, no mess no fuss. Seems to be easiest way to fix the problem
 
 
 posted in Awakening: The Skyward Castle Collector's Edition on Sep 18, 12 6:08 AM
me too the scissors just disappeared and are nowhere to be found, is there a fix for this?
 
 
I am also a no saved gamer.... twice now and I really don't want to start again.
 
 
 posted in Maestro: Notes of Life Collector's Edition on Jan 18, 12 4:34 AM
I have almost finished the game, I am at the last scene where eva and her prodigy disappear in side and alice comes foward and the shadows trap her. At this point the game freezes, all inventary, strategy guide, hint etc. disappear and I can do nothing. Help, what can I do? BTW the bonus game hasn't unlocked either. I have tried coling and opening the game several times but no luck I have had not issues up until this point
 
 
got it thanks a lot
 
 
I try to give kai his picture but he won't take it, just keeps repeating it's safe up here etc, have I missed a vital step somewhere?
 
 
I'm having a co9mpletely different problem I cant get the candle in the HOS in the museum because it wont let me pick up the "letter Z" from the HOS, is anyone else having this problem. I reinstalled the game but that hasnt helped
 
 
 posted in Dark Dimensions: City of Fog Collector's Edition on Jun 16, 11 10:57 PM
Thanks for the spoiler list, I have searched each and every locations thoroughly even down to using the hint button just in case I was missing something and I cannot find the elusive 12th angel. I did have a glitch early in playing the game and it makes me think that my missing angel has disappeared into the black ether and I will never get it back. I don't relish the thought of starting again especially if I end up with the same result. Has anyone else had this problem? HELP!!!!
 
 
 posted in Dark Dimensions: City of Fog Collector's Edition on Jun 9, 11 9:40 PM
I too have only 11 angels and spent a lot of time looking for the 12th, I have looked in the guide but so far can't work out where I've missed one, HELP PLEASE
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator