Posts created by anlylo

 
 
Thank you,Sazoria! I really feel so much better now I know someone is listening! I don't ask for help much only when the Strategy guides are no help.At least I know it's not a complete fraud.
 
 
 posted in Witch's Tales on Oct 31, 17 4:33 PM
I also got to the big pile and even though I found all the matches nothing would work.I was going to buy this game but so glad I waited.Big disappointment!
 
 
I have posted questions for help several times and I never ever get a reply.Am I doing something wrong???Thank You
 
 
Hi! I have been a BF Customer since 2009.I love this game and I want to buy it but the inventory in the game will not show.I deleted and and reinstalled it and it will show only in that scene but as soon as I move to a different location it disappears again.I need to know how to fix this.I can't play the game if I can't use my inventory items.Please tell me if this is a bug in the game or something else?I have never had this problem before ever! Thanks in advance!
 
 
 posted in Steel LIFE on Mar 23, 16 4:46 PM
I just figured it out through trial and error.Give the crystals to the bartender.He's going to say"Thank you."Try to use the suction cup on the drawer and the Bartender will ask you not to bother his things.Go outside turn off the electricity then return to the bar and use the Suction cup on the drawer in the dark.Take the brush and add the metal bar from your inventory to get a long brush.Turn the electricity back on get in the mine and use the blowtorch to free the dog and use the brush to unstop the pipe.Hope this helps!
 
 
 posted in Fire on Feb 11, 16 5:25 PM
I read your post and was delighted to see you had listed more of this type of game.I played City of Fools and loved it! I found Evil Pumpkin but i typed in a search and i can't find the Big Secrets of a Small Town on BF anywhere.Could you please tell me where i can find it? Thanks in advance!
 
 
 posted in Fire on Feb 11, 16 5:17 PM
Hi! I.m new to this kind of game genre but i absolutely love it!! I played "The Silent Age"which is like this but my computer would not let me play Violet and i tried 3 times.I am stuck in the lizard trees mouth and i can't get that ball out of the tube! I can't find any Strategy guides the Hint button doesn't help and i'm so happy to finally find this Forum because i've been looking for weeks for a Forum or Walkthrough! Please give me tips so that i can finish this fun game! Thanks in advance!
 
 
 posted in Deponia: The Puzzle on Apr 29, 14 4:22 AM
Good Morning! i have just downloaded Deponia,The Puzzle and the game won't start! All i get are three stars spinning around and the skull is in the middle of the scroll bar instead of starting at the top.please tell me what's wrong?
 
 
 posted in Order of the Light: The Deathly Artisan on Mar 27, 14 9:41 AM
Hi! I'm Angela and i wrote a post before about being stuck in the room because the chemicals won't work.I saw other players also had this problem but i did not see a reply.Could someone please help?i was enjoying this game and it's a bummer that i can't finish it.If there is no solution,i would like another game or a refund.i have tried uninstalling and reinstalling,but still no results.Thanks so much!
 
 
i AM HAVING TROUBLE WITH THE CHEMICALS FOR SPRAYING THE VINES IN THE HOTEL ROOM.THE CHEMICALS SPRAYED TWICE THEN QUIT AND I'M STUCK IN THE ROOM! PLEASE TELL ME HOW TO FIX THIS PROBLEM!
 
 
 posted in Midnight Mysteries: Haunted Houdini Deluxe on Oct 9, 13 8:32 AM
Hello! My name is Angela. I have been stuck on this game for so long and still can't continue the game until I finish the task. I am looking at a Houdini and his wife's graves and am supposed to read the newspaper but the game won't let me! I have been thru SG and the walkthrough but nothing works! Please give me tips or I may as well throw it out for good! Sincerely frustrated
 
 
 posted in Sister's Secrecy: Arcanum Bloodlines on Aug 1, 12 1:33 PM
Hello Big Fish! I just bought Sister's secrecy Arcanum Bloodlines and i am so frustrated because i can't get any farther.I'm stuck on tracing the lines on on the sail to make them glow.It worked fine on her face but the wind coming from her mouth won't glow! I've been trying everthing for three days and nothing works! I can't skip it or go forward until i do! Is my game defective or did i just waste my money? I really like this game and would like to finish it.Any and all advice will be greatly appreciated!!!
 
 
Hi! Can someone please help me? I am stuck at the lever in the lighthouse! I move the arrows right,down,left and up but i cant find a combination that works!The illustration in the guide doesn't work and i am frustrated!!!!! Please help!
 
 
this guide sucks! It's the worst guide iv'e ever used! I cannot solve the green gems puzzle and i can't go forward until i do! Help me please!
 
 
 posted in Echoes of the Past: Royal House of Stone on Aug 17, 10 6:34 PM
Can anyone please tell me how to get the letter out of the bottle?The door is still sparkling but it says the letter is in bottle.and cant be moved.And also i dont have a feather in my inventory even though i played the feather mini-game..
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator