Posts created by Terry742

 
 
 posted in Christmas Wonderland 7 on Mar 8, 17 3:06 AM
The shepherd in the middle looks like Joseph
 
 
You will hear a clicking sound when the pick is in the right position. Then double click to set it, and do the same with the other pick.
 
 
 posted in House of 1000 Doors: Evil Inside Collector's Edition on Apr 7, 15 8:46 PM
I get to the elevator with the dynamite bomb and nothing works.
 
 
 posted in Dark Dimensions: Homecoming Collector's Edition on Feb 17, 15 4:14 PM
Thanks
 
 
 posted in Dark Dimensions: Homecoming Collector's Edition on Feb 15, 15 11:10 PM
Is there some trick to this?
 
 
 posted in Mayan Prophecies: Cursed Island Collector's Edition on Oct 5, 13 10:56 AM
I can't get the download to work, even with Alternate Method.
 
 
 posted in Riddles of Fate: Wild Hunt Collector's Edition on Sep 8, 13 1:37 PM
Where is the sphinx heart?
 
 
 posted in Riddles of Fate: Wild Hunt Collector's Edition on Sep 8, 13 1:33 PM
Try the Windows button.
 
 
This game has numerous technical problems. It -- off and on -- refuses to behave in quite a few parts of the game. IOW, sometimes it works and sometimes it doesn't -- in the same spots. The cauldron in the early part of the game sometimes refuses to clear the scene. Restarts just go back to the same place.. I've used a number of Players trying to get it to work right. Sometimes the termites work, and sometimes not.
Sometimes the ship works.... Sometimes the guide refuses to work.
 
 
 posted in 9: The Dark Side Of Notre Dame Collector's Edition on Feb 18, 13 9:21 AM
Well, I spent many of my "free" minutes searching in vain for
the drain. The strategy guide was of no help, since it showed
only a close up of it. I have no idea if I will like the game enough
to buy it.
 
 
 posted in The Dreamatorium of Dr. Magnus on Sep 16, 12 8:59 PM
I can't get into the basement at all. Is there some trick to opening the door?
 
 
 posted in Haunted Manor: Queen of Death on May 19, 12 7:07 PM
I get all the way to the end, and try to give the potion to Stella, but it doesn't work.
 
 
 posted in Farmscapes on Apr 17, 12 4:10 PM
I'm still trying to make it past level 65. How do I get rid of boxes that
are isolated from the rest of the puzzle?
 
 
 posted in Mystery of the Ancients: Lockwood Manor on Nov 1, 11 5:31 PM
I tried this game and liked it, but had troubles with it freezing. I've used up all my trial time. I updated the display driver. I'd like to buy the program, but not if it's still acting up. Is there some way to get a few more minutes to see if the problem is solved?

 
 
 posted in Mystery of the Ancients: Lockwood Manor on Nov 1, 11 7:51 AM
The graphics were awful for me. The screen froze for many seconds, time after time. I have a decent graphics card, and this doesn't happen very often for me.
I'm interested in buying the program, but not if the graphics problems aren't worked out.
 
 
I remember playing this bonus game before, but not with this game,
 
 
Ok, I figured it out. What I really needed was the Second part of the Moon, since the first parts of the Sun and the Moon are already there. By using the Hint, I found out that I had missed a Hidden Object game.
 
 
I can't figure out where the first part of the Sun is? I've read and re-read the Strategy guide for help, and can't find any reference to it.
 
 
 posted in Golden Trails: The New Western Rush on Jul 18, 10 9:48 PM
What tool do I use to get whatever object is under the floor in the Saloon?
I have only 2 tools and neither of them works.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator