Posts created by Patter57

I cannot get past the ship with the sails. I have read the letter, and looked in guide but for some reason it doesn't work. Any ideas?

I did look back through the questions, but the ones asked went unanswered, so thought I would try again.

Never mind....figured it out!

Perfect solution. Thank you!
Hint button does not work.
 posted in Danse Macabre: Thin Ice Collector's Edition on Jul 11, 15 11:21 PM
Martyheinz wrote:Played the game last night with no problems. When I opened it this morning I got a message saying profile was corrupted to start a new game. When I did this, all the collectibles (snow globes) had disappeared. I am reinstalling now.

Same thing happened to me. The snowglobes and morphing objects were gone. When I got to the point that I quit last night, I went in under the orginal name and it picked up where I left. Now I am finding the snowglobes and morphing objects. I guess I could have started over, but thought I would give it a try. When I close the game this evening, I'll go back in and see if it is doing the same thing. If so, I'll just send it back to BigFish, send in my felix report and let them sort it out. I have never had a problem with them either fixing the game or giving me a credit for a new one.
 posted in Haunted Hotel: Death Sentence on Jan 17, 15 10:06 AM
I beta tested this game and loved it, bought the CE

I have a game credit if anyone is interested. Please pm me and I'll send it to you.

 posted in Fear for Sale: The 13 Keys Collector's Edition on Nov 26, 14 10:52 AM
November 26th, and still no fix. I really liked all the previous Fear for Sale games. But will not buy another unless they fix this one. I'm sure a lot of folks have the same problem and are not posting, just reading and waiting.
 posted in Fear for Sale: The 13 Keys Collector's Edition on Nov 7, 14 5:07 PM
LaVerne702 wrote:I see that others are having this same issue. I finished the main game with no problems, but I am having a problem with the bonus game. When I get to the part where you have to combine the occult book with the book key, it is not possible because I don't have a book--only a notebook page that has "Occult Book" printed on it. It also doesn't give me the option to combine it with anything. Please help! Thank you in advance.

Same here, maybe if we post enough, they will get a fix for it.

 posted in Sable Maze: Forbidden Garden Collector's Edition on Jul 24, 14 10:42 PM
I did not find the game fun. Graphics were okay, storyline was okay. puzzles were okay. Just normal stuff in all these recent games.

What I did find, was an ermine. Okay, that was kinda funny. But would have rather found a vicious dog I could use. Sic em Fido! Cute and fuzzy...No...Scary and spooky....yes. So no buy for me on CE. Maybe if I am out of games , I'll get it with a coupon. Don't want to see dragons, emine, small puppys, fairies or pandas, So over them.
 posted in The Others on Apr 23, 14 5:16 PM
Put the grappling hook on the left end first and then the rock on the other end. It will then shoot the hook to the top.
 posted in Mystery of Sargasso Sea on Jan 22, 14 8:20 PM
Thank you!
 posted in Otherworld: Shades of Fall Collector's Edition on Oct 17, 13 7:13 AM
tammytheo wrote:You are so right CiChDa.

A big thank you to all our wonderful reviewers.

So True....Thank you!

 posted in Grim Tales: Bloody Mary Collector's Edition on Aug 1, 13 11:13 AM
Can't add anything more than what others have stated. Wonderful game. I love the spooky feel of this game. Real life, not so much...but in a game! WOW! Just perfect. I turned my sound up and away I went into the dark recesses of my childhood scare room! Love it! Makes me wonder what they will come up with around Halloween! This will be hard to beat!

 posted in Reveries: Sisterly Love Collector's Edition on Jun 11, 13 8:29 PM
This has got to be the most horrible game I have tried to play. So much wrong. Tried to play on desk top, could not get the water elephant. Put in a message to help, told me to do all the things I had already done.

Finally said they would save it and send it back to me with the elephant picked up. Thought I would try to play on lap top. Hot game and lap top kept turning off. But finally made it to the end. Started the bonus part. going fine, then clicked on the amulet?? The fire water thing in the left hand bottom corner. Can not get out of it. Have tried everything. At this point I am tired of fighting it. I am going to delete it and not look back. But it will be the last ERS game I buy. Their 50th game was a flop. Can't decide if this is a review or a problem. Thought If I put it in review, they would moderate me. I hate it when that happens.

A not happy Jellyfish .
 posted in Timeless: The Lost Castle on Feb 17, 13 6:42 PM
I had trouble with the green, but after messing around with it, finally found the right green. Just keep moving those crystals around till ya get the color that they want.
 posted in Murder, She Wrote 2: Return to Cabot Cove on Nov 28, 12 1:28 PM
So far I am enjoying the game, got through the first murder! After playing the first Murder She Wrote, I find this one not near as refreshing but okay. I liked the first one much better and it had 5 books. This one only 3. I like the straight seek and find in the first one as opposed to this one also. But mainly got it for my mom, who enjoys straight seek and find and a few simple puzzles. I just hope this one is not too difficult for her....she will blame me!

Oh...and in the first series, there were flower gardens and flowers and other girlie stuff. I like that mixed in with the straight dead body laying on the ground.
 posted in Fierce Tales: The Dog's Heart Collector's Edition on Jun 28, 12 9:28 AM
[Removed by Moderator]
 posted in Resurrection, New Mexico Collector's Edition on Oct 28, 11 12:29 PM
Took a while to download but finally got it.

Wide Screen on my monitor which is a 22" worked fine.

Only one option

No voice overs, which I think would have added to the game.

No mad clicking penalty, tried it to see if would give me one, never did.

**** scenes are junk piles and at times difficult to find items. Not clear and crisp.

The hint charges very quickly, and moves you in the direction you need to go, plus tells you at the top of the screen.

Music was out of a bad spaghetti western. Just muted on my computer.

Took me forever to get through the first chapter. Not sure if it is because I'm slow or because the game might have some length to it.

Seems to be jerky through the game. It doesn't have a flow like other games. You swear you need that item, but will not let you pick up. But come back and whalla...pick it up. That bothered me. I'd just as soon pick it up, and then figure out later what I need to do with it.

Might get with a credit, but not the awesomeness of other games and not worth the CE price.

 posted in Guardians of Beyond: Witchville Collector's Edition on Oct 17, 11 11:58 AM
Downloaded game and said my trial version is over. Had not even tried it yet. I am running windows 7 64 bit. But often times, when my desk top will not let me try a game as with this one, it will run on my lap top, which is also running windows 7 64 bit. So something with my desk top, that my lap top has no problems with. Wish I could figure out what it is that is different.

I got the vault to open went in and found all the items. there is One left that is crossed off but is still hanging in the search box. Won't then I can't put the coil away. Any help? on what this old woman is doing wrong? I backed out of the game and reentered, didn't seem to make a difference. I hate being this close to the end and not being able to finish it.

 posted in Grim Tales: The Bride Collector's Edition on Aug 25, 11 10:20 PM
I also became stuck on the handle and the oil. Uninstalled and reinstalled 3 times, no luck. But the 3rd time, I changed my profile to a different name. Had to start over, but so far I have gotten past the oil and handle.

Hope this helps someone else.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator