Posts created by AliKat611

 
 
 posted in Incredible Dracula: Chasing Love Collector's Edition on Nov 5, 15 7:08 AM
I'm glad I'm not the only one confused. If I understand correctly, the boosters are on the right and the bonuses are on the left at the bottom of your screen. Either way, I use them all as many times as I can on a level and I haven't gotten that trophy either.
 
 
 posted in Delicious: Emily's Home Sweet Home Collector's Edition on Jun 29, 15 11:25 AM
I've never encountered glitches in any Emily game before, so I can be forgiving about the ones in this edition. What ticks me off is how long it's gone on. Why no fix to any of the reported problems?
 
 
 posted in Delicious: Emily's Home Sweet Home Collector's Edition on Jun 28, 15 11:19 PM
This has been an issue with this game since it was released on another site weeks ago. Some of the menu items (the french toast and espresso I think) aren't marked to give tips. Without that being fixed, no combination of menu items seems to work. Was hoping that would be fixed by now.
 
 
 posted in Gizmos: Spirit Of The Christmas on Dec 13, 14 9:46 AM
I've had the same problem with the cursor before. If you go into the game's settings there's options for wide screen or full screen (at least the previous gizmo games had this). I can't remember which fixes the problem, but try toggling those settings. It fixed the cursor problem for me before.
 
 
 posted in Gizmos: Spooky Adventures on Oct 28, 14 12:37 PM
Merkredy wrote:That 45&69 level problems are fixed on Big Fish Games version


Wonderful, Merkredy, thank you!
 
 
 posted in Gizmos: Spooky Adventures on Oct 28, 14 2:22 AM
I downloaded this a week or so ago from another site and 2 levels I know of (46 & 69) have glitches. The bottom row on each puzzle registers as a misclick no matter what you click on (one's a row of 20 and the other a row of 25 all filled in). There is a work around--just leave the rows blank and solve the rest and it will work, but I was wondering if it's been fixed. I tried 4 TIMES reporting it on that site and all they did was keep telling me to download new drivers and other stupid stuff that had nothing to do with the problem. If anyone knows if it's been fixed I'd love to download it from here.
 
 
 posted in Clutter IV: Minigame Madness Tour on Oct 15, 14 7:22 PM
That's what happened! Thanks!!
 
 
 posted in Clutter IV: Minigame Madness Tour on Oct 15, 14 6:15 PM
On the very first puzzle it says to click on coins and letters to move them out of the way. The coins work fine, but clicking on the letters does nothing. Makes it very hard to see anything since there are so many letters mixed in. Is this how it's supposed to be?

Also, on the second puzzle (with brick blocks) I have the same problem with the letters and now it adds in some square puzzle pieces (look like part flowers on them) that it said to click on and it's the same as the letters--clicking on them does nothing. I haven't gone any further than that.
 
 
 posted in Bella Design on Sep 29, 14 7:30 PM
$10 away. Doesn't make sense that I get everyone thru with full hearts and no customers were turned away and it's not expert. Frustrating.
 
 
 posted in Bella Design on Sep 29, 14 1:55 PM
Does anyone know how to get expert on this one? It's the first level the teenage girl shows up. I've tried and tried and the closest I've gotten is $15 short.
 
 
 posted in Statue of Liberty: The Lost Symbol on Aug 25, 14 5:55 AM
Is this really new? I feel like I've seen this before. Deja vu I guess.
 
 
 posted in Monument Builders: Alcatraz on Jun 25, 14 6:35 PM
I was getting that same message in level 23. Plus one spot of damaged road I was supposed to fix would just show up as "worker" when I highlighted it so I couldn't even fix it to finish the level. Hoping a reboot helps.
 
 
 posted in Deponia: The Puzzle on Apr 29, 14 5:21 PM
I don't know of any way to manually switch modes yourself, but I did make it to room 2 in the demo and in that room it was automatically drag & drop. The blurb info in the description does say play 2 modes, but it doesn't say choose which one, so maybe it just switches from puzzle room to puzzle room. Wish this had some kind of story with it. It's just a bunch of bizarre pictures that make no logical sense because there's no backstory at all.
 
 
 posted in My Kingdom for the Princess IV on Feb 4, 14 5:16 AM
FINALLY!!! It's been so long since the last TM was released I was about to cancel my subscription! I loved the first 3 installments of this game. Hopefully this will be a good one. Off to play!
 
 
 posted in Northern Tale 2 on Nov 19, 13 8:31 AM
Ooohhh!! I'm still a few stars short of opening that level. Duh! Should have thought of that! Thanks!!
 
 
 posted in Northern Tale 2 on Nov 17, 13 11:38 PM
I've finished the game and I was going back to get whatever achievements I'd missed and one of them is "feed the dragon." I can't figure out how to do that. I played each level with a dragon in it and I didn't see any opportunity to "feed" it. Anyone know what I'm missing?
 
 
 posted in Viking Saga on Jun 10, 13 11:28 AM
tinyzac wrote:hi fishies but chapter one has me puzzled can anyone help with building the druids hut? the stone pillar says i need to build it first but i only have two buildings available which are ahut and log house am i missing something ? please help oh by the way its chp one level 6 thanks fishies


tinyzac--it's under a different tab. The first tab is houses, the second is your industrial buildings, but then there's a third tab (has a lightning bolt thing on it if I remember correctly) where you'll find the druid's hut.
 
 
 posted in Outta This Kingdom on Mar 18, 13 3:07 PM
I found out you don't have to demolish the farms you build. As long as you demolish the original buildings it starts with, that's all it requires.
 
 
 posted in Meridian: Age of Invention on Feb 6, 13 7:56 PM
The game seems to be playing fine but the achievements are all messed up. I'm not getting all of the trophies I should have and it's showing that I've gotten trophies that there's no way I should have. Like how could I have the trophy for completing all levels in gold time if I'm not even halfway through the game yet? And I haven't built any university or planned a wedding and I have those, but I don't have the trophy for building a sandwalker which I've done. Weird.
 
 
 posted in The Tribloos 2 on Jan 15, 13 8:17 PM
Not all of my achievements are showing up. I've baked more than 10 loaves of bread, but it hasn't given me that flag. It hasn't given me the flag for fixing 10 pipes either. It did finally give me the one for clearing scrap piles although I had cleared a lot more than what it required. And so far it's frozen up on me twice.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator