Posts created by PatW47

 
 
 posted in Agatha Christie: The ABC Murders on Oct 30, 17 12:40 AM
bought it with a free credit, so glad didn't actually spend money on it. So boring! tossed it before half an hour of play, don't waste your money.
 
 
 posted in Lost Lands: The Golden Curse on Dec 22, 15 2:19 AM
Brilliant Game! Don't usually post in these threads, but I have so much enjoyed this game, I had to. Its a really long game, excellent value for money and I only bought the SE.
I am very happy with this developer, hope they make more.
 
 
 posted in Grim Tales: The Final Suspect Collector's Edition on May 17, 15 1:24 AM
i am having the same problem also!
 
 
Can anyone help me with finding the morphing object in this scene please!
 
 
 posted in Fright Collector's Edition on Jul 8, 14 1:13 AM
algal0181 wrote:THIS WAS BY FAR THE WORST GAME I HAVE PLAYED! It started off ok and then got worst as it progressed! Wish I hadn't wasted money on purchasing this one! If you haven't brought it...DON'T BUY IT!


I don't normally complain, but have to agree with the above quote, terrible game, slow and jerky, voices were out of sync, had to click on items 2 or 3 times for them to work,
I was glad when I got to the end!
 
 
 posted in Fright Collector's Edition on Jul 2, 14 12:33 AM
I don't believe this! I installed the update and started from the beginning with a new profile and it stuck on the inhaler again!!

Its very slow and jerky playing anyway, think I might ask for my money back

 
 
 posted in Fright Collector's Edition on Jun 30, 14 12:17 AM
this is happening to me too!
 
 
 posted in Angelica Weaver: Catch Me When You Can on Oct 8, 12 6:40 PM
Kegggie wrote:I also got the debug message when I tried to play again after buying the game.


Ditto!
 
 
Add me to the list of people stuck on this jewel, I have tried all the suggestions, nothing works
 
 
LakotaShaman wrote:I collected the second eagle eye crystal. Missed the first eye crystal in the jail, am unable to go back and collect the crystal. Is this a glitch - if so when will it be addressed. Don't want to start game over.


This is exactly what has happened to me, is there a fix?
Tried re-starting the game several times, doesnt help.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator