Posts created by Loren55

 
 
I'm having the exact same problem, chaddle21. I click on the jellyfish and the game hangs. I can get into the achievements page and the menu, but that is all.

Hello, anyone helping? I'm running a MacBook Pro using OS 10.9.5; there should be no problem. Can anyone help?
 
 
I cannot open the secret compartment in the elevator. When I click on it the screen dims and that's it. Like the previous poster, I have to click on the map to get out. I'm on a Mac running 10.6.8, and have an NVIDIA GeForce 9400 graphics card. Please tell me there is a way around this? Thanks!
 
 
I finished the demo and was starting the 3rd chapter at the end of an hour.

PROS:

The graphics were great though a little blurry (and I have a large screen and perfect eyesight).
The story was held my interest. At least it wasn't another 1) demon or evil being as the antagonist; 2) rescue my brother/sister/mother/father/aunt/uncle/cousin/grandpa; 3) disaster on a deserted island or in a series of underground tunnels and caves . . .
The voice-overs were good! Actual voice acting, not just some people reading words off a card.

So now the CONS:

To complete two-fifths of the game in an hour? It was way to easy and there was way too much hand-holding. We were told what we would need before we even needed it, so no brain-work was necessary.
There were sparkles. Sorry to sound snarky, but do we really need sparkles to tell us where to look? We can't search a scene on our own? Again, no challenge—even on the difficult setting with no sparkles, only a few clicks were needed to find the hidden object game within the scene.
This is a small thing, but the character's mouths stayed shut while they spoke. For a CE, the character's mouths should move, unless they're ventriloquists, lol!

It was an okay game—I would recommend it for beginners.
____________
I'm wondering if there isn't a way to grade the games for beginners, medium players, and advanced. Many others besides me would love a game that presented a real challenge. As another player mentioned, the old Myst games worked our minds —there were no sparkles, no hints, nothing unless one wanted to resort to a walkthrough. We really had to think for ourselves. Just figuring out what to do or where to go was in many cases a demanding task, and the mini-games were nearly impossible. I keep an old Mac so that I can replay them. That kind of game has been sorely missing from Big Fish's offerings. The only games that come remotely close are the Mystery Case Files games from Ravenhearst on (possibly exepting The 13th Skull).

Please, developers, make us some truly difficult games. You might find they are far more popular than you imagine!
 
 
 posted in Secrets of the Vatican: The Holy Lance on Nov 30, 11 12:36 AM
I really do try not to post a negative review, but . . . I downloaded the demo and played for an hour, and was reminded of several other games quite like it, where somewhat stereotypical characters slid in and out from the sides of the screen as they spoke, there was an unnecessarily complicated button system, many of the items in the hidden object scenes were horrendously small—and my eyesight is just fine!—and there was excessive hand-holding.

The gameplay was like driving an automobile with square wheels. There was nothing fun about this game (even the most educational of games can be made fun). If the company that made this game isn't out of business fairly soon, I'll be surprised. There's no way I will buy this game.
 
 
Just finished playing the demo and . . . I am sorry, but I think a CE should be well-written enough that I can't tell what's going to happen. Nothing was surprising, and I was disappointed. The story was so predictable I got bored, and that generally takes some doing. It was obvious by reading the diary pages that John was the good guy and Matthew was skewed; it was obvious that the girl had the demon in her the minute she said to get the bottle. *sigh* So much for that.

The music was good. The graphics were not excellent. The cursor was a bit sensitive at spots, but nothing I couldn't handle. Still, in my opinion this is not worth a CE stat, I don't care how many story-board sketches or wallpapers are provided with the game. The guide is no bonus, as the game was so easy it was not necessary. I might look for this as a daily special, but not even as a SE. Sorry, devs, this one didn't make the cut.
 
 
 posted in Escape Whisper Valley on Sep 21, 11 12:52 PM
Just downloaded the demo and can't get started . . . in order to play, I must enter a player name and when I try to, nothing happens. I checked to make sure it was a Mac game for my Mac, lol, so don't have a clue what I am doing wrong.
 
 
 posted in Grim Tales: The Bride on Sep 15, 11 2:12 PM
I have played both the CE and SE demos for this and loved it so far as it went. I played on the intermediate mode (not easy, not advanced), and found the puzzles easy. The graphics were lovely, the sound effects well done, the music added to the atmosphere.

BUT after having read the reviews here about the ending being so incredibly unsatisfying , I have decided not to buy this even on sale. As a writer, I like stories to have endings—there must be resolution! Sorry, BFG, I'll spend my $7 on a different game some other time.

I am glad for those who did enjoy it. Good gaming, all!
 
 
 posted in Luxor: 5th Passage on Jul 29, 11 1:40 PM
I love the Luxor games—there isn't much by Mumbo Jumbo I don't like —but this one is so disappointing I don't know where to begin.

I downloaded the trial version last year and even though I have a new, fully loaded Mac which exceeds all system requirements for this game, right-clicking (which can also be done by control-clicking) would not change the colors of the balls but rather gave me a pop-up menu. I commented on this on the technical board and watched, but there were no responses to my problem, or to any others.

So here it is seven months later and I thought I'd try it again. Imagine my lack of surprise when right-clicking still does not work.

If in seven months Mumbo Jumbo could not address this small problem, I'm not buying the game. I have Luxor, Amon Rising and the first three, so I don't need this buggy game anyway.

Hope the rest of you fishies have a great day gaming!
 
 
 posted in Midnight Mysteries 3: Devil on the Mississippi on Jul 5, 11 12:15 PM
WARNING! CONTAINS SPOILER!

I just downloaded this and played it last week (been stuck on a rock waving my tentacles so couldn't get here right away). The minute I saw it was by Mumbo Jumbo, I knew it would be a good game. All the scenes took part at night (so far as I rememer) and the graphics were a bit fuzzy , but there was more animation than in most games, which I did appreciate. The characters were appropriately aggravating or helpful, and the story behind the game was fascinating for those of us interested in the controversy regarding Shakespeare's authorship of his works.The hidden object scenes were few and far between which in this case I did appreciate; there wasn't an incredible amount of running back and forth, but considerable thought was needed to get through the game without help. I enjoyed the music as well.

The only part that I didn't like was the faces of Twain's children. Their expressions ranged from bored to down right creepy. These were kids, and their only roll was to whine if you didn't have a tea party with them? Otherwise, outstanding. The game took me ten hours to get through (I was very tired and played in three blocks of time), so I consider it well worth the $6.99 I paid for it.

Now I'm just saving up my credits so I can by the next CE from Mystery Case Files!
 
 
 posted in Haunted Halls: Green Hills Sanitarium on Feb 1, 11 9:47 PM
I got the roses in the lobster mausoleum, brightened them up with paint, and gave them to the doll in the woman's childhood toy room. But I didn't know I was supposed to spray them with rose oil in the mausoleum to catch the butterfly . . . now how can I get the butterfly for the stamp? I'm stumped! Thanks.
 
 
 posted in Luxor: 5th Passage on Dec 4, 10 1:56 PM
Control-click does not work for me to change the marble colors (I have an Intel 2 Core Duo Mac running at 2.66 GHz, with OS 10.5.8 and a plain mouse without buttons). Control-click has always worked for me before. I would love to be able to get somewhere with this game, but playing it without changing marble colors is discouraging as I have arthritis in my hands and can't move *that* fast!
 
 
 posted in Twisted Lands: Shadow Town on Dec 4, 10 1:40 PM
SPOILER ALERT!!! SPOILER ALERT!!!


Graphics were good, some of the scenes were dark and the objects difficult to see, and the storyline was good until the ending, which made absolutely no sense to me whatsoever:

They were on the boat, he showed her the statue he'd brought up from the ocean floor or whatever, and everything goes dark. We're lead to believe the boat washed up on shore, but at the end we find he was dumped overboard and *just happened* to wash up on shore right next to the boat? And evidently he's dead the whole time, and rotting? And then at the end she kills him again? Having conveniently carried the knife with her the whole time? Even if there is a sequel, the writers are going to have to work hard to make anything intelligent of that ending.

Then there was the information in the book in the house about the tree which caused a fog that killed small animals and even humans, and on the way the humans could experience hallucinations. So I spent a large part of my time wondering if the guy was hallucinating parts of the story . . . if he hallucinated the ending, *that* might perhaps make a little sense. Also, when he looked out the porthole on the ship he saw some dark foggy shape, which was never explained. Some of the graphics were nice but never used, like the moon through the telescope. I like all the loose ends tied up; all the things in the game should have a meaning or a purpose. Good writing in the beginning can make for a very good game in the end. Just my opinion . . . :-)
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator