Posts created by Poof11

 
 
 posted in The Otherside: Realm of Eons on Dec 6, 09 1:23 PM
Just finished the demo, although the graphics are great (wish all game makers would do this) this game was way too sloooooooow for me. Too much dialogue. Some of the items did not look like the actual item you were to find. I was better off hovering my cursor over the item and finding out what I was to look for, if I couldn't figure it out from the picture. One item looked like the tip of an arrow and here it was rebar that I was supposed to be looking for.
Anyhow, I won't be buying this one. As others said, it may be great for the grandkids, etc. I may give it a rethink when my neices are around.
 
 
 posted in The Dark Hills of Cherai on Dec 5, 09 10:23 AM
bribling wrote:Gorgeous Graphics got me to try this despite it's huge size. The endless Hint renewal Kills it for me. I find List items difficult to see.

Also, I am finding the butterfly annoying. It stays there flapping, I click on it, get a message and it is still flapping. I click on it and get the same message. It does not stop flapping or go away. How do I know when it has something else to tell me?

I find the visual problems I have along with the endless loading of Hints a killer for me. I love the graphics, am intrigued by the story but sorry, "No Sale!"


I beta tested this game and told them the same exact thing especially about the ANNOYING butterfly. Once you clicked on it and got the information, it should stop fluttering and blinking. I also thought the objects that you were to find were the most difficult to see. I didn't think this would do well if they didn't clean that up. I also thought that the grandma looked like a dude dressed in drag....haha...jmo.
Another writer said they couldn't think of the second mislabled item, it was a chisel that you were looking for which turned out to be a perfume bottle.
Knowing now that the things that I didn't like about the game are still there, this is definately a no buy.
 
 
 posted in Real Crimes: Jack the Ripper on Dec 3, 09 3:14 AM
Yet another night unable to . Just finished demo and those of you who like the choice of timer or no timer will be glad to know that you are given a choice. I wish they would have given you a choice for the pointer since the knife is just a bit too large and you can hit the wrong items at times. Be careful what you click on since you lose 10 seconds for each wrong click.
Graphics were okay, nothing special and a little blurry in some parts. You need to find 5 fingerprints at each scene which give you extra time in the scene and a badge for extra hints. These items are very well hidden of all different sizes. Don't try to save up all of your hints since you lose them at the end of each case. There are some items which were unfamiliar to me that I did use the hints on (ex: budgie: small bird [should have know this from EastEnders])
The story line is good and you can always quickly click past some of the dialogue. Couldn't tell you about the music since I always mute that...sorry.
I'd say 2.5 stars out of 5. I won't be buying right now but will put it on my possible list for the dry season.
Enjoy friends and have a Wonderful Weekend.... Cheers
 
 
 posted in Find Your Own Way Home on Dec 1, 09 2:48 AM
Since I couldn't , I decided to play, just finished the demo and it left me dissappointed . The graphics are very blurry and grainy, began to hurt my eyes. From what I played the game could have been very enjoyable if not for the bad graphics.
The take the picture scene was the most difficult imo since the scenes that they provide are very dark images but you can hover over the image for more of the image (which I figured out too late). I ran out of time on the first try and only made it on the second try since I already knew where some of the pics were and that is as far as I had gotten, I think level one part 5 maybe.
The scene where you have to find items in the order listed can be a little tough trying to get the open windows (click, hold, drag) to move to find the hidden items.
I also didn't get the hint system (maybe I am too tired) but during the levels it told me I had earned at least two of the different hint types but only one was showing.
If the creators upgraded the graphics, I would definately consider buying especially since the game seems like it has a long game play but until then it is a no go. Sorry friends but this is a .
 
 
After reading about the technical issues, I was a little hesitant to buy but I just couldn't wait any longer and had to treat myself (particularly after cooking all day and killing my back....ugh ) Anyhow, the game was going great until I reached the point I had to remove the lock at the museum with the bolt cutters....as soon as I did that I got the dreaded black screen. Luckily, I did not get the access violation as others have. I decided to immediately restart my computer and start the game up with my fingers crossed. Lo and behold my game was saved right at that very point. I continued on and had the same exact thing happen when I put the soap powder in the washing machine, much later in the game. I restarted and was able to continue on and finish the game.
My suggestion to those who are getting the windows not responding issue, try the restart and see if that helps to not lose all of your progress. Who knows maybe it will work for you. Good luck all....Happy Gaming . I hope you all had a wonderful Thanksgiving.
 
 
Well I really have to hand it to you, I cooked all day yesterday, was exhausted but played this game straight through. I managed to get all the achievement awards. I had a lot of fun....Great Game Well worth the money and the lack of sleep..... love it...keep up the great work! Can't wait for the next one.
Hope you all had a wonderful Thanksgiving.
 
 
 posted in Escape the Museum 2 on Nov 18, 09 5:35 PM
I was able to click open the map and click on the areas that had exclamation marks and searched, if I found nothing, I clicked on the area directly after the exclamation mark and found what I needed. Once you complete that the exclamation should disappear and your stars for that area will upgrade. I hope this helps.
 
 
 posted in Ghost Town Mysteries: Bodie on Nov 15, 09 4:52 PM
Wow....What a disappointment! This game could have been really good with the storyline and all but fat chance. First the game runs really slow. Second, the graphics are so grainy objects are very hard to see. I was up on top of my monitor at times. Also, some of the objects are at the edge of the screen and you can't quite make out what it is without using a hint (something I really don't like to do). It takes some time between picking up objects, so if your a fast clicker forget it. The tombstone minigames were frustrating. When you didn't want the object to turn, that would be when it turned. The game developers should have used the right click to rotate the object if needed. Also, instead of going back to the map each time, why couldn't they have just said complete and take you to the main location. And what was with the going to the church for nothing.....filler? They could also get rid of the whole key thing. Once you have the key that should be it, open up the next location, instead of wasting time having me put the key in and showing me the door unlocking. The game seems more like its based on putting together the tombstones and the **** are the minigames. Very glad my demo was over. Don't waste your money.
 
 
 posted in The Dracula Files on Nov 8, 09 11:32 AM
This game was boring , if the Eagles/Dallas game was on earlier, I wouldn't have wasted my time!
If you are going to play you need to remove the cursor but if you are like me the cursor will still reappear on its own, giving me two cursors, which really slows down the game. Also deselect the graphic.
The game is way too dark. The storyline needs a skip section.....you can click all you want but that storyline is not gonna move forward until it is ready too. Some objects you can click on forever before it actually recognized that it is the item that you needed.
I also had problems the first time I tried downloading this morning. My computer froze and had to restart. The second time worked though and was much faster.
All in all, if you can't sleep and need something to help....Try this game....it should do the job.
 
 
 posted in Legends of the Wild West: Golden Hill on Sep 29, 09 8:36 PM
Well, I played the trial and all I can say is, "Ehhh." Nothing to get excited about. Anyone who has vision problems, this game is NOT for you, unless you get out the magnifying glass. Some items are very well hidden and blend in with the background or are just so small that it is difficult to make out what it is.
I agree with the others on the spelling issue, I had one which was cockies. My original thought was maybe it was cockles then I finally figured out it was supposed to be Cookies. Now that is pretty bad when it comes to the spelling issue. I'm sure there were others but I guess I am becoming so accustomed to the developers not really caring about the translation or basic spelling errors that I have learned what they really want. (I really hope my spelling is correct in this message...lol )
I also was not a fan of the inventory bag and hourglass contantly blinking at you even if you didn't need to use your inventory in that particular scene. Okay, I know where it is if I need it, enough already.
This definitely isn't a game that I will run out to buy in any hurry. The free hour was enough for me.
 
 
 posted in I SPY™ Fun House on Sep 1, 09 10:51 PM
Patty60 wrote:
reneesenn wrote:The game has a lag for me as well. I still can not find the "face without a nose" in the trailer. This game seems to have no story line which gives me no desire to buy it and finish it. Maybe people with kids will love it.


It's a clock somewhere in the middle of the frame.
 
 
 posted in I SPY™ Fun House on Sep 1, 09 10:50 PM
nancymc wrote:Went and bought the game, finished the ticket stuff except for the horses rear-end, haunches---since I live on a horse ranch you would think I would be able to find it--the leg, hip and all that stuff.. used the hint, still can't find it---I have worn my mouse out clicking on every thing on the right side---ha,ha of course.. PLUS even with this ticket I'll only have 10 tickets---gone threw the game several times and have not found the 11 one---guess I'll wait for Margos--walk-through..This game is on the tricky side--you-all Nancy


Did you try the gumball machine? I missed that one the first time around. It is in the second section where the car and trailer are.
 
 
 posted in I SPY™ Fun House on Sep 1, 09 10:48 PM
lisa4862 wrote:I never keep the sound on so the voice isn't bothering me! I also wish there were hints available, but otherwise, it's a cute game.

Can anyone tell me where the dot to dot star is please...it's in the clown's dressing room scene.

Thanks.


It is in the lower right hand side inside an umbrella. Once you click the balloon, it will connect the dots to make the star. Hope this helps.
 
 
 posted in I SPY™ Fun House on Sep 1, 09 10:46 PM
First there is no menu. Second, there is no options for the sound & music volume (which I personally don't like to listen to the background music). Third, that annoying voice. Hearing the riddle repeated over and over or just when you pick something up....eck.
I realize that this game may be for kids, but even a child could use a hint every once in a while. And that question mark shouldn't even be at the top of the page if its just gonna repeat over and over how to play the game. I think you get the gist of it once you start.
Well, I guess you can tell I won't be buying this game....big thumbs
 
 
 posted in Relic Hunt on Aug 23, 09 11:13 PM
I have to agree with everyone on this game. Not only did it take longer for the game to load than it did to complete it but there were many issues with this game that a standard **** normally has.
1.) Ability to mute the sounds or at least turn them down (I'm not a fan of the music - usually have the TV going while playing a game.
2.) Inability to change the cursor...what was with that sword? I thought it was very awkward. It drives me nuts when you are clicking on an object and you have to do it like 20 times before it recoginizes it.
3.)No pause....if you hit the menu key midgame - it took you back to the main screen. Although you were taken back to the level you were playing you had to restart.
4.) Terrible english (I know I'm not the best but).....some of the words were even missing letters.
5.) Find the difference - why can't they just have you point to just one of the pictures instead of having you jumping back and forth from each scene?
I'm sure there were other things that I forgot but that's my review.
I did finish the game in less than an hour so I guess I should that BF for the freebie .
In my opinion this was a real stinker
Hey....now I'm a Seahorse....Yeah
 
 
 posted in Delaware St. John - The Curse of Midnight Manor on Aug 9, 09 5:34 PM
lauder wrote:I got game 2 play but there is no way 2 leave game and all I show is a arrow and walk around with the arrow doing nothing, plus nothing in the menu area. I am glad that they let us download 2 test game as I think this game might not be capable with my computer.


If you hit the small green square in the bottome middle of the screen it will bring up the exit, options, etc. menu. I just happened to find this since, I was getting very frustrated going around in circles.
 
 
 posted in The Legend of Crystal Valley on Jul 13, 09 7:34 PM
I too have had the same problems with the game as others . My first game play, I was able to play through to the horse statue and was suddenly kicked out of the game. When I went to return to the game, the game wasn't saved and I could only get to the beginning scene (farmhouse) and was kicked out of the game.....thanks for playing .
I decided to do a check on the internet to see if other sites/forums were talking about these issues, etc. and found at another site that the creators, Cateia games, had left a link to their forums to contact them directly, about any game problems. I know that many of you are frustrated and waiting on the rebuild, maybe if we all contact them they'll be a little swifter in getting the kinks out. Good luck all.
 
 
 posted in Department 42: The Mystery of the Nine on Jul 11, 09 8:00 PM
Take the ladder and click in at the right side of the house (I had to do this a few times before it finally clicked in) then at the window on the top you'll see a little icon change, click on it and then the roots will come up and cut them off with the magical knife and put them in the pot.
I hope this helps.
 
 
 posted in Magic Encyclopedia: Moon Light on Jul 7, 09 10:56 PM
Margie B.....Thank You! Thank You! Thank You! I was going crazy trying to figure out which gem stone that I missed. When I finally read your post for the LABYRINTH (OUTSIDE) I was completely missing the blue dice on the left side of the wall, to the right of the large statue. It blends in with the blue part of the wall. It really did blend in...took me a few glances to finally notice it. But thank you once again, I was finally able to complete the game. Your the best! Cheers!
 
 
 posted in Margrave Manor 2: The Lost Ship on Jul 6, 09 12:46 AM
I'm not quite sure which game version I downloaded but I did notice that about half way through that the find the difference scenes would have umpteen differences but you had to click on any and all to actually figure out which ones the game was asking for, very frustrating ....It got to the point where I loathed these scenes. I also noticed at about the same point into the game that some objects were not being recognized no matter where you put your pointer on it. If there was another object directly in front or beside it then at times by removing that item it would finally recognize it...otherwise, you just had to keep on clicking at every angle possible and I hate having to use hints, paticularly when you know you have the right object.
My version, had extremely long waits to load, and between each scene. I did finish the game but was just frustrated with the above glitches.
All in all, with the glitches to be fixed, if you want a game that will last you a good part of a day it is well worth buying.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator