Posts created by mizzdeecee

 
 
 posted in Haunted Legends: The Bronze Horseman on May 25, 12 11:59 PM
I have got the pin. I am in the correct place according to the walk thru. I am supposed to put the pin in a certain place, but it won't allow it. I am at a loss. Have I missed something? I can't move on at all. Help! Pleasee!
 
 
 posted in Mystery Legends: Beauty and the Beast on Jan 6, 12 10:42 PM
This game was okay. The graphics are very nice.... beautiful, if you will. It was not particularly interesting because there was really not much interaction. I found myself wanting to 'move on'. The biggest problem I had was the curser was very 'sketchy'. I mean itat it would not hold onto anything and 'floated' around. I found it very tiring. I have found that in some other games and in the future, if it is that way in the pre-purchase hour, I will not purchase. If that is not a problem, then the game is satisfactory.
 
 
To put an object down you must right click on the object.
 
 
crabbycat wrote:Picked up some sort of stick on a desk and was unable to put the thing down....up til then this was a fun game. No problems downloading and was able to exit out of the scene I was in, but not sure if I will buy this as a CE or wait til SE. I found it a bit confusing...
 
 
 posted in Urban Legends: The Maze on Sep 18, 11 4:13 PM
Game loaded fine.... am only playing demo before purchase. Now am stuck on a window and there is no option to get out of window.... Sometimes these games make me crazy!
 
 
 posted in Vampire Saga - Welcome To Hell Lock on Jul 16, 11 9:08 PM
I downloaded the 1 hour trial. I got a page of what looks like an old town and a gate to the town, but nothing more happens. All there were is leaves moving across the page. There was no option to go to MENU, nothing. The only way to get out of it was Control, Atl, Delete. I restarted computer and same thing happened when I tried to play the game. Am I missing something? Game Manager says I've used ten minutes of game play. Actually I've played no game. Suggestions?
 
 
 posted in Treasure Seekers: The Enchanted Canvases on Apr 18, 11 9:10 PM
...addition to last post. The first 'puzzlel' was to match butterflies and find the one that was left. There were no butterflies - just some flowers. None matched. I finally let the 'skip' button run out and got the butterfly. So far, I am not pleased with the game at all. I hope it gets better. How did you folks get the game for $2.99? I paid $4.99 and wish I'd not paid that.
 
 
 posted in Treasure Seekers: The Enchanted Canvases on Apr 18, 11 9:05 PM
I bought this game and find it very problematic. For one thing..... the 'hint' button give no hint at all. But it does 'use up' and then recharges. I wish I had tried the free hour first because I would have never bought it.
 
 
Redhawk113 wrote:I can't seem to get the smelling salts to work on the coach driver???
 
 
 posted in Incredible Adventures of my Mom on Nov 20, 10 11:21 PM
Got the spices in the pot but now can't get the olive oil to go in. I suspect that I must remove the lid from the bottle of olive oil, but for the life of me - I can't figure out how to do that. I also mixed the fancy cocktail but then the cocktail disappeared. I'm hoping it will reappear once the 'potion' is complete. Anyone have any ideas about how to get the d*** olive oil into the pot? Other than this frustration, it's a fun game.
 
 
 posted in Dream Chronicles: The Book of Air on Oct 16, 10 9:36 PM
I am having same problem: last object on water balance scales will not balance. Have tried all the options and cannot get the last object balanced. In my opinion, this is the worst game yet. I have had to go to the forum on almost every segment. The puzzles are impossible. I do not recommend this game at all. I want to finish it, but it looks as if I will not be able to. I give up!
 
 
 posted in Mystic Diary: Haunted Island on Oct 9, 10 8:36 PM
Where do I find the clock hands?
 
 
 posted in Reincarnations: Uncover the Past on Oct 8, 10 9:50 PM
You have to go back - take the scroll to proper place to get the code. I'm stuck tho. Can't seem to make the code open the door.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator