Posts created by tiasnana

 
 
I beta tested this game and have been waiting to be able to buy it. I loved everything about it so I will be buying this one today.
 
 
 posted in Youda Legend: The Golden Bird of Paradise on Jan 3, 10 12:40 AM
I had the same problem. It stalled my computer, then when I was able to get it to go, after only about 5 minutes, it said my trial time was up so I never got to try it. Guess I won't be buying this because I don't like to buy it unless I try it first.
 
 
 posted in I SPY ™ Spooky Mansion Deluxe on Nov 20, 09 5:21 PM
I bought several other I Spy games for my grandson, but don't think I'll buy this one. On the demo, I just got tired of waiting for the pages to load. It was worse than watching paint dry. Don't know about the kids in your family, but ours would just click out and go to another game. Sorry, but it just isn't something I think the kids would like.
 
 
 posted in Elementals: The Magic Key on Nov 3, 09 4:27 AM
It shut down on me several times, and I have everything updated on my computer. I finally just decided to uninstall it until BF has worked out the bugs. Too bad because I might have bought this one.
 
 
 posted in Coyote`s Tale: Fire and Water on Jan 29, 09 2:42 AM
I thought this game was a real mess with a lot of glitches. I was playing the timed mode and it was continually hanging up. I only played for about 15 minutes and got so frustrated I didn't even want to finish it. I had to use the task manager to leave the game.
My computer is up to date and I checked to make sure it had everything to necessary to run the game. I've never had this problem with any other game from BF. I sent a note to customer support, so if they do a new version, I'd like to try it again and maybe even buy it. For now, I had too many problems to actually know if it's a good game or not.
 
 
 posted in Haunted Hotel II: Believe the Lies on Jan 4, 09 12:34 AM
I doubt I'll buy this game because I'm having such a hard time playing the demo. It wouldn't allow me to click on any of the objects in the professor's room, and when I closed out and came back in I was at the door with the key card but nothing in the inventory or list. The hints kept telling me to find a clue in the room, but couldn't get into the room. I've spent most of the 60 minutes going out and coming back into the game. When I first went into the professor's room there was nothing in the list, so had to go out and come back. Really don't have an idea if I'd like this game or not because I can't play the demo. I see a lot of other people with the same problem, but don't see anywhere BFG has given us a solution. I have a new computer, meets all the requirements, keep my computer cleaned up from adware, everything updated, so it has to be the game since so many are having the problems.
I buy a lot of games, but don't think it will be this one unless they get it fixed in a hurry.
 
 
 posted in Mystery Stories: Berlin Nights on Nov 15, 08 3:34 AM
Having a problem in the penthouse and need help. I know the pigeon needs to go onto the spike and I get the hand on the pigeon but it won't let me pick it up. Anyone else have this problem.
 
 
 posted in Zoo Vet 2: Endangered Animals on Oct 8, 08 11:55 AM
I've been having a lot of problems with this game since I bought it and would really like to know if there are still bugs in it. On several animals it will say to use a specific instrument, but the instrument isn't highlighted at the bottom making it unusable. On the mother elephant, it says to take the temperature in the feces and it wouldn't let me do it. I had to go out of that screen and come back in to be able to use the feces. I did send a note through to customer support but still haven't received an answer.
Has anyone else had this problem?
Thanks,
Yvonne
 
 
 posted in Zoo Vet 2: Endangered Animals on Oct 8, 08 11:51 AM
I'm having the same problem and I did use the save option on the main menu. I sent a request through the contact support feature but still have not received an answer. I tried several times to use the save feature but it doesn't save the game and I have to start all over each time I go out and come back. I've checked my computer, it's new, and have all the requirements specified.
Any help would be appreciated.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator