Posts created by sw0p

 
 
I downloaded the game for the first time after the update for Mac was done.
Still I have the tent issue which is disappeared before be able to glue the swan.
 
 
 posted in The Beast of Lycan Isle Collector's Edition on Nov 25, 12 4:45 AM
Opening the game did not give full screen mode but next to the screen a flickering screen. Also I had to put the cursor 2 centimeters above what I wanted to do.
 
 
bfgBaikal wrote:Hi Mac Fishies,

Quailridge and sw0p - if your game is not opening for you it may mean that your computer is having trouble running it. To combat this, I would suggest having a look at the following help article to update those elements that run your game. The following help article will help you do this:

<a href="http://bigfishgames.com/help/index.html?rn=166"> Game Crashing, Freezing, or Blank Screen </a>


All my software Mac, Adobe Flash+Shock is completely up-to-date. I will send a DrFelix report.
 
 
Quailridge wrote:I tried to download using the latest OS version. All my apps are current and as with other Echoes of the Past games, all I get after download is "Time is running out, 60 minutes left to play" and the game will not open. I have un/reinstalled Game Manager, turned off Firewall and still nothing. One would think this error would have been fixed a long time ago. If anyone has any suggestions as to how to get even the Trial version to run, would love to hear. I know that if the Trial Version won't run, don't buy it because the purchased version won't work either!

Sue.


I have the same issue as Sue.
 
 
 posted in The Keepers: Lost Progeny on Jan 16, 12 11:12 AM
Tried the MacVersion today. When I try to zoom on the door of the house at the right after seducing the dog, I get the message that an image can not be found. Game looks like to continue but the pointer acts strange (the total path of the pointer is on the screen.
 
 
 posted in Lost Souls: Enchanted Paintings on Oct 9, 11 12:42 AM
In the Mac version I get the hall as completed at the moment I take the 4th star. However you need 5. So the game is now stuck.
 
 
 posted in Redemption Cemetery: Curse of the Raven on Sep 19, 10 8:42 AM
Same problem with safe with playing the Mac version. Email to BF did not give a solution.
 
 
Same here - with a Mac crashing when touching the save. Did already send an email to TechSupport but no answer yet.
 
 
 posted in Victorian Mysteries: Woman in White on Sep 17, 10 1:52 PM
In my first try of the game the hammer disappeared from inventory when entering the secret passage - I only had the acid left (forgot to use it). Second try with another profile - I used the acid and now the hammer was still in my inventory after passing the secret passage.
Issue was first posted as separate topic and closed with remark - check your videocard etc. In my opinion a non relevant answer for this issue.
 
 
 posted in Victorian Mysteries: Woman in White on Sep 17, 10 8:54 AM
The hammer disappeared from the inventory after going through the secret passage. Another bug??
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator