Posts created by grammakim

 
 
 posted in Mystery Heritage: Sign of the Spirit on Nov 17, 12 8:07 PM
I reached the level where I gave the instruction book to the magician and found the dead assistant (Luther) under the stage. Now there is no way to progress. Can't use any of the inventory items anywhere. I have gone back to every scene several times and every time I push the hint function, it says "there's nothing to do here". No HOS to be found anywhere!
 
 
 posted in Entwined: Strings of Deception on Apr 8, 12 1:50 PM
I had the same frustrating experience with the fingerprint puzzle. When you have it all lined up (Charles' print) and it doesn't work, try flipping completely over. Then just make very small adjustments (take your time) and you'll be able to see it trying to capture. Happily, it worked for me. Good luck!
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on May 31, 11 9:08 AM
I am having the same problem...very frustrating! Also am stuck on the telephone. Can't light up all the lights and there is no "skip" option. Although I like a bit of a challenge, this is getting ridiculous! Would also have preferred having a "hint" option.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on May 30, 11 10:55 AM
I am stuck...is there a walkthrough available yet?
 
 
 posted in Mystery Case Files ®: 13th Skull ™ on Feb 22, 11 6:17 PM
It worked...thanks!
 
 
 posted in Mystery Case Files ®: 13th Skull ™ on Feb 21, 11 3:10 PM
I am also stuck at the piano side panel. My screwdriver will not remove the screws. I've tried several times and just get the message "that won't work here"
 
 
 posted in Victorian Mysteries: Woman in White on Sep 19, 10 10:30 AM
I have uninstalled and reinstalled this game. Still stuck in the graveyard-gate won't open.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator