Posts created by ElisaRol

 
 
 posted in Nancy Drew: The Captive Curse on Apr 13, 18 6:35 PM
In my second attempt at this game, the game did not follow through with the "second monster sighting". On my third attempt at this game I switched to "junior detective" mode so that I could get the clipboard checklist, but this mode did not let my character go out into the woods to collect the flashlight. I need the flashlight in order to inspect the well and get down into the secret passageways.

There must be technical flaws that are preventing my character from fulfilling the steps.

Disappointing.
 
 
 posted in Nancy Drew: The Captive Curse on Apr 11, 18 9:26 PM
According to the video walkthrough there's supposed to be a second monster sighting after speaking to Anya. My character has wandered into every room and passageway including the forest at the end of the tunnels underneath the castle and my "Nancy" is not receiving the 2nd cell phone call that's supposed to tell her that the monster is in the glass furnace.

 
 
 posted in Ancient Rome 2 on Oct 26, 17 11:54 PM
I have done level 30 3 times and it always quits once I get 8 out of the 30 top level houses. The game quits on itself and then if I re-start the game it doesn't remember the cities I "built" and starts from the beginning.

My pet peeve with this game is that each level takes 2-3 hours so I can only play it on a "day off" from work because I can't leave the game and come back to it later. It won't save the "play-work" I've done.
 
 
 posted in BRIDGE CONSTRUCTOR: Medieval on Aug 10, 17 8:34 PM
There isn't really enough instruction at the beginning of this game. Am I already supposed to be an engineer in order to play this game? I thought there would at least be some elementary concepts given at the start of this game in order for me (a non-engineer) to understand at least some basic concepts of what I'm supposed to do. I'm still in my "free hour" of this game, but I will probably not purchase it.
 
 
 posted in Nancy Drew: The Captive Curse on Sep 3, 15 11:36 AM
I am enjoying this, but I find the puzzles insanely difficult to do. I'm on the box with the 10 rows of coloured dots. I have no idea how I'm going to finish this. I need more hints than what is given even in the "Junior Detective" mode. I'm finally not getting so lost as I was the first few days I was playing this, but I would appreciate an interactive map like there is in other mystery games. The coloured dots re-set themselves if I leave that puzzle and come back to it. This is VERY HARD. It might be a long time before I reach the end.
 
 
 posted in Green City 2 on Mar 2, 14 7:21 PM
I am getting everything built by the end of the gold on the timer, but this level is not recognizing the 2 houses at the back of the screen as meeting the 2 suburban house tally. If I build the 2 houses at the front then there is no room for the park which I need in order to get the "green" score.
 
 
 posted in Rooms: The Main Building on Oct 21, 13 8:40 PM
This is the most beautifully drawn game I've played with BigFish so far. I love the "Harry Potter music" as well. It is very pleasant to play this game. Most of the games lose me with poor music choices. I normally turn down the music of each game and keep the sound effects only. This music is much nicer. I like games that allow me to relax and figure out a puzzle rather than getting stressed out after a day at work.
 
 
 posted in Westward IV: All Aboard on Apr 12, 12 9:11 PM
I'm responding to myself but I figured it out. It took about 100 tries, but I did it.
 
 
 posted in Westward IV: All Aboard on Apr 11, 12 10:38 AM
I'm stuck on Haverbrook. I can get through the first wood and coal task fine, but I can't get through the second task of 600 gold and 60 food. I've tried many things including blasting the rocks at the top left corner and building the bridge across the river. I can get up to 13 people to help, but I haven't been able to get more of them. Demolishing the sawmills after the wood/coal task doesn't seem to help and the upgraded sawmill doesn't seem to make much more wood even fully staffed. Also, the mines keep collapsing even after I bought the fortification at the upgraded sawmill.

I did one where I was able to get the hat to the merchant and trade stuff for more gold, but I still wasn't able to get enough gold.

I did demolish the hat shop, clothes shop and bakery which helped, but it only gets you through the first task.
 
 
 posted in Plan It Green on Jun 15, 11 10:47 AM
I have done the "try-it" hour for this game. I like the general concept. However, the time allotted to complete the tasks seems impossible to achieve.

I just want some reassurance before buying this game that the tasks are possible to complete with some strategy learning.

I got to the level where you have to re-model eco-shops and build eco-homes. However, you have to wait until enough income is generated from what you've built. I tried that level 3 times with different ways and I couldn't generate income fast enough for the clock.

I don't want a total game-spoiler. I just want some success stories before buying this.

Thanks
 
 
not getting the second cave riddle. I got the first one, but I'm stumped on the second. I have the alphabet in the case book, but I can't guess what the word should be. Maybe I'll get it tomorrow.
 
 
VenusHun wrote:
klinkie wrote:I have done everything to start the generator, but it doesn't make any noise. Is it supposed to? When I go try to hook up the cell phone, it doesn't let me, so then I go re do the generator.
Very frustrating. What am I doing/not doing?
thanks!




[/b]SPOILER

ok to start the generator you have to do it in this order

1. attach the spark plug to the wire
2. click the green switch on the left side of generator
3. just under green click silver switch to the up position
4. push the red button 4 times on right side of generator
5. pull the handle at the top down twice
6. pull the other handle to the side 3 times.

you will know it started when it kicks you out of the scene and you are looking at the generator with steam coming out of it.

to get the phone charger to go you have to click on the outlet to get a closer view, then take the charger and click it on the outlet.

if you need a closer look at the generator instructions, look in your journal, it will have the directions in there from when you found them.

good luck



I have tried this several times and the generator hasn't started for me. I'm stuck.
 
 
 posted in Victorian Mysteries: Woman in White on Sep 22, 10 12:44 AM
Generally a good game. I really like soft piano music in games. I read the novel "Woman in White" and the game keeps the spooky feeling of the book. My one complaint is that the game doesn't always remember where you were if you exit and then re-join the game again. That is frustrating especially if you have a job, a family or a life of your own.

I started it a second time under a different player name and finished the whole thing in one sitting which took me a longer time, but at least the game didn't lose my place.

My advice is to play the game on a weekend.

To the makers of the game, it needs better game-memory.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator