Posts created by AnnaGP

 
 
 posted in Gummy Drop! on Feb 2, 17 2:01 AM
I am also not enjoying Seoul. Very hard and very expensive. 64-1(particularly vile as practically no green gummies!) and 66 have taken nearly all the hard earned cash I managed to earn in weeks of playing. I had to use boosts and extra moves, plus many, many attempts. Disproportionately resource sucking and almost no fun. Would be nice to get some real help not feigned commiserations and a recitation of the level of which we are already aware. Very frustrating and disheartening. I spent easily 1000 gold coins on those two levels plus having to buy resources in the misnamed "helping hands" and still don't have enough to build monument at 70. From the looks of the comments here, it seems that the suffering is going to continue. Not sure that I will.
 
 
 posted in Gummy Drop! on Jan 22, 17 4:46 PM
I too have found this level impossible and a blackhole for boosts, thus money earned. The help here is irrelevant and rather insulting. Of course we are trying to fill the green colour blocker for the explosion. Stop stating the obivous, but the lack of green tokens makes this impossible for the number of moves alloted. Shovels do not work the way they used to so the chains on lightning are not removed. I shouldn't have to buy more and more moves or boosts. Sick of the waste just to get through one level 3 times. This is the only level I have before I finish LA. Very frustrating. Made worse by lack of sincere help here.
 
 
 posted in Surface: Lost Tales Collector's Edition on Jun 18, 16 9:38 PM
Can't get the staff to take been trying and trying but keep getting clunking sound and really annoying me. I know it is the right place because I had to check walkthrough/Guide. Just bought the game and was enjoying playing. Yet again more tech problems with games from here. How do I continue?
 
 
 posted in Sir Match-a-Lot on Feb 10, 16 2:24 PM
[Removed by Moderator]
 
 
 posted in Sir Match-a-Lot on Feb 9, 16 4:41 PM
I foolishly downloaded yet another faulty [Removed by Moderator] game from BigFIsh. getting sick of problems. i tried this game for 3 minutes and now nothing else will play, saying "another game is running" BUT THERE IS NOT! I am so sick of these problems.
I tried to uninstall it but says "another game is running" again NO THERE IS NOT!!
I shutdown everything and still it is saying this.

HOW DO I GET RID OF IT.
 
 
 posted in Atlantis Adventure on Oct 4, 14 8:48 PM
Again you are helping me? Just found this little tid bit. Thank you
 
 
 posted in Atlantis Adventure on Oct 4, 14 8:47 PM
It is a timed level but I'd won it almost straight away and it was saying 'winner bonus'. Definitely within in time and number of moves. Then when that box comes up it said level lost. Feels random, like a game glitch. Thanks for help
 
 
 posted in Atlantis Adventure on Oct 3, 14 12:20 AM
OMG! So frustrating! Just had an incredible level and while it is saying 'winner bonus' the box comes up with 'you lose' !! What the heck is going on!?!
 
 
 posted in Atlantis Adventure on Oct 1, 14 10:56 PM
Hi, I have been playing this game for a while now but at level 85 I have now won twice - it even says 'winner bonus' but then the 'failed' window comes up and I have to replay the level. What's happening?
 
 
 posted in True Fear: Forsaken Souls Collector's Edition on Mar 1, 14 8:05 PM
Wow so glad I'm not the only one! My computer froze and I had to CTRL-ALT-DEL and even then was left with a black screen! Had to turn off computer at the back!!! So hoping no permanent damage. Will take advice to uninstall. Very scary. Scariest part of the game.
 
 
Awesome! So glad someone else noticed. The character is definitely a dead ringer for Mads Mikkelsen. Couldn't believe my eyes! I wonder if he knows Sooooo hot!!
 
 
 posted in Call of the Ages on Nov 2, 13 3:02 PM
Phew! I thought it was just me. Cannot get past the first England challenge no. 15. Has anyone done it yet? Is it possible?
 
 
i found the lantern on the ground, and i only received the key after I entered the church...
 
 
thanks, i have the cemetary key, bullet comparison, scrubbing brush, a diagram and a lantern
when i try to leave it says the door is locked with a key and i have to exit via the secret passage but i didnt come in via the secret passage
 
 
im in the same position.. cannot exit the building and monk has locked the door.. i dont have the scuba gear and the hatch is locked from the otherside
 
 
Hi, I am currently stuck inside the monastary... cannot exit, the strat guide says to walk out but i have tried everywhere and cannot exit.. any help please?
 
 
Hi, I am having a problem with the door puzzle containing the card suits and chess pieces. The puzzle will not accept the solution card and is refusing to acknowledge the tile I placed in it. It keeps asking for the tile and solution even though I've done one and am trying the other.
Can anyone help?

annag
 
 
 posted in Otherworld: Spring of Shadows Collector's Edition on Feb 20, 12 5:09 PM
It appears others are having problems with this game as well.
It gets worse. The game refuses to end!!
I have reversed as many tiles as I intend to and will not play again.
 
 
 posted in Fruit Mania on Feb 17, 12 5:36 PM
I appear to be having the same problem as many here. I also got black screen but cursor was moving.
I also had hell of a time shutting down. Had to restart my computer to get rid of it. But first had to alt tab to get out of it, then close everyting I was doing then restart the computer.
I was looking forward to this game. Looked like the kind of M3 I love.
Please fix soon!
 
 
 posted in Farmscapes on Jan 25, 12 2:28 AM
To Whom It May Concern,

When are we getting a new Farmscapes?[b]

I loved this game. Where is next one (don't say Gardenscapes, that game was terrible crap!)
I miss the lovely atmosphere it creates along with the incredibly funky music. A revelation! Need more, Lots more!!!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator