Posts created by Audreyfavre

 
 
 posted in Darkheart: Flight of the Harpies on Apr 25, 18 6:42 PM
Mabelina and simplicity19,

BF will issue a credit for you if you have made an unintended purchase. Just send them a message through customer support.

I was confused, too, thinking this was a regular SE game.

HTH,
Acudrey
 
 
 posted in Mundus: Impossible Universe on Mar 26, 18 6:12 PM
Hey s_tickle,

The only way I know to create bombs is to make a match of 5 in a row.

I think I remember that level. It took me a few tries to get it. Btw, buying bombs does not work towards the 10 bombs. You have to "earn" them with your matches.

HTH,
Audrey

 
 
 posted in Mundus: Impossible Universe on Mar 20, 18 12:32 PM
Hi MrPuzzler!

Thanks for asking.

A limited moves option would be nice. Also some mini-games to break up the monotony of playing M3 boards over and over again.

Audrey

**Edited as of 26 March: After playing on and off for several days, I have to change my answer. Limited moves are what makes this game. I would never have bought a game with limited moves before, but I didn't realize that it can add another dimension of fun.

Also, you don't have to pay to keep playing a level. When the window pops up to ask for 200 coins to keep playing, close that window. Another one will pop up asking if you want to retry. This is free.

Audrey
 
 
 posted in Nevertales: Creator's Spark Collector's Edition on Mar 10, 18 8:34 PM
I am so sorry to post this review because I LOVE Mad Head games. I guess i should say I did love them. They still have interesting hidden object scenes and I love their mini-games, but the incessant locked doors, cabinets, portals, music boxes, etc. that require a specific shaped object to open is just exhausting to me! I played the hour of the demo and then uninstalled.

Audrey
 
 
 posted in Cursed House 5 on Feb 25, 18 8:06 AM
I am a little more than halfway through this game and I am having a blast! Most times with M3 I am getting a little bored at this point, but this game offers something different with each level, IMO.

I also love the mini games. The solitaire games seemed easy at first, but they got more difficult as I leveled up. Not frustratingly so, but enough to be a welcome challenge.

The help book is definitely needed (for me) and most thoughtful. I appreciate being able to access it at anytime during the game play.

Thanks developers and BF!

Audrey
 
 
 posted in Cursed House 5 on Feb 22, 18 1:59 PM
I had to start this level over again. I was also stuck in the same place. I can't remember the exact order, but you must direct lightning to the switchblade, snowflake, etc. until they move out of the path of the fire. You will know when you have been successful when all paths are cleared and you can get on with the game. It only took me a minute or two to figure out once I started over.


HTH,
Audrey

P.S. Great game! Very inventive!
 
 
 posted in Bad Dream: Coma on Nov 15, 17 8:29 AM
yaeltje wrote:How do I live the hospital? I have only matches ans a siccior. The doors of the elevator are suddenly closed.


I got stuck in the hospital forever!. I finally clicked around and turned the light on in the hallway with the 4 doors (2 patient rooms, the WC, and the kitchen). Then I was able to click on the elevator buttons to exit the hospital.

I thought I was being "good" by not wasting energy

HTH,
Audrey
 
 
 posted in Bad Dream: Coma on Nov 11, 17 6:47 PM
Jesusluvsme wrote:I'm completely lost on this game! How do I even use the inventory items? Do I have to drag them to where I want or just click on it or what? I really want to play this game but I won't spend money to get this aggravated. Why wouldn't the developer give a better hint system? Seems to me they stand to lose alot of money if they don't do something different Thank God I at least found this forum to help and any help at all will be greatly appreciated. Thanks!


To use the inventory item click on it. It will say the name of the item and "active" if you move your cursor over it. Then when you need to use it, a picture of the inventory item will appear over the spot where it can be used.

Be careful! I had the scissors active when I was trying to do something else and they cut off a body part and I was instantly a BAD person. I had to start over from the auto-save. Be sure your magnifying glass is the active inventory item when browsing around. It can't get you into trouble, so far as I know.

There is a video walkthrough online if you search for it.

HTH,
Audrey
 
 
 posted in Leaves 2: The Return on Oct 2, 17 11:15 AM
dsegel wrote:Can anyone tell me if there is a clue to this puzzle elsewhere or is it simply trial and error?


Hi, if I am thinking of the right puzzle (with sets of numbers to be placed on the dice so they all disappear) it is trial and error.

HTH,
Audrey
 
 
 posted in Leaves: The Journey on Sep 20, 17 6:17 PM
tamjgb wrote:is there a walkthrough and if so where???PLeeeeese


Hey tamjgb,

There are video walkthroughs online. Just do a search.

Have fun.

Audrey
 
 
 posted in Antique Shop: Lost Gems London on Sep 4, 17 10:40 PM
This is the best Match 3 game that I have played in a long time! It has so many unique features that I have never seen before. The developers have really outdone themselves! Please give the demo a try. It is so worth it.
Audrey
 
 
 posted in Leaves: The Journey on Aug 27, 17 8:10 AM
distantsmoke wrote:I "did" the puzzle. All the pieces appear to be in the right places. The puzzle magnifying glass appeared. And I can see the arrow with the ovals on it. But that's as far as I get with it. I am deaf and if there is sound associated with it, I am missing it. But I can't seem to get beyond the room that comes after this. So I keep thinking I must have to do more with this puzzle.


Hi distantsmoke,

If I'm remembering correctly the ovals are a clue that you will need later for another puzzle.

As for sounds, some puzzles don't give you any indication that you have done them correctly except for a small "tink" sound, but usually you get something for your inventory or a leaf when finished There are excellent walkthroughs online if you get too stuck.

HTH,
Audrey

 
 
 posted in Leaves 2: The Return on Aug 24, 17 8:58 AM
ladyarcana55 wrote:I really like these kinds of games but I don't understand how to play. If I am at the map screen or a puzzle, I can't back out of it without quitting first. Is there a section to help me with the controls at least?

Thanks!


Hi ladyarcana55,

No need to exit the game. Just move your cursor to the bottom of the page and you will get a down arrow. Click on that to exit the map and the puzzles.

HTH,
Audrey
 
 
 posted in Leaves 2: The Return on Aug 23, 17 9:39 AM
lacard wrote:Not sure if this is technical or if I'm just not getting it? I tried to use the map to navigate by clicking on the little pictures. Nothing happened. I clicked on the green leaf assuming that was a finished location. Nothing. I tried to close the map. Zip. I had to exit the game and start over with a new game. When I tried to continue, I ended up back at the map where I got stuck before. I watched part of the utube video but they didn't use the map. Anyone know how to use the map? Or is it my system? I don't like starting over because I have to watch the tree sneeze. Again and again. Makes me wonder what else might not work right. Too bad. I liked the game otherwise. Have a win7 64 bit Acer Aspire laptop. Thanks.


Hi lacard,
There is no tech issue. The map isn't a jump map. You can only use it to see where you are (green tinge) and to see if there are leaves to find in your location. To exit the map, move your cursor to the bottom of the page to get a down arrow. Click on that to return to the game. Have fun!
Audrey
 
 
 posted in Leaves: The Journey on Aug 22, 17 9:29 AM
driain wrote:Hi, Can anybody recommend games available on BF that come close to the genre of this delightful game? The games mentioned elsewhere in the forum Samerost and Machinarium - are not currently available here.
Thanks,
drian


Hi driain,

Try The Tiny Bang Story.

Audrey
 
 
 posted in Leaves: The Journey on Aug 19, 17 9:17 AM
PMonkey710 wrote:OK. I've gotten to the area with the white domed huts above the water. I can get the paper with the check mark from the first door, give it to the second, but the third rejects it. But that's as far as I get! I don't know what else to do here!


Hi PMonkey710,

I don't remember the order, but you have to exchange the papers more than once between the 3 doors.

HTH,
Audrey
 
 
 posted in Leaves: The Journey on Aug 15, 17 9:57 AM
driain wrote:I'd greatly appreciate any help on an early stage of the game where the door containing hieroglyphs and a puzzle (completed) is proving stubborn to open. I've found the leaf in this scene and solved puzzle but cannot open the door. The video walkthrough doesn't help because at the end of vol.1 the door is closed but open at the start of vol. 2.
Thanks in advance for any assistance.


Hi driain,
If I remember correctly, the door you mention does not open. You view it ::::::
SPOILER::::::


with the magnifying glass and it shows you all the inhabitants that are "hiding" throughout the game.

HTH,
Audrey
 
 
 posted in Leaves: The Journey on Aug 10, 17 7:53 AM
geezygirl wrote:I downloaded the game but the magnifying glass did not download. From the walkthroughs I can see it's an important part to have but how to get one? I have reloaded the game but still nothing. Otherwise the game plays well.


Hi geezygirl,

The magnifying glass comes later in the game. Sorry I don't remember when or where, but it doesn't come with the game as soon as you download. You have to find it.
HTH,

Audrey
 
 
 posted in Leaves: The Journey on Aug 8, 17 8:45 AM
There's one tricky one that's hard to see in the shadows (bottom left if I remember correctly).

Audrey
 
 
 posted in Leaves: The Journey on Aug 8, 17 8:40 AM
eagletta wrote:Thank you, Audrey. That solves that question – but I still haven't worked out how to extricate myself from the completed comb puzzle and move on. Any tips?


Yes, just move your cursor to the bottom of the screen and you will get a down arrow. Click on that. For some reason, you can still go in and out of puzzles even after you have finished them.

Audrey
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator