Posts created by Navelringz

 
 
 posted in Whispered Secrets: Into the Wind Collector's Edition on Apr 10, 17 5:47 PM
I rescued the panda and he's sitting in his place in the corner, but when I click to send him up to get the plank, I get neither the paw in the magnifier nor does he climb up. If I click him he just chuckles. I am playing a second time without having had any issue on the first round, some time ago.
 
 
 posted in Subliminal Realms: The Masterpiece Collector's Edition on Apr 4, 17 12:37 PM
The hut on the tropical island has a recipe to be made. I have the book but cannot find the missing page. The SG says to place the book and recipe but I have been unable to locate where to pick up the page in the SG either.
 
 
 posted in Sable Maze: Sinister Knowledge Collector's Edition on Sep 14, 16 1:06 PM
I have reached the Horror section, and found the two metal pieces that go in the Lobby minigame at the left. However, the pieces do not move, i.e. they snap back to their original location, and the Skip doesn't work either. Just wanted to report this bug and see if anyone else experiences the same issue. I will try an R&R of the game. Otherwise, really enjoying the game and the beautiful imagery.
 
 
 posted in Time Mysteries: The Ancient Spectres on Jul 3, 12 11:26 AM
Do the hands turning on the face of the Time Device have some significance, is it an indicator to move to a different time or location, or to look for an area tha has not been visited? Also, the device never shows any exclamation marks indicating a task to be completed. Thanks!
 
 
 posted in Dream Chronicles: Book of Air Collector's Edition on Mar 5, 11 10:35 AM
Although I must say the graphics are beautiful, and this game does not demand a great deal of processor, in the end, it was VERY disappointing: it was over in no time, and the games were pretty simplistic. I can't believe I paid a collector's edition price for a game finished in a couple hours. The standard game is half the price of other standard games, this should be too, it's only half a game. I feel ripped off by this one.
 
 
Opsimath wrote:I deleted the original game, downloaded and installed the update and am still no better off. I simply cannot get the hook, The mace worked twice but that third whack just isn't possible. Is there another fix in the offing or should I seek a refund?
Thank you.


Having the same issue as Opsimath. Any suggestions?
 
 
Thanks, LadyCav, I was unaware of the hideous box. It's clear the elaborate box has a place for something to be inserted in the top, but I'm unable to find the hideous box. No indication of it appears on the map, either. Would you please point me i the right direction? Cheers!
 
 
I'm clicking on the 'elaborate box' in the bonus game, but can't seem to figure out what it is supposed to do or show, as nothing happens. Has anyone solved this last part?
 
 
 posted in Mystery Case Files®: Dire Grove™ on Oct 6, 10 7:18 AM
I loved this game! Does anyone know of games similar in style? Objects to find to accomplish tasks, puzzles to solve, etc. in addition to the hidden objects. I really enjoyed the figuring out what to do to move forward in the game, and would like more.Thanks!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator