Posts created by hmoss

 posted in Secrets of the Dark: Mystery of the Ancestral Estate on May 2, 14 3:20 PM
I keep trying but the crystal will not go in the blimp holder.
 posted in The Lake House: Children of Silence on Feb 6, 14 10:06 AM
I finished game it went back to beginning screen How do I get the bonus chapter?
 posted in Charlaine Harris: Dying for Daylight on Oct 26, 13 2:01 PM
I placed the basketball on the teeter totter try to pick up stone can see the sparkle but can not pick up stone I've tried several times I know where it is but my mouse seems unable to grab it.
 posted in Robin's Quest: A Legend Born on Jul 24, 13 3:14 PM
I'm in the church at the altar I need to find John's pardon & the hint button will not work. It puffs out a little puff does not subtract from the number of hints. I've tried reinstalling the game. It did not help. The hint button had been working before this point.
 posted in City of Fools on May 26, 13 10:40 AM
At house 71 I have the saw tried several times to use it on the branch & nothing
happens. With the dog I have the sleeping pills & sausage in inventory They will not combine
 posted in Big City Adventure: London Story on Mar 13, 13 1:41 PM
I repaired the lamp dug up handle The doors are still locked
 posted in Awakening: The Goblin Kingdom on Jan 19, 13 11:03 AM
I can not find the last tankard to pour down the grate. I printed out the walkthrough
picture of the scene & still could not find it Help
 posted in Avenue Flo: Special Delivery on Jul 13, 12 1:51 PM
I got the string off Jo She left to get cookie cutters. Somehow the minigame disappeared. Jo did not come back with cookie cutters. How do I get them?
 posted in Vesuvia on Jun 19, 11 3:32 PM
I can't find the key or exit on this level
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator