Posts created by jersey714

 
 
 posted in Legend of Maya on Jan 31, 15 1:47 PM
I can't either. Up to level 115 with thousands more in resources and there are still two to buy (iron mine and stock). Anyone know what I have to do? Thanks!
 
 
 posted in Around the World in 80 Days on Sep 11, 14 3:18 PM
I tried this and it didn't work. I used 5 fireballs and not only didn't it drop the tiles, it didn't even melt the ice. Thanks for the suggestion though.
 
 
 posted in Call of the Ages on Dec 7, 13 3:04 PM
Thanks, SynthpopAddict! I'll give it a try!
 
 
 posted in Call of the Ages on Dec 6, 13 1:00 PM
stuck on 84...no bombs only time. It's impossible to blow both bombs up in the minute that's allowed. If I get the lightning bolt, it knocks down the game pieces, but not enough time to get the swap icon down. and vice versa.....Tried to get lightning to save it but it doesn't save for the next try. Totally frustrated!! Any help is appreciated!
 
 
 posted in Call of the Ages on Dec 4, 13 3:39 PM
I can't get past level 84. How do I kill the ticking bombs in a minute? Also, I have 10 (hour glass)? but can't click them. Any ideas would be greatly appreciated.




 
 
 posted in Cradle of Rome 2 on Dec 28, 11 10:24 AM
hannah57 wrote:I actually bought this game awhile ago from another site. It seems you can't lose unless your as slow as a turtle. I find there is no challenge with this game. The first one was impossible to finish, I finally stopped trying and deleted it. BUT you should try this one because you really never do seem to run out of time.


Cradle of Rome was difficult for me; took me weeks and weeks to finish. COR 2 is SO much easier that I was disappointed. Up to level 92 with 22 lives; no challenge really. Time is very generous so for those of you who don't like timed games, don't be afraid to try this one. It's much, much easier than the original.
 
 
 posted in Cradle of Rome on Jul 17, 11 8:09 AM
I can understand why people want to cheat in this game. A better idea for the developer would be to use a relaxed mode in addition to the current mode. I've been to level 72 several times only to lose everything and get knocked back to level 54. This game is very frustrating and I like a challenge but am getting too ticked off to continue playing much longer. COR 2 is not in my future purchase! Anyone can help me with hints would be appreciated since I've been knocked back to level 54 for the umpteenth time. Thanks!
 
 
 posted in Victorian Mysteries: Woman in White on Oct 9, 10 8:03 AM
I'm having the same problem. Solved the book puzzle that took me to the hidden room and then stopped the game. Can't get back to that point. Every room says there's nothing to do here now. How do I get back? I believe it's chapter 5. The walkthrough doesn't say how to do it. Thanks for any help!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator