Posts created by TigerJo714

 
 
Brenda519 wrote:Suddenly when I enter Benjamin's office the room shrinks and I can't continue the game.

Windows 7 Professional


I've just started reading so sorry if someone's already figured this problem out. I'm having the exact same problem as Brenda. The hint still works but I can't see where it's showing me. Tiny rectangle in upper left of screen.
 
 
 posted in Cadenza: The Kiss of Death Collector's Edition on Apr 4, 15 2:32 PM
I can't even get the game to download. I bought it but can't play it. I get Error 801. I did everything in BFG help section. It let me download another CE but it still won't work with this game.
 
 
 posted in Questerium: Sinister Trinity on Mar 2, 14 4:08 PM
Thanks Mado.

I'm still having trouble finding the $$ in the Laundry Room. Roots (coins) ??? Help plz anyone.
 
 
 posted in Echoes of Sorrow II on Feb 5, 14 7:31 PM
Wow ... you all are the most helpful herd of I've had the pleasure to meet.

Welcome to the pond firehorescos, greenbenroth and locojet.

I ended up playing something else and was going to call it a day. Now I'm off to fill and light my lantern and carry on.

All y'all rock!!

Thank you again for the help

ETA:

Most people call me Tig or Tigger.
 
 
 posted in Echoes of Sorrow II on Feb 5, 14 1:17 PM
I went thru the last door. I'm in the mansion and have a: Lantern, blue chemical, weird set of paints and 3 figurines.

I am totally stuck. I don't know where to light the lantern. I tried the hint button and it keeps pointing to the foyer. But in the foyer, the hint button won't work. I don't know how to get rid of the spiders. In fact, I'm at a complete standstill.

Help anyone???
 
 
 posted in Echoes of Sorrow II on Feb 4, 14 4:04 PM
Never mind everyone. I got it!!
 
 
 posted in Echoes of Sorrow II on Feb 4, 14 3:50 PM
I've got a hockey stick and 8/9 photo of kids pieces.

I can't find the safe code and the hint button keeps pointing to the safe in the husband's office.

Wow, if I can't even get out of the house, maybe I should just pack it in
 
 
[Removed by Moderator]
 
 
Hi ganonsbane. Thanks for the help.

I wasn't sure what you meant at 1st so I just followed your directions as best as I could ... and it worked!!!

Thanks again
 
 
I've figured out most of this puzzle and I'm at the "jigsaw" puzzle part on the left side.

I know I've got to make 3 pictures by changing tiles. I just can't figure out how to switch between pieces ... or how to swap pieces ... or do anything but turn over tiles.

Anyone have any help for me??
 
 
Hope it worked out for you Nick ... nice seeing you.
 
 
SPOILER:

I'm having trouble with part of this puzzle. No matter how I arrange the Height and Power buttons, I can't make Zeus' lightening bolt hit the molecule round thing ... not sure what it's called, sorry.

Does anyone have any advice for me??? I refuse to skip puzzles and haven't had to yet.
 
 
Thank you so so much ganonsbane.

I was finished playing ... for the day ... and saw your reply so I went back in and I got it!!! I didn't realize that the inner triangle changed.

You rock!!
 
 
I keep going back to try to solve this puzzle. I've tried everything. I even checked the Strategy Guide which I don't like using ... especially in MCF games. It looks the same as my solution but nothing happens.

I've turned the triangle upside down and the birds when needed. I tried backward, mirror-image and anything else I could think of.

Does anyone know what I'm doing wrong?
 
 
 posted in Legacy: Witch Island on Nov 15, 13 7:12 PM
I finally got it. Woohoo!!!

I think the game is even worth a replay ... eventually.
 
 
 posted in Legacy: Witch Island on Nov 15, 13 10:25 AM
I'm almost at the end of the game ... in the palace, to the right of the main/dining room. There are 10 coins to pick up. I've got 9, and I can see the 10th.

It's right at the front left of the room. But every time I try to pick it up, the cursor takes me back to the previous room. It's so close to the edge that I just can't get it.

I've tried clicking everywhere near it but to put the edge of the cursor on it, it turns into a down arrow.

AAHHH - I am really liking this game but it looks like I won't be able to finish it ... unless one of you kind fishies has an idea for me.
 
 
 posted in Spooky Bonus on Oct 21, 13 9:14 AM
This game is great ... so much fun. There have been a lot of M3's lately and I've tried all of them. None of them held my interest past level 3 or 4.

I thought I would play 5 levels or so and before I knew it, the demo was over. I don't think that's ever happened to me before!!

I bought the game, figured I'd play another few levels before I start my Monday and well, I've been playing for over 2 hours now!!

There are many different goals that get increasingly harder. Power-ups that you can upgrade. And I love decorating my yard for Halloween. I think it's great that the decorations include boosts to power-ups, new power-ups etc. There is so much going on in this game that I will leave the details to our usual amazing reviewers.

Just wanted to stop by and say:

Thanks so much Grey Alien Games and thanks to you to BFG!!!
 
 
 posted in World Mosaics 7 on Oct 8, 13 8:13 AM
Sorry to hear that Timbuctu. Did you try setting it for exactly that resolution? Also, you might want to go to Options in the game and either Check or Uncheck the Wide Screen Option.

If that still doesn't work, I suggest you post your message in the Tech Thread and/or send a message to Tech Support.- it's the little Green Envelope to your right Good luck.
 
 
 posted in World Mosaics 7 on Oct 8, 13 7:50 AM
DragonLadyOz wrote:Hi there,
Well, as usual for those of us who are experienced with these logic grids, the worst part of these games is having the patience to get through the early rounds in anticipation of bigger and more challenging grids - but at least the devs have ditched the 5X5 ones at the start and moved straight into 10X10 grids on this occasion.
The story really doesn't matter - just an excuse to play.
Enjoy... Cheers
Thanks for the heads-up vegaskitkat, so demo to make sure the game works OK, but don't go too far if you intend to purchase the game.


Nice to see you Ozzie. I couldn't agree more. I like that we get to start with 10 grids; I just hope it doesn't mean we're getting more of them before we get to move on to the more challenging puzzles. Just last night I was re-playing WM6 and realized how badly this series needed a new installment.

I played 2 games and bought immediately!!! Love this series!!

 
 
 posted in Dark Cases: The Blood Ruby Collector's Edition on Sep 27, 13 8:17 PM
I've gotten the symbol off of the window in the kitchen. I have tried to insert the paper into the box on the desk in the study. It says that I've got the wrong symbol.

Even tho I hate using hints, I tried that: it showed me the box.

I hate using Strategy Guides even more; tried that too. It told me to "choose the right symbol". It may just be too late for me, but HOW do you choose a symbol. It doesn't change. I can't flip the paper.

Ahhhh, what am I doing wrong.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator