Posts created by miss_marigold11

 
 
 posted in Shopping Empire on Apr 29, 18 3:26 AM
Don't bother. Game locks up about 30 seconds after starting and won't let you go until you go to "task manager" and force it to finally leave the screen. What you see before lock up looks to be animation and such from many many years ago. Once again.....don't bother.
 
 
 posted in Dig The Ground on Apr 16, 18 7:22 AM
Game is kind of boring and repetitive but fairly interesting. I can't figure out how to make a nuclear explosion on purpose, have done it by accident I guess. Had to use a coupon before it expired so this was it.
 
 
 posted in Plantera on Apr 9, 18 3:39 AM
Why would anyone even make such a silly game. No directions. No nothing. A waste of a download. Off to uninstall.
 
 
 posted in Phantasmat: Curse of the Mist Collector's Edition on Dec 23, 17 4:56 AM
I don't know if this is a "tech" issue or just my dumbness so I will ask for advice. I have barely started game...am to the last of the first maze and even using the guide, the game will not let me continue past the last phase of the forest maze. I put the signs in proper order...the hint button keeps pointing to the middle arrow but clicking on arrow does not allow me access to go further. Am I just dumb or is there something wrong with the game? thanks
 
 
 posted in The Far Kingdoms: Garden Mosaics on Oct 2, 17 2:55 AM
I have not tried this as of yet. I doubt it will have an option to make as many mistakes as you want. Does anyone know of a mosaic game that does? I have one on my Kindle but not computer.

thanks
 
 
 posted in Mystery Loss on Aug 21, 17 3:22 AM
No relaxed mode... will not buy.
 
 
 posted in Leaves: The Journey on Jul 31, 17 4:37 AM
I tried, I really did, but I guess I am not smart enough or patient enough to master how to even play this game. Admittedly, the images are beautiful, music is wonderful but how, when and what to do eludes me besides the basics of "find the leaves". I shall wait and see what others have to say and if informed, maybe try again.
 
 
 posted in Lost Artifacts Collector's Edition on Jul 18, 17 5:07 AM
This is a cute little game but certainly not a CE. I came to the Forums to see if I had missed anything about the game, wondering why in the world BF considered this worthy of full price. I would most certainly buy it with a coupon if the occasion arises in the future but not now at this outrageous price.
 
 
 posted in Rescue Quest Gold Collector's Edition on Jul 5, 17 12:24 PM
Thank you everyone. I won't buy any TM game, especially a CE, if there is no "relaxed" option. Won't even bother with this one. Too bad.
 
 
 posted in Glass Masquerade on Jul 3, 17 3:35 AM
A very pretty, well working, with gentle appropriate music game. Everything perfect except for one thing.........it's too hard for these old eyes. Spent 20 minutes and only made it half way through the first puzzle. If you have lots of patience and time this is the game for you. I wish it was for me.
 
 
 posted in Berry Blast on Jun 28, 17 7:12 AM
What an awful, silly, waste of time to even download this game is. Horrible tinny music, hardly any directions on how or what to do except for a few pictures and nothing worth winning or losing except for your time.

Give it a try if you have a few minutes with nothing better to do but be prepared to uninstall shortly after installing.
 
 
 posted in Lily's Epic Quest on Jun 16, 17 3:55 AM
This is rather an interesting game. A twist on the usual Match 3. Sadly, there is no relaxed mode and one can play forever and stay on level one or two. The instructions on how to play are pretty much non-existent which does not help when trying to figure out what and when to do things.
If there were a relaxed mode I would probably buy it just to figure it out but having to do a level over and over is too tedious and boring. Sorry!
 
 
 posted in 4 Aztec Skulls on May 2, 17 4:41 AM
That makes sense. I thought that was the reason for delayed introductions also. I've seen it before but thankfully, not very often. I have found BF the most up-to date with offerings and of course, will stick with them.
 
 
 posted in 4 Aztec Skulls on May 2, 17 3:15 AM
Thanks for the tip. I checked and I also bought the game under the name you mentioned from another site in December of 2016. I vaguely remember not being very impressed at the time.
 
 
 posted in Make it Big in Hollywood on Apr 11, 17 5:41 AM
After fiddling with the compatibility for ages and getting the game to work, I made it through 3 levels..When I attempted level 4...same thing blank screen and music. My advice is NOT to buy this game. Something is most definitely wrong with it.
 
 
 posted in Make it Big in Hollywood on Apr 10, 17 12:38 PM
How do I get the actors to go on stage bald or faceless as they show up on screen to be fashioned. This must be one of my "dumb" days.
 
 
 posted in Make it Big in Hollywood on Apr 10, 17 12:37 PM
Just a note from earlier. I finally got the game to continue to play by going to the very basics of the game in it's deep folder and allowing it to be played as administrator. It won't work with just a simple admin allowance, have to go inside the game innards so to speak. Never had to do that before with any game. Learned something new today.
 
 
 posted in Make it Big in Hollywood on Apr 10, 17 3:40 AM
Game downloads and begins fine. Cut scene is fine but when it gets to the "Play" screen, I click Play and screen turns black....music continues but screen stays black. I have to go to task manager to leave game.
I tried this game at another site weeks ago and it did the same thing. All other games work on this computer, I can't imagine what is wrong with this game and have tried everything to remedy the problem.
 
 
 posted in Enchanted Kingdom: A Dark Seed Collector's Edition on Apr 6, 17 1:56 AM
I bought this game earlier today and it will not activate. It downloads fine...tried it on bought and trial but it does not ask to be validated and suddenly pops up as failed. I did all that was told in the help section and still won't work. I tried downloading another game to see if it was my computer and it downloaded just fine. I don't know what to do next.
 
 
 posted in The Far Kingdoms: Forgotten Relics on Apr 4, 17 8:51 AM
I am fairly early in the game and have not figured out where the purchased helpers are when you return to a game. All the little locks are still locked and no amount of clicking anywhere does anything to show me a helper has been used. Where are they and how does one use them?

I only figured out the silly combo lock by accident and continue to play finding it by accident to continue. Very bad and incomplete directions on how to play.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator