Posts created by DarkSnowWhite

 
 
 posted in Yuletide Legends: The Brothers Claus on Dec 31, 16 7:07 AM
Using a Mac version Mac OS Sierra 10.12.2 can't install this game properly it will not download just patching block one screens sound but no content.

Reinstalled and deleted several times still no difference, anyone on here having iMac issues as your all talking about PC and that's what the fix is for too which is no help to an iMac user!

I am very sad....
 
 
Mac Player

System Sierra version 10.12.1

This game is SOOOOOO glitchy! Really frustrating I have installed and reinstalled. Updated Adobe as per the norm and everything is all up to add etc.

Why does this keep happening? Big Fish please stop promoting new games and getting people to purchase them when there are soooooo many faults and tech issues.

It is an ongoing trend when purchasing games and regardless of whether on offer or a BOGOF deal etc it still is very poor service.

Can you not move with the times/ Especially for us iMac users , we always seem to get the tech issue and glitches and freezes...

Not Cool Big Fish! Not Cool
 
 
I am mac user- Have Sierra version 10.12.1 game keeps repeatedly crashing since I downloaded it.. Extremely frustrating.
 
 
Downloaded the game and ok until I got to horse in carriage and then when I opened the diary the screen froze and I could not get back out again? I thought this was supposed to a Top Title? How can you be advertising it as such when it has all these glitches?
 
 
 posted in Haunted Legends: The Iron Mask Collector's Edition on Jul 8, 16 9:44 AM
I have an iMac just doing the Bonus chapter and I gave the coins to the guard but he still has his hand out the response says he has expensive gates...

Someone put on another Thread on this forum Headed Coins they have had the same issue and someone else mentioned that he asks for tobacco next but I have not got a clue if it is a glitch or not... I did check the Strategy Guide and it says he should allow you past to speak to Luisa, so I am think glitch?
 
 
 posted in Haunted Legends: The Iron Mask Collector's Edition on Jul 8, 16 9:41 AM
I have the same exact problem Cherleadford.. I am using an iMac ... Can not see this on the tech issues page though? Not sure if this is a glitch in the game as in a tech problem or something else.

I suggest putting your issue on the tech issue page on this forum I will do this also.
 
 
 posted in Spirit of Revenge: Florry's Well Collector's Edition on Jul 6, 16 7:59 AM
Hi

Just downloaded the trial has crashed 3 times in space of about 7 minutes...

So sad as looks like a brilliant game.. will try again and then send request to tech support.... I am using iMac OS X El Capitan 10.11.5
 
 
Hi i have a Mac Os X El Capitan version 10.11.3 and have just had the same issue with the Carters house on the map..Thought I was being stupid for while going back and forth and retracing my steps... It happened straight after developing the photo. I am annoyed because I did try the trail before I purchased too as it has been recommended as a go round for certain games that don't play well on iMac and its a CE game too so not cheap....
 
 
 posted in Fright Collector's Edition on Aug 23, 14 1:50 PM
Yet again another problem with a big fish game for my mac… this one won't even open for me… there is no fix on the app either as the thread says there is on this forum … so yet again I have to send in a tech complaint re a game for the imac
I really don't understand why they keep releasing games they don't work… very unhappy
 
 
 posted in Forbidden Secrets: Alien Town Collector's Edition on Aug 13, 14 6:32 AM
Hey Penhip…. just saw your post and yes I am having a problem with it on my iMAC…. I keep having to close the game down and restart again which goes ok until about 10 mins in then starts playing up again… The cursor slows right down and seriously effects the gameplay which is irritating….

It's frustrating as this is supposed to be a well rated game… why is it always the iMAC versions that have the problem? I've encountered this so many times on games I've bought its annoying that these things happen at all given the tech the games developers are working with these days….
 
 
 posted in True Fear: Forsaken Souls Collector's Edition on Mar 13, 14 10:05 AM
I bought this game as part of a bundle deal, so I've paid full price for this game minus the discount for being a member.

I have an iMac and first played the game a couple of days ago, noticed it was jumpy and slow, thought it might sort itself out until I got to the basement and realised I didn't have the faucet handle from the HOP in the bedroom, so checked on here and realised it was a problem with the game… so I started it again today and now same thing! But with TWO different HOPS this time the car boot for the winch and again the Faucet handle.

I'm not happy at all about this, as so many have had problems with it and no Moderator responses on here from Big Fish… I will be contacting Customer Support.. AGAIN… But in all honesty Big Fish should be selling games on their site if they are known to have SO many glitches with them…. as for Goblinz the game company why did they bother releasing a very good game that doesn't work properly??????

 
 
 posted in Final Cut: Encore Collector's Edition on Jan 27, 14 1:54 PM
lmcangusee wrote:I can't get the safe dial to turn in the bio lab. I've got the stethoscope, but the dial doesn't turn.

I'm using the Mac version.



I've just bought this game and had the same thing, using the mouse in a different area has no effect and I've deleted and reinstalled it as well… still the same issue, it's a real pain tbh… is there any fixes for this yet? Everyone else on here seems to have a nightmare with it since July 2013?
 
 
Just finished playing this game and as I loved the first one in this series with Edwina. But the song on the end credits is so beautiful…. I was hoping you would get this as downloadable content but alas no.. but Katherine Abbott the artist…. is on itunes and utube if anyone is interested!
 
 
Mr_Russ wrote:
What really upset me was no extra content, now for a CE game this is a bit out of order really… it should have been displayed/advertised that there was no extra content.. leaving me feeling slightly ripped off…
Assuming that the Mac CE is the same as the PC CE, the extra content is embedded in the game.


Sorry to be thick but embedded where exactly??? Cheers Mr_Russ x

 
 
Just completed this game as I'm a Mac user and we had to wait bloody ages to get it released on Mac us… grumble over!

On the whole it was ok, creepy in places which I love, but I found the ongoing concept of the Ravenscroft saga slightly boring and bordering on irritating.

I waited so long for this game to find MCF have gone down the Trilogy route which I'm disappointed about. Would have liked for them to have come up with a brand new concept and storyboard.. (Maybe next time guys?)

The puzzles were hard which is good.. like the morphing scenes but that and HOS would have worked better…

What really upset me was no extra content, now for a CE game this is a bit out of order really… it should have been displayed/advertised that there was no extra content.. leaving me feeling slightly ripped off…
 
 
 posted in Witches' Legacy: The Charleston Curse on Apr 24, 12 10:37 AM
DarkSnowWhite wrote:Just got to dining room and game has crashed several times on me…. not sure what to do now as I have only recently purchased the game???? So deleting and reinstalling seems a bit redundant>


I'm absolutely bloody gutted,,, this game still wont work… I've just wasted good money on this. I'm not impressed at all… wheres the fix for it????

Not cool Big Fish, not cool at all…
 
 
 posted in Witches' Legacy: The Charleston Curse on Apr 17, 12 5:03 PM
Just got to dining room and game has crashed several times on me…. not sure what to do now as I have only recently purchased the game???? So deleting and reinstalling seems a bit redundant>
 
 
 posted in Lost Chronicles: Salem on Dec 6, 11 5:10 PM
Purchased this for the Mac when on DD and have just had issue when using the pitchfork in the stable - the bloody thing just crashed out and can up with an Adobe error message… have just uninstalled and then reinstalled and gonna try agin to see if this works… not very happy…..
 
 
 posted in Trapped: The Abduction on Jul 25, 11 6:42 AM
I just finished this game.... and just saw this post... I thought that game was good... But this post???

Erm, what part of 'IT'S A GAME'... did some of you not understand????

It's not a documentary, it's not a news report, it's not based on any actual persons experience from what I understand..... IT'S A COMPUTER GAME!!!!

If you can't differentiate between fact, fiction or actual reality vs virtual reality , then maybe you should stay away from any such possibly "Offensive" material such as this game, and maybe stick to looking for unicorns and painting rainbows…

Don't like it… fine, its your opinion… hey knock yourself out and be offended… but you don't have to play it… don't have to buy it.. it's really that simple…..

(Unless, of course you HAVE been forced to play it by some very creepy guy in a monks robe… then.. I TOTALLY understand the content of this very unfortunate, albeit slightly over the top posting… ;-) )



 
 
 posted in Twisted Lands: Shadow Town Collector's Edition on Nov 24, 10 5:23 PM
This is the second time I have had a problem with a game I have downloaded from Big Fish and I am getting really hacked off....

I have spent time and money on this game to get to the end of it and be denied the last cut scene and also the end of the Bonus Game...

I am not a happy customer by any stretch of the imagination..... This is totally preposterous..... I am very put off by downloading any more games if this is going to be the outcome.......
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator