Posts created by derekthedj

 
 
 posted in My Singing Monsters on Aug 25, 14 10:51 PM
I thought I was exchanging 1,000,000 coins for 50 diamonds, not the other way around. Cut me in half. With no 'Undo' function that may be the end of me. Well, it was fun while it lasted.
 
 
 posted in My Singing Monsters on Aug 22, 14 2:40 AM
And now you know how free-to-play works. It makes you so frustrated that you a) spend money or b) quit. Either way, they win,

Not even bothering with ethereals myself. I don't know how the process works but reading all of the frustrated comments here is enough to keep me from trying.
 
 
 posted in My Singing Monsters on Apr 16, 14 9:11 AM
Wow, did I read that wrong! Good thing I asked.

Is this one of those monsters that I should light the torch for? Sounds like a monster that shows up randomly.

Thanks all!
 
 
 posted in My Singing Monsters on Apr 16, 14 9:08 AM
Thanks Redcloud and Zoppy! (I should have purchased a mine a long time ago.)
 
 
 posted in My Singing Monsters on Apr 16, 14 12:45 AM
On page 4 of the guide, it says you can create monsters like Entbrat, Quarrister, Riff, with one ingredient plus gold. How is that possible? I've tried everything to creat the Entbrat but I keep getting forced to use at least two ingredients (and I don't see gold as an ingredient.)

Thanks!
 
 
 posted in My Singing Monsters on Apr 16, 14 12:29 AM
So you don't "discover" mines, you have to purchase them through the market? I was confused because the description of the mine in the market says they were "replacing an existing mine structure." I thought I might find a mine after clearing the right rock or something.

 
 
 posted in The Scruffs: Return of the Duke on Mar 8, 12 5:55 AM
Yeah, the walkthrough blog helps. I'm just ranting over the dog being more of a bug than a help in the game.
 
 
 posted in The Scruffs: Return of the Duke on Mar 7, 12 2:55 AM
Ugh, I do not enjoy the move to point-and-click adventure in this game. Worse yet the dog is no help, always telling me to go somewhere else then "hinting" at a place I can't access because I don't have the right tools.

Right now I'm stuck at the beach/rowboat area. Stupid dog tells me to open an underwater shell but I can't do this until I get a snorkel and diving mask. I've cleared all the areas and have a lot of cogs but no idea where they are supposed to go. I also have a map that needs something to make it readable. Does anyone have tips?
 
 
 posted in Princess Isabella: Return of the Curse on Aug 2, 11 11:39 PM
pomconfi wrote:
the truth is - creators cut big part of the game - where you actually have all explanations about the Prince, dragon etc... and give it ONLY in collector edition.

basically we all know that collector's editions give us additional play after play or some other bonuses. but not in this case. in that case collector's edition is actually THE game


Wow, is this true? I have a credit I need to use and was considering this because I liked the first game. Not if the standard edition is incomplete, though.
 
 
 posted in Golden Trails 2: The Lost Legacy Collector's Edition on Jul 4, 11 7:23 AM
I agree with Bpup but I can also see how people can get annoyed by it too. Maybe they can make it an option that can be turned on and off. I do enjoy the arcade aspect of it, though.
 
 
 posted in Brain Training for Dummies on Jun 21, 11 10:37 PM
This is a lot better than Brain Challenge (which is horrible) but this game is sooooo easy it must be designed for young kids. When am I going to get out of the easy "Difficulty Level 1" questions and move up the skill ladder? Not much of a slog to remember two items or the answer to 3+1.

To help explain the "30 games" problem - there are six different skills the game tests you on such as Spatial, Math, Reasoning, etc. In each of the six skills there are five different challenges for a total of 30 games. A few of the games aren't explained very clearly so you may fail the first couple of times until you figure out what they expect out of you. Most are easy to learn, though.

If the game ever starts progressing up the skill tree it could be fun for a little brain massage. The problem is the instructions, while good about explaining how to play a game, are sparse about progression and there is no indication I'm ever going to see "Difficulty Level 2". How does one progress in this game other than Practice Mode?

Edit 7/13: Finally realized you have to do a "Full Circuit" of 15 tests (about 20 min) for the skill levels to improve. It won't count individual circuits. It's really easy in the beginning so anyone doing the 1-hour trial will probably think it's hohum. Rest assured it gets challenging once you get to later levels. It'll exercise your brain and I'm starting to put a half an hour into it almost every day. Recommended.

 
 
 posted in Brunhilda and the Dark Crystal on May 29, 11 7:11 PM
I can;t get this game to display at all. I can hear it starting up with all of the intro videos but my monitor is giving me an "Input out of range" error. My native resolution is 1920x1200. Desktop HannsG 28" HG281.

Looking at the log it seems the game may be setting a resolution my monitor doesn't support.

11:01:02.0 - I. DX8 widescreen salected: 1280 x 768 (aspect: 1.667)

Any way to adjust the game resolution via command line or some way other than the in-game options?
 
 
 posted in Chocolatier on May 27, 11 3:46 AM
Thank you, that was very helpful.
 
 
 posted in Chocolatier on May 24, 11 11:40 AM
Did the trial and enjoyed it, the first hour went by quick, but I feel like I've played this game before. For instance, I own Recettear which is an Americanized version of a popular japanese economic sim and it's similar to Chocolatier in many ways. Other games like Port Royale have the same buy, sell, trade underpinnings.

The minigame of actually creating the different chocolates is innovative. I'm just trying to figure out if there's more to it than growing the business and gathering enough money to complete quests. Thanks in advance.
 
 
 posted in Haunted Legends: The Queen of Spades on Jan 18, 11 5:00 PM
Problems with demo installation. Kept downloading 100% over and over but never got past validation. I assume it failed validation but after the third attempt I gave up. May try it again in the future but not right now.
 
 
 posted in Ranch Rush on Nov 7, 10 2:13 PM
I never got a chance to see a week 10. Like Blueskunk the game ended at week 8 and there was no continue option, just to Start a new ranch. I have the Gamehouse version, though, if it makes a difference.
 
 
 posted in Ranch Rush on Nov 7, 10 2:08 PM
Ok, I FINALLY finished this level. Took about five attempts. Here are some tips:

http://www.gamezebo.com/download-games/ranch-rush/walkthrough

Personally, I realized I was going to need as much help as I could get so I started by doing two things. First, I used the Gamezebo tip of putting crops near the ostriches. I took the three crops that were the furthest away from them and added them to my existing crop that was closest to them, stuck a sprinkler in the center so they got water.

Secondly, I spent a level planning to fail, basically. My 4th attempt I gave it the college try but once I realized I wasn't going to finish in time I spent the last half of the level stocking up on everything. I had the ketchup, cheese, bread, and jelly stations all filled up, all the sheep had three already cut wool shearings set up and ready to collect, everything was maxed out and I even had extra tomatoes, honey, and grapes waiting to be processed once I collected the three that were waiting to be picked up.

This gave me a big head start. In my case I had three sheep so by the time I started I had 9 of the 14 already put together. Same with the other items. Although I did complete the level a minute or two early, I still don't think I could pass the level without a head start like this.

Finally, I made ketchup, bread, and jelly the priorities since I needed the most of these items. Between the three I had little need to do any of the other crops but obviously I had to keep feeding the cows and the ostriches and collecting honey and grapes to keep the machines going.

The combination of these tips were all it took, once you get past this level you complete the game.
 
 
 posted in Ranch Rush on Nov 6, 10 4:49 AM
You too mollyal? Lol, I am stuck on the *exact* same level, Friday of week 8 - damn annoying. I am nearly at the same point of uninstalling but I found some tips on Gamezebo that may help. Notably, growing 1 of each crop in a square right next to the ostriches so I don't have to run around every time they want something. Speaking of which, do ostriches sound like that in real life? It's such an annoying noise.

And, yes jkuci, I agree completely that TM games are more work than fun. I never understood the appeal either. Thought Ranch Rush would be a notable exception but apparently not.
 
 
 posted in Deadtime Stories on Nov 4, 10 10:19 AM
Posting on behalf of a friend who isn't good with computers. He has an old computer with a built-in SIS graphics chip (whatever that is) and he can't get past the part where you enter your player name. After this is entered it seems like he is at the title screen but all it is are these rectangles spinning slowly. You can sometimes make out what appears to be tiny bats flying around. Nothing else shows up. Clicking the mouse cursor makes a sound but I couldn't get anything to change on screen.

Tried changing the display properties, no dice. If it makes a difference, the max his monitor can display is 1024x768. It's an old 14" CRT. I assume it's a graphics driver issue but I'm pretty sure there are no updated drivers.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator