Posts created by 70summerfield

 
 
To answer your question, find the angel's wing for the angel in the gift room and you will get the reindeer symbol!

 
 
I'm stuck there too! Also, I was supposed to get an eraser when I got the lion stamp, but I didn't! Have you had any success with that?
 
 
 posted in Leaves: The Journey on Aug 23, 17 4:58 PM
I'm stuck on the puzzle that is underneath the little animal in the cave. Can anyone tell me what the order is--I'm totally frustrated!
 
 
 posted in Silver Tale on Jul 19, 17 2:30 PM
Near the end of the level and the game freezes. I can only move things in certain areas, not in the area I need. What's up with that?
 
 
 posted in Ashley Clark: The Secrets of the Ancient Temple on Jun 2, 16 5:15 PM
No matter what I do, I cannot get out of the catacombs; hint but keeps indicating a place where there is nothing to be found. I have an oiler and a corkscrew. Anybody got any ideas?
 
 
 posted in Silver Tale on May 25, 16 5:59 AM
I've earned all the badges, aced all the levels and now, all I get is a blue screen at level 124. All of the side art is there, but just a blue screen where the game is supposed to be! What's up with that?
 
 
 posted in Ashley Clark: The Secrets of the Ancient Temple on Oct 20, 15 1:21 PM
I go through the standard procedure--click on play game, click on the download arrow and nothing happens. Can't get game to download. Have no problem downloading any other games. It will let me buy the game, but not let me play it it. What could be the problem?
 
 
 posted in 12 Labours of Hercules IV: Mother Nature on Sep 20, 15 11:51 AM
I'm on level 2.1 and no matter how many times I go to the gold mines, it never registers on the meter, so I can't move on. Is anyone else having this problem?
 
 
 posted in Myths of the World: Stolen Spring on May 4, 15 4:01 PM
I can't get back to Father Frosts cottage! I've revisited every scene and the hint button tells me there's nothing to do. Is this a glitch in the game? I have the ladle, samovar, rabbit shape, compost, ewer and 2 of 4 snow globes in my inventory. What do I do?
 
 
 posted in The Big Secret of a Small Town on Mar 22, 15 2:20 PM
You might like BF's "Pahelika" games.
 
 
 posted in Fishdom: Depths of Time on Dec 30, 14 6:10 AM
How do you get rid of the bombs before they explode on this level? I see that you can switch them back and forth but they explode before I can line them up with anything. What am I doing wrong?
 
 
 posted in Dark Dimensions: Somber Song on Apr 11, 14 11:01 AM
Same thing and then the game took forever--seriously, about 15 minutes to load! What's up with that. No problems loading other things.
 
 
 posted in Finders on Feb 11, 14 2:56 PM
You have to make sure that you have five or more items to sell before you can use the shift button.
 
 
 posted in Finders on Feb 11, 14 2:52 PM
Where do you buy the gas guns? They are not in the storehouse or with the machines and equipment. I know it's probably a very simple answer, but I can't seem to find it.
 
 
 posted in Finders on Feb 5, 14 12:38 PM
On level 7 you have to make fish soup then serve it. Finally caught enough fish to make it, but how on earth do you serve it?
 
 
 posted in Shiver: Moonlit Grove Collector's Edition on May 10, 13 9:18 PM
I have completed the ritual, the wolf transformed, then the screen went blank. I started the computer over, went back to the game. It took me back to the same final scene at the stone with the kite. Is there something else I'm supposed to do? The strategy guide says I'm supposed to be able to play the bonus content, but it remains locked. Has anyone else had this problem? Any suggestions?
 
 
 posted in Motor Town: Soul of the Machine on Feb 12, 13 6:08 PM
Would someone please tell me where the last candle is? Have searched everywhere and can't finish the game! Help!
 
 
 posted in Weird Park: Scary Tales on Dec 12, 12 8:29 AM
I bought this game after tryiing the demo and then found out I couldn't get into my inventory on a regular basis. The cursor also seems to have a mind of its own. I'm really getting tired of having to contact tech support in order to make a game work right. It would seem that BF would make sure all the kinks are worked out before they put this games up for public consumption. I'm a long time BF member and have bought a great many games, but this is really starting to get beyond annoying. I hope you guys to something to tighten up your act.
 
 
 posted in Christmas Stories: Nutcracker Collector's Edition on Dec 5, 12 7:33 AM
Is anybody else having problems getting the armor on the nutcracker? I've tried all kinds of maneuvers and can't seem to coordinate getting the rivets onto the legs or arms and making them stay. Somebody out ther please help!!
 
 
 posted in Inception of Darkness: Exorcist 3 on Nov 12, 12 10:28 AM
I found and used a bucket of water earlier in the game; now I'm stuck in the cave and need a bucket of water to flush the stone or get out. Anybody got any suggestions?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator