Posts created by eserafina

 
 
 posted in Mystery Case Files: Madame Fate™ on Nov 29, 13 4:39 PM
Yes - the reason I went back to the original is because my current computer does NOT meet the requirements for the new game. Some of us can't afford the latest and greatest. I only get a new one when I am absolutely forced to by planned obsolescence, and I haven't gotten to that point yet with this one, but I see it may be starting to get to that point.

Ditto on your "Grrrrrr."
 
 
 posted in Mystery Case Files: Madame Fate™ on Nov 26, 13 12:37 PM
I'm having the same problem. One thing I was wondering - this was one of the first games I bought (back before I had an Intel-based Mac). So will this game no longer work? If so, it would be nice if a message to that effect would come up, or better yet, if a new version would be released. I see that there HAS been a new PC version released this year (of course), according to the topics on this board.
 
 
 posted in Chicken Invaders 3 Christmas Edition on Mar 14, 12 8:50 PM
I was actually (finally) able to kill that thing, but thanks for the tip about staying in the corner!
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Mar 5, 12 6:23 PM
I have the knife but I can't do anything else there, and I still need to dig for the gems and use the dynamite.
 
 
 posted in Jane Croft: The Baker Street Murder on Dec 23, 11 3:01 PM
I can't get past the intro. First it went about three frames into it and stopped. Now it won't go past the ringing phone. I tried opening a new profile, quitting and reopening, and nothing. I guess this is one Daily Deal I won't be getting.
 
 
 posted in Mystery Case Files ®: 13th Skull ™ on Nov 13, 11 4:08 PM
Thanks - that worked.
 
 
 posted in Mystery Case Files ®: 13th Skull ™ on Nov 13, 11 2:23 PM
OK - I went to phone the plumber, put my quarter in and started to dial. Then I realized that I didn't remember the last 4 digits exactly so went back to check since I couldn't find the number anywhere in the journal. Now my quarter is gone from my inventory. Please tell me I don't have to start all over again.
 
 
 posted in Romancing the Seven Wonders: Taj Mahal on Oct 2, 11 8:50 AM
It seems as if it depends on your computer. I played this game all the way through on my PowerPC-based Mac and as far as I can remember I had no problems. Just installed it on my new Intel-based one and this exact same thing is happening.
 
 
 posted in Cooking Academy 2: World Cuisine on Sep 30, 11 6:56 PM
I have the same question and it IS making na'an in the Indian restaurant, NOT peeling bananas. What really seems unfair (and seems to make it next to impossible) is that you have to flatten out numbers 9-12 before you can coat number 9.
 
 
 posted in Mystic Gallery on Sep 5, 11 6:49 AM
The hint button doesn't seem to work for me. It just makes the name of one of the objects blink rapidly on and off. I've stared and stared at the picture (trying to ignore the blinking) looking for something that is being highlighted but can't see anything. Very annoying.
 
 
 posted in Phantasmat Collector's Edition on Mar 1, 11 8:16 PM
Thanks - I may. It's very frustrating when something like that happens, especially what has to be most of the way through the game. At least it feels like I've been playing it for quite a while. Even worse, I have a PowerPC Mac and these days can get virtually nothing new here, since they're all for Intel-based only - not BF's fault, I know, but my membership is worth less and less, and I don't see myself being able to afford a new computer any time soon.
 
 
 posted in Phantasmat Collector's Edition on Mar 1, 11 4:58 PM
So however much time I've spent on this so far is a wash? I have to go all the way back to the beginning, play this far again and hope the same thing doesn't happen? I'm not sure I can be bothered.
 
 
 posted in Phantasmat Collector's Edition on Feb 19, 11 1:22 PM
Actually, he(?) did not answer the question - just made a suggestion. I had the same problem as the OP, and in my case, at least, the chess pieces are not back in my inventory. They are gone. Period.
 
 
 posted in Tibor: Tale of a Kind Vampire on Oct 30, 10 8:10 PM
Also a Mac user, System 10.5.8. The game starts up but then it just seems to go by itself. I have absolutely no control.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator