Posts created by Coronagold

 
 
Mr_Russ wrote:That's being too literal! Consumed = used up = disappear from inventory on last use.

They're not used on anything. They're used for being able to walk up the path to farmhouse and barn. Without them, you can't.


I've played HOGs, adventure, and escape the room games where if you have the lantern or flashlight in your inventory you don't need to use them, the area is just magically lit up. But in this game (like some others) I had to use the lantern to see in the darkness. Wouldn't it make sense to have a scenario like "I can't proceed any further, the snow is too deep and steep here", thus making you think that possibly the snowshoes are needed? Basically they cut a puzzle out of the game. Does that make sense?
 
 
Mr_Russ wrote:PS The snowshoes are needed but not consumed.


Nobody eats snowshoes. Please explain.
 
 
Oh, wait a minute...suppose you don't jump the void, back out, and let the earth freeze, will you be able to cross the river?
 
 
Urban1a, the only time limit in the game is an achievement reward. Completing the game in under 6 hours gives you that reward. Otherwise, there are no time limits. I finished it close to 8 hours.
 
 
ffpz5989 wrote:But I never figured out how to use the snow shoes. I'm sure there must be a way how.


Hey, that's right. I had snowshoes and another inventory item leftover by the time the game finished. Hmmmmmmmm....And I know that gnarly grandmother-faced tree by the river has just got to come alive. I got the 2 fishies and saw that secret room, but I know that they said secret levels. That doesn't sound like a single room to me. And hey.............I never did find the old-timey phone receiver.

Hmmmmmmmmmmm.....wow. But I gotta take a breather.

I liked the "X marks the spot" reference to the RTR lighthouse designs.
 
 
Frank Morgan, Colonel Potter from MASH, the top of your Diary pages will tell you what chapter you are in.
 
 
calsmom2001 wrote:Coronagold LOVE your sense of humor. I see that you're a relative newbie to posting - hope to see more of you.


Thanks! Happy turkey day!
 
 
Oh, so that's what Jay (Jay Is Games/Casual Gameplay) was talking about. I figured it was because Al Gore gave a global warming summit in Yorkshire.
 
 
When I saw 'collectors edition' I thought, "Screw December I'm getting it Now!" I'm not even halfway through it after 5 hours. (I'm not slow, just, thorough.) And the guy up there who said he was disappointed by finishing it in 3 hours must've been the same guy who finished Riven in one hour. Go back to your home planet, Ego. They miss you.

This is a stunning unexpected follow-up to RTR. I had no idea something like this was in the works. And it's very nice to see that they continue with the adventure-style navigation as well as the return of the morphing objects. True, I can live without the Blair Witch element but some of those videos are very well done. (And now I know where to look for a certain combination #.)

Marie Barone - "Better than Broadway!"
 
 
 posted in Alexandra Fortune: Mystery of the Lunar Archipelago on Oct 30, 09 7:41 AM
Mine didn't freeze, but this game has flaws. What's with the hint system? Does it run out & that's it? Can it be recharged? Even NOT using it runs it out of 'energy', like looking for that blasted last feather in that hut where the woman is playing a bongo drum. Being that I ran out of hints (somehow it has a limit but God forbid they should tell you that) the first 25 minutes of the demo. So I restarted under a new profile. Of course I only needed like one hint per screen since I remembered. Lo & behold I get to the bongo hut and the hint thing looks green and good. I find everything on my own except the last feather, I look at the hint button and it's dead. Great design.
And during my first run it appeared out of hints but it let me pick it up and use it as a radar item finder. But not during the second run. What consistency.

Too bad. I WAS gonna buy this game because it has the hidden logic I like in games and it looks great too.
 
 
 posted in Hidden Expedition ® - Devil's Triangle on Oct 23, 09 7:26 PM
If it wasn't for that walkthrough the last chapter or so would've enveloped me. Thank God for walkthroughs. Though I hate to jump out of games and turn on the evergobbling app known as FireFox, I must in order to continue. (old pooter and all, etc.)
 
 
 posted in Hidden Expedition ® - Devil's Triangle on Oct 23, 09 7:16 PM
Seems these games are focusing on Win7 4GB systems already. Hey, Africa.
 
 
 posted in Hidden Expedition ® - Devil's Triangle on Oct 23, 09 6:50 PM
THANK you! Jeez, you have no idea how much that means. Sure, I can appreciate a full screen, but having the option between full and windowed is way more important than fancy or regular cursor. My pooter is from 1999, ME native, running XP. Ancient nVidea card. Downloading this now as I type.
 
 
 posted in Hidden Expedition ® - Devil's Triangle on Oct 23, 09 6:33 PM
The only problem I had was at a certain mini-game within the Windy Area, the "incredibly white suburban talking Mexican" with the sombrero, in the minigame one of the tiles turned only 45 degrees instead of the usual 90 degrees making the tile totally unusable with the game board. Thankfully I still had a few Hints left so I left that tile for last, used a Hint to "solve" the puzzle and it solved the problem. No biggie but still a bug.
 
 
 posted in Millennium: A New Hope on Oct 12, 09 6:31 AM
Travel back in time and learn how the city of Myst was able to overcome its humble beginnings...


Hmmm, I bet Rand Miller will take an interest in that.
 
 
 posted in I SPY™ Fun House on Sep 1, 09 8:43 AM
I think Can You See What I See 1 & 2 did a more mature job relating to kids with realistic settings. Kids don't like to be talked down to. (Neither do adults with credit cards.)
No options. No hints. No pins. (I found 1 out of 3 in 2 different locations. When it's that tough for an adult, what fun is a kid gonna get out of it?)
 
 
 posted in Hide & Secret 3: Pharaoh's Quest on Aug 31, 09 8:07 AM
I played the hour demo. Was intrigued and glad it was not like 1 & 2. Some games are beginning to incorporate navigation, which is good. But yeah, sloppy objects. I find it more fun to find pieces of objects and then use the objects.
The timing of the demo couldn't have been better because I was at a dead end. Gave old man 2 (of what must total 5) scrolls, put 2 (of what must total 7) Rosetta stone pieces into gold box, fixed camels' hoof, fixed very top of pyramid, went to first 2 passport locations, I've used everything in my inventory except for one unlit torch. I re-tried all locations and I couldn't access any knew screens. And then the demo ended.

I'd like to buy it but I'm wary. 70MB isn't all that big these days.
 
 
 posted in Princess Isabella: A Witch's Curse on Aug 21, 09 11:01 AM
In the powder room I'm supposed to solve a puzzle with a red key but all I was given from a previous puzzle is a blue key that doesn't work on that puzzle. I have a green and red marble for a puzzle but not the other 2. And as far as I can tell I'm near the end of the game with about 6 mirror pieces left to find for the king. All the other rooms are solved. What am I doing wrong? Otherwise this game is great.
 
 
 posted in Mystery Case Files: Madame Fate™ on Feb 19, 09 4:45 AM
I just downloaded Safecracker last night, and I gotta say this is more like a Safecracker 2 for me. I had the original PC game many eons ago and it's nothing at all like this newer game, layout-wise. The original PC game started outside at night across the street. The first puzzle was a musical puzzle to open the gates to gain access to the house. And it really wasn't a house, more like a townhouse/museum of safes. This newer game seems to have more of a plot and a reward system (access to newer rooms), which is fine by me.
 
 
 posted in Haunted Hotel II: Believe the Lies on Jan 21, 09 8:14 AM
170MBs. You'd think it was a decent sized game & would last a day or so. Nope. Video must've been 4/5 of all those MBs. Why waste our time on videos? We want gaming, not videos.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator