Posts created by dogcatmom

I have finished the level, but it won't go out of the level. It just sits there. I have tried moving the cursor, but it just goes between the 2 screens. Any advice?
 posted in Immortal Love: Black Lotus Collector's Edition on Mar 23, 18 6:46 AM
All of the graphics flicker its not possible to play - I buy all of your collectors editions and have never had a problem I believe its something in the game not our video cards but will try all of your suggested trouble shooting fixes thank you
 posted in Shiver: The Lily's Requiem Collector's Edition on Dec 5, 17 5:39 AM
I know I must be totally overlooking it, but the game says leave the gate and go to the shed. I can't find the shed<;Thanks!
 posted in Mystery Tales: Dangerous Desires Collector's Edition on Oct 17, 17 5:09 AM
Playing on windows 10 in bonus game it did not register when I picked up the glue and brush to repair the broken vase. I uninstalled and reinstalled still not working. I can see the brush and glue when I open the broken pot in inventory but when I try to select them I get a message that I need the brush and glue
 posted in Bonfire Stories: Faceless Gravedigger on Jul 6, 17 9:04 AM
Where do I find the key for the gate?
 posted in Mystery Tales: The Twilight World Collector's Edition on Apr 15, 17 1:18 PM
How do I get the T symbol? The strategy guide says to take it, but it says I will cut myself on the glass?
 posted in Grim Tales: Graywitch Collector's Edition on Feb 6, 17 5:05 PM
its becoming quite the norm to not be able to finish a game due to a 'glitch' getting very tiring................
same problem with the winding key - I have a list now of 15 games with issues similar to this one - over the past year the problems with games have been increasing.
Hello this game had quite a few glitches, including corrupting itself and I had to start all over with a new profile in the last chapter of the in bonus chapter and the glass cutter will NOT cut the mirror! Have tried everything to see if something must be done first to trigger it to work with no luck. Have placed it on every inch of the mirror - any hints that might help? Not being able to finish the game is becoming a common occurrence with games these days not sure what's going on

 posted in Cursed on Jan 27, 17 5:08 AM
Found this in an earlier post thank you double47
Back out of the puzzle and look at the order that is on the wheel. Skull, lightning, so on. Then go back to the puzzle and you can shift the order by clicking on the top. Starting from left to right you want the skull first, the lightning, and so on. You can exit the puzzle and look at the order again when you need to. Hope this helps.
 posted in Curse of the Pharaoh: The Quest for Nefertiti on Dec 8, 16 10:58 AM
I cannot find the bow for the gold statue in the room on the bottom left. I have everything else!
 posted in Mortimer Beckett and the Crimson Thief on Jul 26, 16 1:50 PM
I am at the movie marquee, and all the letters are missing. They were there before, but now they are missing.
 posted in Mortimer Beckett and the Crimson Thief on Jul 23, 16 6:15 PM
There are 2 places to solve this. One is a you tube video that is mentioned in a post on this page. The other is at a gamesite that we are not allowed to name, but can be found on the internet, it always has tons of walkthroughs, the first place I look when I am stuck. I still don't understand how they figured the sort, but it works.
Good Luck!
 posted in Mortimer Beckett and the Crimson Thief on Jul 23, 16 5:54 PM
Awesome! Thanks!!
 posted in Mortimer Beckett and the Lost King on Jul 19, 16 4:16 PM
That's perfectly alright. A lot of us find ourselves replying to ourselves. Shows we are good puzzle solvers.
I got the glue and the broken swan but the tent disappeared and I cannot fix the swan. As far as I know the only thing to do is start a new profile. I now have a list of 7 games that I was not able to play to the end even with a new profile PLEASE don't let this be added to that list. I HATE replaying and starting over but I hate it worse when I do so and have the same problem again!
 posted in Mortimer Beckett and the Lost King on Jul 6, 16 5:34 PM
Sad to say, but sometimes the answer lies in a place you wouldn't expect. After getting no help from big fish or the forum,. I went to a games place outside big fish and got a walkthrough. It helped immensely.
 posted in Mortimer Beckett and the Lost King on Jun 23, 16 9:27 PM
Because it is locked. I am totally stumped by the fish puzzle. While it can be fun to figure things out, it seems when something is totally confusing, it would be nice to get a hint or something. I have sent my question out, but the 16 people who have read it either forgot how they did it, or aren't bothering to answer. It is very frustrating when you are trying to complete a game.
 posted in Mortimer Beckett and the Lost King on Jun 17, 16 5:10 PM
What am I supposed to do with the fish puzzle. I can't figure it out.
 posted in Mortimer Beckett and the Lost King on Jun 17, 16 5:08 PM
The only way I solved it was just to watch carefully. I have seen them one on the firsrt row, one on the 3rd row, and both on the back row. Sorry I can't be of more help.
 posted in Mortimer Beckett and the Lost King on Jun 16, 16 2:21 PM
I think it is different every time. If you watch carefully, and at worst, play part of it, then you will get it.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator