Posts created by lucygirl7

 
 
 posted in Sable Maze: Forbidden Garden on Aug 22, 14 4:03 PM
I have tried playing both CE and SE and it crashes on me very early on. I love this game and don't know what the problem is because my computer is relatively new and I have everything I need to get through games. Anybody have any ideas?
 
 
 posted in Mystery Age: Liberation of Souls on Sep 29, 13 1:49 PM
I can't pick up the fourth caterpillar
 
 
 posted in Mystery Age: Liberation of Souls on Sep 29, 13 1:47 PM
I can't pick up the last caterpillar. So I can't move on.
 
 
 posted in Reveries: Sisterly Love on Jul 7, 13 11:36 AM
I am totally stuck on the cracker. How or where do I light it? I've tried different ways but I am never successful.
 
 
 posted in Chronicles of Vida: The Story of the Missing Princess on May 22, 13 7:49 AM
I have trouble with the cursor. I lose it, and then it comes back at some point in some obscure place. Also, I can't pick up anything. It's like everything is there at my fingertips, but I can't get it. I really like this game, and after reading the other issues, I will reload and try to use the standard cursor.
 
 
 posted in Phenomenon: Meteorite Collector's Edition on May 14, 13 3:05 PM
I keep clicking on the marks on the left side of the well, but nothing happens. Ironically, I played this demo and didn't have a problem so I know it's the "bought" game. So I have downloaded the new version, etc. and nothing happens. I just keep clicking. This is very confusing!
 
 
 posted in Otherworld: Omens of Summer Collector's Edition on Mar 16, 13 5:54 PM
I finally got the stuff mashed up (but the guide says do it 5 times) and I don't know how many times I did it until it finally happened (about 40) but now I can't get the stuff into the pouch, so I can't move on.
 
 
 posted in Otherworld: Omens of Summer Collector's Edition on Mar 16, 13 5:51 PM
(This is the mermaid chapter) I am now at the part of the game where you are supposed to pound the stagmite purple stuff and put it into the empty pouch and it just won't happen. It took me several minutes just to pound it once where the guide says 5 times and then I can't get the stuff in the pouch so I'm stuck. So do we get credit for the games we buy and then we can't play?
 
 
 posted in A Wizard's Curse on Mar 16, 13 11:54 AM
I was first having a problem with picking up items from inventory. I couldn't get rid of them. Very frustrating. Then I clicked on the hint button for help and it said use the hammer and nails on the chair (I should have seen that one) but when I tried to do that it kept saying it wasn't the right thing. So after 5 minutes of all this frustration, I just gave up.
 
 
 posted in Dreamscapes: The Sandman on Mar 14, 13 1:32 PM
thanks katejoe999. Got what I needed and finished the game!
 
 
 posted in Dreamscapes: The Sandman on Mar 13, 13 8:25 PM
which site did u use for the walkthrough cause I'm having trouble with the ones I click on. I can't figure out what to do and nothing downloads for me.
 
 
 posted in Dreamscapes: The Sandman on Mar 13, 13 8:19 PM
After I bought the game I went back in to continue playing and it said I didn't have enough space so I tried again and it worked out fine. I too have a new computer and should never have a problem
 
 
 posted in Dreamscapes: The Sandman on Mar 13, 13 5:36 PM
I'm almost through with the game, I think, and to the right of the chopping block (take off her head) you go into a stone building, down the stairs and at the end of the room there is another room where you mix powders, etc. and the "hint" button keeps sending me there but I don't have the green powder and don't know where to get it! help!!! Sorry, I know this is probably confusing, but I'm confused. It also shows red on a piece of paper in the front room but I don't have any of that. I can't get out of this scene and don't know what to do!
 
 
 posted in Strangestone on Feb 27, 13 11:00 AM
This game froze on me when I clicked on the diary/notebook and it jammed up my new computer which is quite capable of handling any of these games. I finally had to call Dell and they worked it out for me because every time I shut down my computer and booted it back up it went straight to the frozen game.
 
 
 posted in Shadows: Price for Our Sins on Feb 19, 13 5:43 PM
I am almost to the end of the game and I see that I'm much luckier than some, and I can't get any help from the map which I have been using all along and have really appreciated, and also my hint button doesn't work anymore. It just refills. I saw several people had an issue with this type of problem. I love this game and am sorry about not being able to finish.
 
 
 posted in The Beast of Lycan Isle Collector's Edition on Nov 25, 12 5:41 PM
This game reminds me of Empress of the Deep for some reason and so does the VO. I really like it but it is a tad weird and I wish you could get to where you need to go by clicking on the map instead of having to backtrack all over the place. This is one of those games where I would (and have already) get lost alot. It is very different.
 
 
 posted in Inception of Darkness: Exorcist 3 on Nov 23, 12 4:37 PM
Thank You!!! Never would have thought to use the jack and that was what I needed and had all along. I don't know where I got it either though.
 
 
 posted in Inception of Darkness: Exorcist 3 on Nov 20, 12 4:27 PM
I can't figure out what's what with the mine cart. I have a "wheel"? but it won't go on. I have a yoke? and I have a rod or something. Anyway, how does it all go together? I can't figure out what to do in the train although the hint button keeps telling me to go there. HELP!!! I hate to just file this game because unlike a lot of other people, I really like it. It's different and fun and no it's not "realistic" but I'm enjoying it.
 
 
 posted in Unfinished Tales: Illicit Love Collector's Edition on Nov 7, 12 6:05 PM
Thanks Elijah5 for your super quick response to this puzzle. Got in right away. it was so confusing for me for some reason.
 
 
 posted in Unfinished Tales: Illicit Love Collector's Edition on Nov 5, 12 3:33 PM
I can't figure out the solution to the book puzzle. To me, the strategy guide is no help. It just doesn't make sense, so either the solution is different in the guide than it is in my game or I'm just totally confused. Please help. Any walkthrough coming soon?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator