Posts created by Palenque1978

 posted in Sea of Lies: Tide of Treachery Collector's Edition on Sep 2, 16 10:45 AM
..., no walk through. Guess, I won't be buying this game.
 posted in Hidden Mysteries - Civil War on Sep 1, 16 5:42 AM
I bought this game several years back.... I gave up on it. I recently retrieved it and I still can't find the Maracas.... dammit. I wonder if anyone has ever finished this game. What a waste of money.
 posted in Vermillion Watch: Moorgate Accord Collector's Edition on Aug 18, 16 9:25 AM
This is way over my ol' head. I can't figure out this part....
 posted in Alice's Magical Mahjong on Aug 14, 16 6:11 PM
... the other is The Rise of Atlantis. I LOVE these games.... they are so much fun... they start easy and then get challenging. Although the game is always the same ... it become "new" because the "setup" can vary. I can't say enough for this games. I've had them for years and I still play them... almost daily.

 posted in Les Misérables: Jean Valjean on Aug 28, 15 1:12 AM
The curser is strange... doesn't move well about the site. And, it's difficult altogether. I'm glad I didn't buy the game.
 posted in Nancy Drew: Alibi in Ashes on Aug 27, 15 5:11 PM
I decided to try a Nancy Drew game... they're very challenging. I found the note on the desk on the right... then on the next frame... How do I get out?
 posted in Rite of Passage: Hide and Seek on Aug 3, 15 11:13 AM
The link for walkthrough gives me a blank page. What do I do now?
 posted in Special Enquiry Detail: Engaged to Kill on Jul 14, 14 10:21 PM
Ahhh,,,, I hope this works for me. Wish there was a Walkthrough
 posted in Special Enquiry Detail: Engaged to Kill on Jul 14, 14 7:39 PM
I'm stuck at this part.... How do I get a printout of the killer. I've spoken to the clerk in the store... and can't get past it.
 posted in Web of Deceit: Deadly Sands Collector's Edition on Sep 28, 13 7:51 AM
I'd buy it, if there was a Walkthrough for it. I'm stuck with the gears.
I can't figure this out. Where do I buy Unlimited coffee?
 posted in Motor Town: Soul of the Machine on Mar 14, 13 4:18 PM
margie, I'm confused too. numbers with the slashes don't work for me either.

Anyone.... what is the code.........please.
 posted in Motor Town: Soul of the Machine on Mar 14, 13 4:15 PM
kesacat, I can't get it either.

Will someone just gives us the code numbers.... ? PLEASE.
 posted in Silent Scream II: The Bride on Mar 6, 13 4:13 AM
This game wouldn't open up for me. It was stuck at the name... it had three names and there was no indication as to how to replace them. I had to do a reboot to get out. Not impressed, to say the least.
 posted in Motor Town: Soul of the Machine on Feb 23, 13 12:25 AM
I'm still stuck with the locker. I've tried 3, 4, 4, 4.... nothing. I've tried 3, 4, 4, 8 because the last number is a 4 added to the prior 4, making it an 8 and it still doesn't work.

I'm stuck.
 posted in Motor Town: Soul of the Machine on Feb 21, 13 3:31 AM
I'm sorry I bought this game. It's my fault, I should have checked first if it had a walkthrough.
How do I unlatch the latch?
 posted in Paris 1925 on Oct 4, 12 12:42 PM
I'm convinced; I won't buy this game. Thanks for your input... sorry you all are having problems. Good luck!
 posted in Whispers on May 31, 12 12:43 AM
Thanks for the "heads up"... I couldn't have gone on without it.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator