Posts created by Tarni64

 
 
 posted in Corpatros: The Hidden Village on Jul 25, 13 12:11 AM
OK, its me again, I am starting to think I am just not smart enough for this game. I finished the camp site. There are only 2 things on the map now. Me, and one item that is showing on the map UNDER the label for Inside the Village House (technically it isnt even flashing within the borders of the map) I have searched the house, and outside of the house,
I have no idea where to go from here and am feeling very discouraged. The walkthrough that was posted on youtube was taken down, and the other is asking me to install some kind of .exe which I will not do as I know that is not required to read a walkthrough... if anyone out there knows what I need to do next that would be awesome.
Thanks
 
 
 posted in Corpatros: The Hidden Village on Jul 24, 13 11:40 PM
fresh227 wrote:You have to use the pigment and the sulphur on the painting of the snakes and they will die in the hut. Have fun!


Thank you so much!!
 
 
 posted in Corpatros: The Hidden Village on Jul 19, 13 7:34 AM
Ok I feel like a complete idiot.
I am only in the second scene... In the treehouse/hut and it wont let me use the sulphur on the snake... suggestions?
Thanks!
 
 
 posted in Dark Dimensions: City of Fog Collector's Edition on May 28, 11 9:16 PM
I, like quite a few others, am stuck on the second tree hollow HOG, as, well... there is not HOG there! I have rebooted (the computer), restarted (the game), and even tried hint in Every section available, just to make sure I didnt miss anything. Even tried a third time following the guide provided, step by step. The ONLY thing the hint button does is tell me I need to cut the bush outside the train station beside the stained glass puzzle. but I cant do that, because I cannot move any further in the game to get whatever I need to cut the bush! please someone help I was really enjoying this game!
 
 
 posted in Goddess Chronicles on Nov 22, 10 7:57 AM
Ok I am in what resembles China, the last board in this "chapter" I know this because I have found everything, there are two statues that sparkle, I have obtained the wind, and the rock, BUT neither of these work on the sparkling statues, so I know that I have to find the next element, but have NO idea what I am looking for!!! I cant find a walkthrough ANYWHERE online, so if someone has completed the game and wouldnt mind posting for me what I am looking for and where so I can move forward I would appreciate it!! I pride myself in being able to do most of these things on my own, but this game is ridiculous. twice, I have found the bases of the mini statues, and when I click on them it tells me to only click on what I am looking for, and that IS what I am looking for!! even the karma beads say so!!! TIA for any help offered.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator