Posts created by nancer

 
 
mac 10.9.5. had some issues before but now i can't play the game at all. fired it up to play and find i can't do anything without double clicking----can't pick up things i need and hints don't work.

it's getting old, buying these games and having them start glitching. i have another one with an update that i can't get to download. uninstalling and re-installing is just a hassle and i shouldn't have to do it. just make them WORK!!!
 
 
yep, same problem. OS 10.9.5.
 
 
 posted in Living Legends: Bound by Wishes Collector's Edition on Mar 3, 16 5:27 AM
running mac OS X 10.9.5. can't even download this. my archive utility crashes and won't download it at all.
 
 
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 13, 15 8:23 AM
running el capitan. game froze. now the hint function doesn't work at all. very disappointing.
 
 
 posted in Forgotten Kingdoms: The Ruby Ring Collector's Edition on Jun 22, 15 11:42 AM
ditto here. i thought i was losing it. glad to see i have company!
 
 
 posted in Bridge to Another World: The Others Collector's Edition on Mar 29, 15 10:50 AM
it became clear the farther i got in this game that it would eventually crash. lag time between scenes, then dark screen. i'm deleting it. one more time, another game i paid for and couldn't complete.
 
 
 posted in Whispered Legends: Tales of Middleport on Jun 11, 14 2:11 PM
same thing here. i don't have anything to do there but the hint keeps sending me there.
 
 
 posted in Dark Dimensions: Somber Song Collector's Edition on Mar 16, 14 7:14 AM
adding a comment about bigfish support. i've always thought this was a real highlight---their tech support is really good. but the response i got about this game just tells me they know it doesn't work and are offering a free game. they're not even really suggesting fixes for it, so i'd say everyone should give up on it and move on. i HOPE they get it fixed, and yes, this has happened to me way too much lately---buying a game and having a problem like this.
 
 
 posted in Dark Dimensions: Somber Song Collector's Edition on Mar 13, 14 11:41 AM
played the demo with no problem. after buying and activating it, i got the intro but when i hit 'play', i got a black screen and a cursor. that's it. no game. nothing i did would change it so i had to shut off my computer. tried it one more time with the same result.
 
 
i can't find more than 4. it says one is near the windmill ruins and i think that's the one i'm missing but i still can't locate it.
 
 
 posted in Dark Alleys: Penumbra Motel Collector's Edition on Aug 25, 12 9:20 AM
i'm in that same spot, wiljul, with the same OS as you on mac. so i guess i'm done til someone answers.
 
 
 posted in Dark Alleys: Penumbra Motel Collector's Edition on Aug 25, 12 9:15 AM
same here! also on mac 10.5.8. can't get past that hotel room.
 
 
 posted in Infected: The Twin Vaccine Collector's Edition on Jul 22, 12 3:29 PM
where's the hornet?
 
 
 posted in Grim Tales: The Legacy Collector's Edition on Feb 4, 12 4:52 PM
i can't find a key for that book. anyone?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator