Posts created by jaxyel

 
 
 posted in Sable Maze: Sinister Knowledge Collector's Edition on May 8, 17 12:50 AM
Like the posts above me, I was playing the trial version, liked it, and purchased the game on my iPad 2 - suddenly in the room with the white wolf. Was able to play for a bit, now it's obvious I'm missing tools and am getting the same message with the hint button - 'I'm done here' - any fixes imminent?
 
 
 posted in Haunted Legends: The Black Hawk Collector's Edition on Mar 24, 17 12:08 AM
I have turned the water dials in the right direction according to the the "help guide" but the water will still not come on nor will the harness go on the horse. What is happening? Can anyone help me?

Did you comb the horse's mane and put the oats in the trough?
 
 
Hi, am playing the demo and when I take the picture of the fog, the game crashes. Has done this 3 times. I'm on Mac platform 10.6.

Help! These are brilliant games - love them!
 
 
 posted in Princess Isabella: A Witch's Curse on Dec 10, 12 7:07 PM
This is brutal - outside the castle, get the crow's feather from the painting to tickle the 3 gargoyles to get the gears. Crow's feather disappears after the second gargoyle. Big glitch, can't finish the game.

Fix please!!
 
 
Intense gameplay so far, really enjoying it, and no hitches, until now. I'm in the fourth door, by the violinist, and looked at the strategy guide when I couldn't do anything else. You're supposed to be able to get a handle and a button from the pile of rubble, but it's not active - can't do anything with the pickaxe. Anyone else come across this??
 
 
 posted in Haunted Manor: Queen of Death on Jan 15, 12 12:30 AM
Have been able to play the game through with no issues, also noticed the urn in the mansion foyer moves but doesn't go anywhere. I'm on the bonus game now, and you have to collect mirror shards for Stella's bedroom mirror. I just placed the last one in the mirror and it's not doing anything. It just keeps saying 'I should collect all the mirror shards' but I have, and they're placed. Looking in the strat guide, I have to get a lockpick from the mirror to open up the next area, so I'm totally stuck, can't do anything.

Any help would be excellent.
 
 
A27A957 - after much backtracking, this is the code you need to enter into the 'cash register' machine in the room with the elevator to get the telekinesis medal. I'm playing the mac version, but I took that from the Gamezebo walkthrough. Good luck - I'm about to go down the elevator!
 
 
First time posting here - bfg has always had great customer service, and Redemption Cemetery is the first game I've had issues with. It's a great involved game, but I stopped playing after the safe crash and found out this was a tech issue with the mac version. I saw on these forums that there was a fix, tried it again, had the same issue.

After reading further, I followed the link to reinstall. All it did was look for the installed game, so I assumed it was a go. I deleted my previous profile, and started over. Just returned to the safe again and the exact same thing happened. It doesn't even allow me to move the safe dial at all; when I try to do anything on the safe, I get the big freeze and it crashes.

Am I doing something wrong? This is incredibly frustrating.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator