Posts created by JORJA42

 posted in Mortimer Beckett and the Lost King on May 25, 16 11:55 AM
I can not get anything to stay under the hammer on the anvil to be hit. I have tried everything I have in my inventory. What am I missing?
 posted in Weeping Skies on Mar 27, 16 12:15 PM
need to find cupid. I found the bow, but will not let me get rid of cupid. when I use hint it tells me to go to jacket and when I use hint again it tells me to exit jacket. so what should I do? I have exited and re started many times .it always starts in same place.
 posted in European Mystery: Flowers of Death Collector's Edition on Oct 26, 15 7:44 PM
Of all the shoes I found I was only able to get two of them to respond. I don't usually get all of the collectables, but it would be nice to be acknowledged when I do find them. I did not have any down load problems. I agree with the other person that the black outs between scenes was off putting.
 posted in Reflections of Life: Tree of Dreams Collector's Edition on Jun 27, 14 11:21 AM
I am unable to find the rose token for the little gazebo so I can put the colored balls in place. Would appreciate any help you can give me. I tried to find it using strategy guide, but that did not work for me.
I am using the map and I still get lost. Must be my senior moments. Thanks for the help , I will see if I can find my way.
I am trying to get to the old truck and can not figure out how to get there. I have gone down all the stairs and elevators i can find but can't get to the right one. Help!!
 posted in I SPY Mystery on Feb 13, 12 8:02 AM
I found all the parts but don't know where they went so I can finish building machine.
what have I overlooked? Thanks for any help.
I figured it out. so thanks anyway.
 posted in Alice's Adventures in Wonderland on May 5, 11 5:54 AM
I can not find the tie in the Cheshire cat scene. I have used the hint button several times and click where it shows to click. But find nothing. Any help would be appreciated. Thanks
 posted in Alice's Adventures in Wonderland on May 5, 11 5:38 AM
Is there a walkthrough for Alice's Adventures in Wonderland?
 posted in Mystery Novel on Apr 12, 11 6:33 AM
How do I get in the house? I keeps telling me it is resisting. Ikeep pushing on it and nothing happens. Thans for all help.
 posted in Hodgepodge Hollow on Jan 12, 11 10:20 AM
I can't seem to find Scruffy. Please help. Thanks
I have scrolled and have nowhere to go. I only have the one row of inventory. sorry didnot mean to yell.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator