Posts created by michreneeg

 
 
 posted in Grim Tales: The Bride Collector's Edition on Aug 8, 11 2:01 PM
The exact same thing has happened to me. Can anyone help? I don't want to start over.

pixiedoll33 wrote:I am on chapter 4 the rose. Near the cottage there is a tree and I have already been on the roof. When I was searching around the area a magnifying glass said tree and I clicked on it. Now I am frozen on the tree. I can only see the ladder I made to climb up. I can't get out of the screen. It won't let me do anything. I don't want to start this game over so could someone please help.
 
 
 posted in Nightmare Realm Collector's Edition on Jul 4, 11 3:05 PM
I just installed & purchased this game (2 days after you posted the "fix"). So, why is it that I can't click on the eyes. Do I need to uninstall? I really like the game but if I have to start over, I want my money back.
 
 
 posted in Hide and Secret: The Lost World on Jun 18, 11 4:05 PM
Thank you! I ended up looking a the Walkthrough Blog. I don't like doing that. :-( I wasn't clicking on the 1-6 buttons in the control panel. I thought that once I had all the parts, the control panel would be like those other puzzles in which you had to follow the line from the top to buttons at the bottom. Ooops!

Thanks, again.

Michelle
 
 
 posted in Hide and Secret: The Lost World on Jun 18, 11 3:41 PM
Where did you find it? I'm stuck there.
 
 
JEC727 wrote:I found my last mirror shard on the screen with the egg, there are three ability areas on this screen. Mirror shard in bottom right corner


Thank you, JEC727!!! I couldn't find that last shard & it was driving me nuts.
 
 
 posted in Snark Busters: All Revved up on May 13, 11 4:31 PM
When I got the purple line through the middle gem, it locked up. I could see the piece that I was supposed to grab but it wouldn't let me. I had to go to the main menu to get out of that screen but now it won't let me get that piece, so I can't continue. Does anybody know how to fix this? I don't want to start over.
 
 
 posted in Mystery Trackers: Raincliff Collector's Edition on May 9, 11 12:29 PM
The tiles didn't do anything when I clicked on them either. I had to skip it. I'm now wat the puzzle in the blimp & the same thing is happening....nothing. I'm not pleased with this game.
 
 
 posted in Maestro: Music of Death on Mar 29, 11 8:45 AM
I'm stuck in the hidden object section right after giving the doll/puppet his eyes. It's asking for a unicorn and when I click on the hint button, it highlights a peacock feather. There is bronze horse statue but I'm not sure what a peacock feather has to do with a unicorn. I've tried using with with the horse and everything else on the screen but still can't figure it out. The walkthrough doesn't explain it either. Can anyone help me?
 
 
 posted in Shiver: Vanishing Hitchhiker Collector's Edition on Mar 25, 11 9:54 AM
The same thing happened to me. Very, very frustrating!! I don't want to start it over, as it's almost done according to the walkthrough. Also, I've already figured out everything to get to that point so it would be boring to repeat it all. There should be a start chapter over option like some games have.
 
 
 posted in Drawn: Dark Flight ® on Dec 13, 10 12:25 PM
I skipped the mixing paint game but wish that I hadn't. Is there a way to go back and play it? I don't want to do the entire game all over again. Thanks!
 
 
 posted in Drawn: Dark Flight ® on Dec 11, 10 8:28 AM
I see all 4 books but I can't catch them for the life of me!!! If I left click, the net goes back into inventory. I've tried to right-click, single-click, double-click and not click at all. No matter what I do, the book just flies right through the net. How in the hell do I catch these stupid books?!?! Nothing seems to work. Sooooo frustrating!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator