Posts created by Bidme

 
 
 posted in Building the Great Wall of China on Nov 27, 12 8:53 AM
I'm not the greatest of fast players, I found Roads of Rome harder, I got apart from level 8..3 stars on all the other levels up too14 when demo ended. I found it really boring so won't buy.
 
 
 posted in Shadow Wolf Mysteries: Cursed Wedding on Nov 16, 12 9:00 AM
Elizabeth Rex and her slave's!! after reading some of the comments in the CE.
 
 
 posted in Sherlock Holmes VS Jack the Ripper on Sep 12, 12 5:26 AM
I have a windows vista about 6 years old, up dated to windows 7 off the internet. I haven't had a problem at all, I downloaded everything it told me to, runs like a dream, motion sickness maybe a problem in the opening scene, then you can go to first person, works by keyboard or mouse, I've only been playing 20 mins, will buy. Hope you all sort this out
 
 
 posted in Inbetween Land on Aug 26, 12 11:57 PM
There's a diary on the left in the game, gives you the time you've played. I'm not fast but 1 hour 48 mins is a bit short!!!!
 
 
 posted in Inbetween Land on Aug 26, 12 3:21 AM
when you look in the dairy it tells you how long you've been playing, well it said 1hour 48 mins, wish I had never brought it
 
 
 posted in Eternal Journey: New Atlantis on Aug 25, 12 1:03 AM
This is one of the best games I've played in a while. I found there wasn't alot of HOS, maybe more adventure, The sound effects were the best I'v heard in a long time. Also I spent 5 mins just playing with the train till I found a lift!! bit like a fair ground ride. I brought the CE which is something I dont normally do. I hope you enjoy it.
 
 
 posted in The Promised Land on Jul 11, 12 8:58 AM
Cjb58 wrote:I bought 2 rooms but I can't seem to drag them. Do I move the other rooms first?
Confused
There is a website out there, put in the promised land building game walkthrough otherwise your get a war game. its a puzzle you will have to fit the rooms exact, or they won't fit, I had to draw the rooms using the web site
 
 
 posted in The Promised Land on Jul 11, 12 3:47 AM
I'm like valdy, I'v got forge, built ship, have kitchen, but when I started I could not build house, have you all got rid of the the little box, I think it has gold border, click the X in the top right, then you can build the house. My trouble is I can't extend the house, I brought the plans and moved it over but nothing happens. Now found out how to add rooms using another website
 
 
 posted in Tesla's Tower: The Wardenclyffe Mystery on May 26, 12 2:19 AM
I'm off to buy. Valdy said it all in the review, what a great change from spooky houses. Oh yes it starts with a Lift crash instead of a car crash!!
 
 
 posted in Amerzone: Part 1 on Jan 19, 12 1:19 AM
I thought it was older then 1999, I brought this on a c.d what I remember of it was very good. I could just get the old disc out, but I doubt it would run on a modern comp
 
 
I really wish all the fishes in the pond and Big fish themselves. A happy christmas, A safe swim into the new year. xxxx
 
 
 posted in Grim Tales: The Bride on Sep 2, 11 1:37 AM
Thanks for your reply, but I can't even get the webpage to open, to buy I've gone through the GM and website, it won't open the page to buy
 
 
 posted in Grim Tales: The Bride on Sep 2, 11 1:13 AM
I can't seem to buy this game or others, I can get into my account, I can down load trials. but my internet explorer keeps telling me there's a prob with the website when I go to buy, I've done the green enverlope, Any other fishes had this prob in the past? Last game I brought was 4 days ago and it was fine. Any help would be welcome
 
 
 posted in Spirit Soup: The Queensbury Curse on Aug 20, 11 11:04 AM
Good game but, very short, maybe 2hrs 2 and half
 
 
 posted in Spirit Soup: The Queensbury Curse on Aug 20, 11 2:16 AM
This makes a nice change, It reminds me of The Fool. This is a buy for me.
 
 
I'am also in the u.k very fast download, must have found a gap in the fast lane. Instead of bumping along on the hard shoulder
 
 
 posted in Nightmare Realm on Jul 29, 11 12:29 PM
great game first class but you won't get passed new game manager. good luck
 
 
 posted in Nightmare Realm on Jul 29, 11 12:14 PM
colorina_11 wrote:I think the problem is the game. Mine also goes blank and takes me back to GM. I already tried everything support told me (the resolution etc..) nothing works. Please fix the game, It has so many good reviews I want to buy the CE....
Its not the game its the new manager
 
 
 posted in Nightmare Realm on Jul 29, 11 12:09 PM
heidiwags wrote:I'm not sure if it's the new Game Manager or the game itself, but it won't launch on my computer. I click on the Play and there seems to be trouble launching it. There is a bit of processing and then back to the Game Manager indicating that I played for a minute.

I'm on a Windows 7 machine. I have not had issues playing another activated game. (I will try another demo game)
I now have same problem, and I brought this as a CE when it came out, I forgot it, so bonus here.. I'am having awful prob's with a lot of games I have brought. I feel its the new manager...It worked before
 
 
 posted in Millennium Secrets: Roxanne's Necklace on Jul 24, 11 12:06 AM
I don't have the X card either, better try and get my money back
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator