Posts created by rosierosebud

 
 
 posted in PuppetShow: Poetic Justice Collector's Edition on Oct 26, 17 9:52 AM
i am in the bonus game and cannot get the feather stuck inside the window any advice
 
 
 posted in Vampire Legends: The Count of New Orleans on May 15, 16 8:07 AM
i am having the same issue cant get back into the carter house please fix

 
 
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 19, 15 11:10 AM
is there FIX for this game yet so many problems so disappointing uninstall reinstall freezes !!!!!!!!heelp
 
 
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 18, 15 8:03 PM
this game is infuriating I have tried and tried to finish it and every time u turn around there is a glitch want my money or a coupon don't really care what happens any more in this one so disappointed either fix it or refund but I have now started over 4 x n dot care to do so again what gives big fish really
 
 
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 16, 15 9:27 AM
the mini game of the star constellation will not close so I can not get to my inventory in that scene. Help!!!!!!!!!!!!!!
 
 
 posted in Lost Souls: Timeless Fables on Jun 6, 14 7:59 AM
I am having the same problem with the beach scene. allowed to pick up a few objects but all I see is black and white splotches, too. will continue to check for updates.
 
 
 posted in Echoes of Sorrow II on Feb 5, 14 11:48 AM
I so not have the key to open padlock in room under stairs thus I have no oil can help, what am I misssing
 
 
 posted in Haunted Halls: Nightmare Dwellers on Jan 8, 14 8:09 AM
I am having the same problem as every one else with the mirror and the 3 gems. Is there a solution or fix available yet
 
 
 posted in Strange Discoveries: Aurora Peak on Aug 11, 13 11:27 AM
got to the cave where Alan is being held and found the protective gloves. but when they went into inventory they disappeared. there was an empty box where they should have been. I clicked the box and they appeared but I am unable to pick them up and use them. I am sure I need them for the volcano vent. that is where the hint sends me. has this happened to anyone else. please let me know how to continue.
 
 
 posted in Azada: Elementa on Apr 6, 13 10:15 AM
every time I go into the store to buy a sphere from the monkey my curser freezes or slows down and is uncontrollable, it will respond after a few minutes but this frustrating-all other areas of the game are fine. is anyone else having this problem
 
 
 posted in Mystery Case Files®: Shadow Lake Collector's Edition on Nov 23, 12 6:33 AM
thanks Rumbi-big help-I think I am missing bird poo in steeple-any more advise
 
 
 posted in Mystery Case Files®: Shadow Lake Collector's Edition on Nov 23, 12 5:53 AM
I am glad I am not the only one that went-"is this it"-at the end. My question is how to I go back to look for the missing morphers-all I can do is listen to Cassandra over and over and then credits appear. Any help would be appreciated. Maybe the answer is already in the forum and I missed it. I do am disappointed with this MCF game-as I have loved them all.
 
 
 posted in Sable Maze: Sullivan River Collector's Edition on Oct 2, 12 1:02 PM
husband and i were on same computer-he finished about 15 minutes before i got back on. He was able to complete game and bonus with no problems, and now I am stuck going back and forth in the labryinth without being able to get to the skeleton. even tried uninstalling and reinstalling.
 
 
 posted in Sable Maze: Sullivan River Collector's Edition on Oct 2, 12 11:03 AM
I to have tried over and over again to get through the labyrinth. Cannot turn left except past the dryad which then leads me to the tree of wishes. I cannot get to the tree that is supposedly pointing to the hole in the wall. Funny ting is my husband was able to finish the whole game right before me. Any more advise out there????
 
 
has anyone spotted the mask in the backyard scene of the theater. am showing a green light, but cannot see it for the life of me. let me know if you have found it. really like this game, a bit different and i am enjoying the story.
 
 
 posted in Snark Busters: High Society on May 23, 12 5:32 AM
kris_cross48 wrote:mine downloads ok, but every time I hit play, it tosses me out into manager.
kris


am having the same issue,
 
 
 posted in Whispered Stories: Sandman on May 21, 12 7:42 AM
glad to see i am not the only one who cannot figure it out. i keep getting the red one on the right also, am frustrated as well, any one out there who can be more specific, have tried everything
 
 
 posted in Whispered Stories: Sandman on May 21, 12 7:40 AM
how do i fill up the tubes on the left with 3 and 4 levels each in the hour glass puzzle? have been stuck here for what seems forever. please let me know as i can not figure it out. thanks
 
 
 posted in The Keepers: Lost Progeny on Dec 14, 11 8:10 AM
the marble dropping mini-game keeps freezing-any one else having this problem
 
 
 posted in Spirit Soup: The Queensbury Curse on Aug 20, 11 6:18 AM
where did you find the last cube
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator