Posts created by giddiup101

 
 
 posted in Sea of Lies: Nemesis Collector's Edition on Jun 20, 14 2:46 AM
It's a glitch.. I had to start over and it worked the second time.
 
 
 posted in The Tiny Tale 2 on Jun 3, 14 9:26 AM
sartasia wrote:
Anangelsprayer wrote:
catbag8717 wrote:Hey, you should post this in the tech issue forums or contact Customer Support. BFG might not know about this!


Good point cat. But the thing is even if you report it in the tech thread, I've seen issues on games that were reported and never taken care of lol. And that's meaning the short time I was on here


BF is not responsible for actual programming errors with independent games and, short of pulling the game altogether, can only alert the Dev. Most but not all games sold here are not the proprietary property of BF. They are merely the sales outlet. Just saying that the lack of corrections for some games falls at the Developers feet. That being said it's always a good idea to post to the tech thread so it can be passed along.


I agree, though I've tried in the past to report a different game to a developer for an obvious programming error and they asked where it was purchased and then referred me right back to BFG so not sure how they will deal with it but don't be surprised if this happens.
 
 
 posted in Mexicana: Deadly Holiday on Apr 16, 14 10:06 PM
PattyMeeMaw wrote:
rosie28sammy wrote:Same issues as others. Game runs about 2 minutes, then freezes. I get an error access code violation and when I click on it to get rid of the message, I get the Twisted Lands message. I also do not have Twisted Lands installed on my game manager. This happened twice in the five minutes I attempted to play the game.


Same issue for me. Too bad, might have been a fun game.



I'm having the same issue as well. I get an error access code violation along with the Twisted Lands message. I too do not have the game Twisted Lands so clearly there's an issue.
 
 
 posted in Surface: Reel Life Collector's Edition on Apr 10, 14 2:32 AM
Thanks DragonLadyOz!!! It worked like a charm!
 
 
Great game!! Puzzles are fun, not too difficult. Decent length, I'm really glad I decided to purchase this game.
 
 
 posted in Psych on Mar 26, 14 11:14 AM
The last episode hasn't played yet, it's on tonight EST @ 9pm on USA Network..

When I said tonight earlier, it was after midnight here.

MildewWolf - It has been cancelled

 
 
 posted in Psych on Mar 26, 14 3:04 AM
What do you mean it disappeared? It has been playing on USA Network, in fact tonight is the series finale. You should be able to find several full episodes on USA network. It's sad tonight is the last episode, afterwards the cast will be telling fans goodbye.
 
 
 posted in Deadly Puzzles: Toymaker on Mar 19, 14 12:19 PM
heatherington wrote:What the heck happened to Artifex Mundi? They can't possibly have anything to do with this game. This game looks like something they pulled out of their archives and dusted off and presented to us in the year 2525 that was made in the year 1950 or something like that. Sorry, not wasting my hard earned coupons on this! How many times do we have to say that we want to travel at OUR will, not the developers. Stuck on a map and having to come back to the same humdrum office time and again, the whole game about putting together a remedial puzzle on your desk. Nope, don't think so.


I totally agree with you!!! Very old school straight-up HOG"s. At least give us a choice to play something else instead of HOG such as mahjong or a 3 match game.

Challenging puzzles and addictive mini games?? Really?? Talk about misleading!! Sorry no buy here, even with a coupon...
 
 
 posted in Dark Dimensions: Somber Song Collector's Edition on Mar 17, 14 6:23 PM
harleyrider2 wrote:I'm in the cemetery and having the same tech issue as LyndaLynLou. The diagram for assembling the violin says the order is top, middle and bottom. I put the top in, the middle wouldn't go in, but the bottom piece did. I'm also stuck there and can go no further in the game. I've tried every variation of putting the middle piece in dozens of times. Please help! Thank you.


Don't try to make it fit on there, just drag the middle piece and use your pointer to select where you want to place it and it will automatically go in. Good Luck
 
 
 posted in Dark Dimensions: Somber Song Collector's Edition on Mar 14, 14 11:51 PM
deadravins wrote:
LyndaLynLou wrote:I am at the Ice Sculpture Park. There is an Angel laying on a pedestal. She has the Clock I need. But first I need to put the violin together. It has 3 pieces. I put in the top piece and the bottom piece but I CANNOT GET the middle piece to go in. What do I do? I'm stuck right here. I've been trying for almost 2 hours to get that middle piece to go in. NOW WHAT?? HELP.....



I'm having the exact same issue. Up till then I've had no problems. Hope they can fix this issue as it will make finishing the game impossible. How long do I have to request a 2 credit refund on a game because of a glitch in the game its self?


Me too.. same exact problem..

Got it to work.. don't try to line it up, just drag it and click with your cursor where you want it to go
 
 
 posted in Nancy Drew: The Deadly Device on Feb 11, 14 8:48 AM
spenny1 wrote:Finally!

So very pleased to see this, I have all the others on here and really looking forward to this. For those of you who haven't tried a Nancy Drew, don't forget you can use a PCC on one, which make for incredible value as they are almost all a really good length. I can't see why these wouldn't run, I used to play them on my really old and outdated laptop. Because they don't use loads of special effects etc, they should run fine for most people I would think.

I just hope this one has plenty of puzzles and maybe a replayable game or two, I got totally addicted to the board games in Tomb of the Lost Queen and The Captive Curse games.



Hi Spenny1.

.If you check the main site (that which must not be named)lol.. you'll find all the mini games from each ND game. They are all free to play online.. just go under Play.

edited: maybe not all but a few..
 
 
 posted in Nancy Drew: The Deadly Device on Feb 11, 14 4:45 AM
Here's another one that has a demo: Nancy Drew: The Final Scene.

I agree, it's frustrating not being able to demo these games. There are so many great ones i wish you guys could try. Watch out, they are VERY addicting...
 
 
 posted in Nancy Drew: The Deadly Device on Feb 11, 14 1:46 AM
Nancy Drew: Secret of Shadow Ranch has a 1 hour trial. At least you can try to see if it's the type of game you would enjoy playing. Secret of Shadow Ranch is a lot of fun, I think you'd enjoy it.

Enjoy!!
 
 
Hang in there!! I hope they have a fix for you guys soon!!

 
 
Valdy wrote:There is no SG, Guide or any other word over the Inventory or any other place in the main game scenes (Win 7)

However, when you click on the Bonus section, there is something called “Parable Notes”. It's for the SE and the CE, but you can open the SE version to the first page to see the Parables available. The CE version is only available in the full version.


Well it's suppose to be there Valdy.. I have it on thoughout the main game scenes (Win 7) Mine looks exactly like the screenshots..
 
 
[Removed by Moderator]
 
 
That's weird that you don't see it. It shows up for me on all difficulties and in both demo and full game.

Edited to add Window info

I have Win 7 Home Basic/Vista
 
 
 posted in Mystery Tales: The Lost Hope Collector's Edition on Jan 26, 14 6:32 PM
Okay so i've played the chess game on the door and managed to open the doors but that's as far as I can get. I still have the artifact in my inventory but it doesn't let me move ahead through the doors.
 
 
 posted in Mystery Tales: The Lost Hope Collector's Edition on Jan 26, 14 6:29 PM
When i get to the end after doing the chess puzzle, I can't move forward. I get the doors open and then nothing.. I still have the artifact in my inventory but can't use it. If i can't get pass this point i can't play the bonus portion and I refuse to start over.

Anyone else having this issue?
 
 
 posted in Secret Bunker USSR on Jan 22, 14 9:40 AM
Tauret wrote:I'm not a game club member at this time so I can't check this out until tomorrow, but I was wondering if anyone could tell me what era this game is set in.

With the title saying "USSR" and the USSR having dissolved in 1991 I figure it must be set in the past, just curious of an approximate time frame.

Thanks,
Tauret


The couple were camping in the woods and the woman gets kidnapped by a dark figure. The woman's fiance is trying to find her and happens upon an abandoned USSR bunker. It has been abandoned for many years, so the game itself is not set in the past but the present time.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator