Posts created by raindear82

 
 
 posted in Tesla's Tower: The Wardenclyffe Mystery on Jan 28, 14 12:38 PM
This is the game where you move the wires to connect from top to bottom. Is there a trick to getting the wires to move? I have tried for over an hour and though I managed to get the wires to move 2 or 3 times, I can't get them to move often enough to get the puzzle solved. Every time I click to grab a wire, my hand just seems to slide off. Is there some trick to this that I'm missing?
 
 
 posted in Syberia II on Jan 8, 14 12:31 PM
The medallion is in "Documents" not in inventory. Hope this helps.
 
 
 posted in Syberia II on Jan 8, 14 10:47 AM
I learned to call this type of game "Adventure". Yes, a lot of adventure games are Large File Games. Others of this type that BFG offers and that I enjoy are some of the Nancy Drew games, Carol Reed games, and Sherlock Holmes games. Some that I find pretty difficult, but still enjoy are the Art of Murder series. Another Benoit Sokal game that is available on BFG is Paradise. This is my favorite genre, even though I am not great at it.
 
 
 posted in Syberia II on Jan 8, 14 10:31 AM
According to Wikia Syberia III may release this year or next. I'll keep an eye open for it.
 
 
 posted in Push The Box on Dec 5, 13 7:48 PM
Level 67 has me stymied. Any help?
 
 
 posted in Surface: The Pantheon Collector's Edition on Oct 26, 13 10:27 AM
I eventually solved this by clicking to block unwanted moves and unclicking where I had to. Sorry, I didn't even try to remember or record the order I did it in.
 
 
 posted in Alice's Adventures in Wonderland on Oct 22, 13 6:58 PM
You want to hit the good ones and leave the bad ones.
 
 
 posted in Alice's Adventures in Wonderland on Oct 22, 13 6:56 PM
Click the white roses in the flower bed. Enlarging the scene and setting it as bright as possible in the in game options may help you see the ones hiding in the shadows.
 
 
 posted in Alice's Adventures in Wonderland on Oct 22, 13 6:54 PM
Dallassnoopy, the entire flower bed contains the rosebush, just look for white roses.

lalalady39 and wizard 54, I may have just gotten lucky, but I got the last one by enlarging the scene, setting it as bright (in game options) as possible and clicking the center of the hint circle.
 
 
 posted in Alice's Adventures in Wonderland on Oct 22, 13 2:23 PM
This is a "move the blocks" puzzle. The logs, branches, and rocks are the "blocks". You have to move them around to make it possible for Alice to cross the river.
 
 
 posted in Otherworld: Shades of Fall Collector's Edition on Oct 21, 13 5:27 PM
I really enjoyed the two previous chapters of this game so I didn't even think twice about buying this one. I really enjoyed the game, though I do have 1 minor complaint. You have to collect pieces of a mosaic. When you get the pieces, the mosaic assembles itself. You collect pieces of a shield. When you get the pieces, the shield assembles itself. You collect pieces of a mural. When you get the pieces, the mural assembles itself. I would have loved it if those then became a mini game for using the pieces to assemble the various items. Each time, I looked forward to the "coming" puzzle which never arrived. Other than that minor complaint, I thoroughly enjoyed this and the previous games in the series and look forward to the next (last?) which I will buy and play with great enthusiasm.
 
 
waterpixie wrote: I'm having a problem with the clock also. I found the clock hands but it isn't acknowledging it. I can't proceed with the game. any ideas sorry of uninstalling and reinstalling again?


I am having this same problem. I have the hands on the clock, but it keeps saying the clock has no hands. Restarted the computer, reinstalled the game-still not working. Has anyone found any solution to this one? I'm about ready to start over and see if that will work
 
 
 posted in Sparkle on Jul 19, 13 12:14 PM
It's actually comforting to know that I am not alone in finding this one too hard. I thought it was my age and general slowness. I did defeat Luxor 2, so maybe I'm not a complete wimp.
 
 
 posted in Strange Cases: The Faces of Vengeance on Jul 9, 13 10:10 AM
Take note of which dials affect other dials and which ones.
 
 
 posted in Silent Scream II: The Bride on Jul 4, 13 5:41 PM
All I can say is try to make a large circle around him. You can make it smaller once he is surrounded. Not easy, but doable.
 
 
 posted in Sherlock Holmes VS Arsene Lupin on Jun 25, 13 1:14 PM
After I don't even know how many attempts, I finally found it is possible to go "up" in the Wakefield Tower. If you turn right just inside the door. If you are having trouble, just keep trying.
 
 
 posted in Sherlock Holmes VS Arsene Lupin on Jun 25, 13 11:07 AM
According to the map in the walkthrough this should be near Wakefield Tower. I can't find it. The door on Wakefield tower leads to stairs down to the dungeon, no stairs up. According to the walkthrough you're supposed to start at the green and turn left and go through the brown door on the corner. There is no brown door on the corner the closest to that is on the side of a tower, but it is not accessible, the cursor doesn't change anywhere around that door. I have tried every accessible door innumerable times and if I hear Holmes say "We have to go to the wall walk" one more time I am throwing my computer out the window. Help, please.
 
 
 posted in Shadows: Price for Our Sins on Jun 22, 13 9:55 AM
I was having the same problem for awhile. Apparently, the game has to tell you that they are mirror holders before you can place the small mirror.
 
 
 posted in Shadows: Price for Our Sins on Jun 22, 13 8:37 AM
There is a shelf with books on it. To the left of the books, there is some straw or something that obscures the lollipop.
 
 
You might be in the third battle of this sequence. In this battle you have to move the smoke from the symbol on one side and find the matching symbol on the other side. All the symbols are under black smoke. This section had me crazy, too. The monster kept shooting rocks at me and I had no idea what I was supposed to do. It seemed like nothing was happening for a long time before I figured it out.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator