Posts created by MzShel

 
 
 posted in Dragon Keeper on May 15, 11 12:08 AM
When replaying the first cave to get the trophies, I click that I want to skip the tutorial -after all I don't need to learn the game - but when I get a second gnome (or whatever) to clear the rock piles and bushes the game puts up an arrow saying "click here to send the gnome". However, it's pointing at a blank space. I can't "click here" because nothing is there. Yet, when I click on rocks or bushes it won't send the gnome because it wants me to click where the arrow is pointing. I have to go back and restart the whole cave over.
There are several little glitches like this that spoil the fun of the game. Something for the devs to think about when designing a sequel.
 
 
 posted in Youda Survivor 2 on Apr 23, 11 9:03 AM
I'm in the same boat. I have all the but the last two trophies. I've tried searching randomly for the levels where I missed the masks, but there are just too many and no way to tell if I've already gotten the masks/medallions or not.
 
 
 posted in Youda Survivor 2 on Apr 19, 11 4:43 AM
Not 100% sure how I did it. I know it took several tries to get it. You have to have all the upgrades. I remember freezing time. Digging the holes. And then using the musical note to make them all quickly drop eggs. Just not sure which order I did it in.
Sorry to not be more help.
 
 
 posted in Youda Survivor 2 on Apr 16, 11 6:24 AM
It's so strange that this came out today. I had a credit sitting there waiting for something other than a HOG. And while I waited I've been rediscovering my older games that I hadn't played in a while. The last 3 days I've been playing YS1. Looked to see what was offered this morning and spent my credit without even demoing the game.
THANKS!!!
 
 
 posted in The Timebuilders: Pyramid Rising on Mar 6, 11 11:56 AM
I managed to get 21 and 26. Don't ask me how I managed to get 21. I'm still in shock over getting it. I just know that I kept the market until the last minute, and I got almost all the stone before building the bridge.
The only ones I can't get now are 25 and 29.
 
 
 posted in The Timebuilders: Pyramid Rising on Mar 4, 11 8:04 PM
Dang! I was hoping there were some solutions here. I'm in the same boat as y'all! Can't get gold on these levels no matter what I try.
 
 
 posted in The Timebuilders: Pyramid Rising on Mar 4, 11 4:49 PM
Looks like I'm in good company. I can't even get close either.
 
 
 posted in Roads of Rome II on Jan 1, 11 1:17 PM
I have no idea why I find these games (1 and 2) so addicting, but I can't seem to get enough. I play them over and over. Thank you for these wonderful games, and how soon until we see Roads of Rome3?
 
 
 posted in Pengu Wars on Dec 13, 10 5:01 AM
First, no instruction on what you are supposed to do to launch the Pengus.
Second, you can't see what you are aiming at, so it's all guesswork.
Third, the music was the worst I've ever heard on a game.
On the whole, it seemed a very pointless game with no redeeming value.
 
 
 posted in My Kingdom for the Princess II on Sep 12, 10 10:45 AM
I'm having an issue with the game. It plays fine. However, one level where you need to clear a bunch of rocks it won't go above 20 gold. You collect it and your mine is making it, but 20 is the limit. Is this part of the level? Because it sucks. You need to clear about 8 piles of rocks at 17 gold each and the gold doesn't build up fast enough between clearing the rocks. If the stockpile of gold doesn't go higher than 20 it makes the goal impossible to meet.
 
 
 posted in Veronica and the Book of Dreams on Aug 23, 10 3:30 PM
Can't create a profile, so I can't even play. Disappointing!
 
 
 posted in Country Harvest on Aug 8, 10 8:38 AM
I'm already having technical issues. It won't load the saved games, so I have to start all over again. The tutorial lady gets stuck on the screen if you get ahead of her (which you do if you have to start a new game instead of loading a saved game).
Other than those issues, I was enjoying the game and looking forward to leveling up and getting more tasks. But I'm not buying until the technical issues are resolved.
 
 
 posted in Making Mr. Right on Jul 1, 10 8:23 PM
stephcatstar wrote:
mreitan14 wrote:i am having issues with the game not working properly. I am not able to...im guessing...build stations? I clicked on the phone and then on the proper icon and then nothing. I have tried uninstalling the game and reinstalling and still no luck. what now please??


im having this same problem i click on the phone as it tells me to but when it says click on the station to pick it up there is nothing there where the arrow is pointing infact there is nothing anywhere


Ditto. I've tired three times (creating new profiles so it will start with the tutorial again). I follow the instructions in the tutorial exactly and nothing.
 
 
 posted in Farm Frenzy 3: Russian Roulette on Jun 30, 10 8:23 PM
Is there ever going to be an update to fix the issues in endless mode? It's a very fun game until you get goals that all revolve around building rockets (which crash the game) or watches (which are never offered in endless mode).
 
 
 posted in Blood Oath on Jun 19, 10 9:16 AM
spiritdog51 wrote:Holy Moly, overwhelmed from running from room to room to room and back again, way to much chasing of items. One piece in the den, another elsewhere, another elsewhere. Glad my hour is up.


I couldn't agree more. I spent way too much time going from room to room and then another room just to get to the destination I needed to get to. And then back through all those rooms just to get the pieces back to where they needed to go.
While I found myself wanting to know how the story ends, I just am not willing to spend all that time running from room to room to continue after the hour demo.
 
 
 posted in Farm Frenzy 3: Russian Roulette on Jun 6, 10 4:42 PM
minmu wrote:
tamweb73 wrote:While playing in endless mode one of the goals is to have 10 watch plans but they are not available for purchase.


That was one of my first goals and it was frustrating for it to be impossible to fulfill. When I kept going, eventually I received the goal to build watches and was able to buy the plans and clear the goal. However, I don't like impossible goals blocking one of the spaces until an advanced level is reached.

I also experienced the bug that about one-third of the time I build a rocket, the game crashes to the desktop.

Also, I don't think it is possible to use the Mega Cake machine in the endless mode since there is no way to buy or make the prize ribbon (made from horns in other versions).

I enjoyed the Farm Frenzy games, but the amount of bugs and problems have really taken the fun out of them.


Same problems here. Except I played for over 3 hours and never got the watch plans for purchase. I love the Farm Frenzy games, but this one is turning out to be very frustrating.
 
 
 posted in Youda Legend: The Golden Bird of Paradise on Jan 2, 10 2:07 PM
Glad it's not just me finding this game slow moving. I figure when you click the hint and you spot the item before the hint can point it out, the game moves way too slow. I didn't even finish the trial.
 
 
 posted in Save Our Spirit on Sep 25, 09 2:50 AM
02bkiwi wrote:I had no problem with the download - played for about 10 minutes and the game crashed. Tried playing again and it crashed in the same place. Anyone else have the same problem?


Exactly the same for me. Downloaded just fine but crashed in the exact same spot yours did. Haven't tried playing again to see if it crashes again, tho.
 
 
 posted in Save Our Spirit on Sep 25, 09 2:45 AM
Also crashing right after the gears.
 
 
 posted in Farm Frenzy 3 on Sep 10, 09 5:30 PM
I love the Farm Frenzy games. They are the ones that I purchase without even doing the trial. This one does not disappoint. For those having problems with slowness and graphics, I'm sorry and I hope you get yours fixed soon. Mine is working great...knock on wood.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator