Posts created by jennsmom

 
 
 posted in Cadenza: The Eternal Dance Collector's Edition on Jan 16, 18 9:25 AM
So, I went to check my achievements, and even though I finished the bonus game, that achievement was blank. What happened?
 
 
 posted in Cadenza: The Eternal Dance Collector's Edition on Jan 13, 18 1:43 PM
I'm enjoying the game; I'm interested in the story; I like that it's a different collectible this time but I am SO disappointed in the music! Bummer, considering the games before, especially the first two!
 
 
I join in the complaints about this SG. In fact, the last game I purchased from this developer seemed to have similar issues. Perhaps I should just wait for the SE to come out, and use hints, or an ordinary walkthrough that I'm not paying for.
 
 
GAMECLUB
 
 
 posted in Grim Facade: The Message Collector's Edition on Jan 2, 18 4:39 PM
william1984 wrote:Having the same problem. Why does it take them so long to get a solution. After all of their suggestions do not work, there is clearly a problem. Fix the problem...so we can finish the game that we purchased.............or give us a refund...


I'm going to guess there will be no fix forthcoming, but BigFish has always been very good about giving replacement coupons if you contact customer service, explain the problem, and ask.
 
 
 posted in Grim Facade: The Message Collector's Edition on Jan 1, 18 6:52 AM
Trinaleena, running the game as administrator doesn't work either, so looks like having Mac or PC doesn't matter.
 
 
 posted in Grim Facade: The Message Collector's Edition on Dec 31, 17 8:28 AM
vsvillanoseven wrote:So, I'm in the Bonus Chapter and trying to put the continents in the globe, and it's frozen, also trying to put the deer on the shelf, frozen. Even on the map, there's no indication that there's anything to be done. I'm stuck and can't go further. I checked the strategy guide, and there's no indication that there's anything I missed. It's just stuck and I'm upset.

Anyone having the same problem?


Yes, same problem. Can't put Aries on the desk where it is supposed to go according to the SG. Cannot progress in the game, so I've spent extra money for a CE that I can't finish. Nice Christmas present.
 
 
 posted in Grim Facade: The Message Collector's Edition on Dec 30, 17 10:23 AM
judy76073, after hitting skip at the 6th gimmick headhunt (because a few is fine but every 5 minutes is boring), I came here to post about it, and found your comment. Spot on! Thank you.
 
 
 posted in The Unseen Fears: Outlive Collector's Edition on Dec 30, 17 6:30 AM
I will say upfront that I have not played the demo. My brief review is from the Beta. The "heroine's" voice drove me up the wall. It was a stupid story line about a survival game and an Evil Entity and the director turns out to be a faun?!? Puzzles I hate, gimmicks I don’t like - two kinds of tattoo gimmicks. It would have to be a desperation buy during a true ½ members price sale. All that, and I see from another review that the bonus game is a prequel, which I personally dislike. So, .
 
 
 posted in Yuletide Legends: Frozen Hearts Collector's Edition on Dec 29, 17 10:57 AM
I can only suggest you keep trying. Perhaps close out the game and then come back. This was only one of the many things that annoyed me about this game. I think it took me 4 or 5 minutes to get that stupid backpack open. Hope you have better luck!
 
 
 posted in The Christmas Spirit: Trouble in Oz Collector's Edition on Dec 21, 17 11:28 AM
This was a most enjoyable game. The music was appealing, I liked the story line. There was a nice mix of puzzles and only 1 that I hated, which is a record for me.

I played the entire game and the bonus with no issues. I rather liked being Dorothy and having a happy ending - for both the main and bonus games. Also, enjoyed decorating the Christmas tree. It was a fun experience, especially after playing this year's Christmas Stories which had me tearing my hair out because of glitches.

I'll look forward to playing this again next year.
 
 
I'll go back and try that. Thank you.

Edit to say: You don't have to drag them. They should move along a track to an empty space. Why nothing would move for the when I tried before, I don't know. I started a new profile, and it worked fine. So, since I'm hooked on Dupin (which I do NOT pronounce DUPE in), I'm off to purchase the game.
 
 
I'm having trouble with the circle puzzle that needs to be solved to get the rune in the room with the piano. I can't figure it out. Even after looking at the SG. The pieces will light up if I click on them, but I can't make anything move. I assume it's because I'm not doing it correctly. Can anyone help? If I'm stuck on a puzzle this early in the game, I'm probably not going to purchase it, and although I keep saying, "No more Dupin," I end up with him anyway.
 
 
 posted in Christmas Stories: A Little Prince Collector's Edition on Dec 16, 17 6:27 AM
I finally finished the game because I was determined to do so. I had screen freeze at least 4 times during the bonus game alone. No, my video card does not need updating; I checked. There were also 2 puzzles which didn't work - in that I could not move things I was supposed to move. For example, the levers in the train puzzle would not move. I loved all the previous games, but this one gave me nothing but trouble with glitches. Very disappointing, and I probably won't play it again, as opposed to the previous games, all of which I have played at least twice.
 
 
 posted in Christmas Stories: A Little Prince Collector's Edition on Dec 12, 17 12:21 PM
I've stopped the flashing, but now, I have screen freeze and had to CAD to leave the game. Also, when I tried to do the train puzzle, nothing would move properly, and yes I checked the SG; I had to skip. I have all the other games in this series and have begun to look at them as a Christmas present to myself. This one is turning out to be an unpleasant one, and especially disappointing since there were no problems with the beta.
 
 
 posted in Christmas Stories: A Little Prince Collector's Edition on Dec 12, 17 11:21 AM
Widows 10 - I played the Beta for this with zero problems, so I purchased the game without doing the demo - more fool I. At any rate, I'm still at the first part of the game, and just finished in the Present Room when the screen started flashing, making play impossible, and just closing out the game, difficult. What's up? I really wanted to be able to play this game.
 
 
 posted in Danse Macabre: A Lover's Pledge Collector's Edition on Dec 2, 17 2:52 PM
I played the beta for a short time and thought it was a disjointed story with nothing appealing about it, including my job as a seamstress. Puzzles that I hate doing, although I realize they may appeal to others. Woman in peril keeps getting hung up in ropes over the stage. Didn't I just get her down from there? Directions for one puzzle were sadly lacking. Not as good as any of the previous games, at least in the beta, and I don't see from the reviews over all, that it has improved enough for me to try the demo. If a true half price sale comes up, I might consider it.
 
 
So, after trying at least 25 times, I hit skip. I watched it finish. I had done exactly the same thing. It's very frustrating to have to skip a puzzle that has an obvious solution.
 
 
I cannot get past the first lock. I have all but three bearings gone, but when I click on one to send it down, it instead moves the ball below instead of the one I'm clicking on. Anyone have any suggestions before I throw my hands up and skip it?
 
 
I played the entire main game without a smidge of trouble and now I'm trying to play the bonus. I'm as far as the puzzle with the car and the arrows, and get "Runtime Error." Any suggestions?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator