Posts created by Penguin29

 
 
I also just finished... great game - really enjoyed. Wished it would have been a longer game though.
 
 
If I remember, I had to tip the head of either the ballerina or the nutcracker down one more notch and that worked. Good luck
 
 
 posted in Adam Wolfe: Flames of Time on Dec 9, 16 10:37 AM
This is a FANTASTIC game - and I'm only 1/2 way through. Very different from the other games I've played lately. Great story and very engaging.
Would love to see more games like this.
 
 
 posted in Chimeras: Mortal Medicine Collector's Edition on Nov 12, 16 10:28 AM
Just about to finish the bonus game.. So far, no tech issues... YEAH! I'm really enjoying this game. The only thing for me is that this game was a little too short. I played the regular game in under 3 hours (only skipped one puzzle and I moved from location to location on my own and didn't use the map to jump). Very clear, bright scenes. Some cool puzzles.
Last thing I wish to mention is that the end of the regular game there is a stuffed rabbit that needs be cut open. I had a scissors in my inventory (the little one), but, I had to go out and find another pair of scissors (a bigger pair) to cut open the rabbit. Why could I just not use the scissors I had??? Happy Playing!
 
 
 posted in Dark Romance: Curse of Bluebeard Collector's Edition on Nov 1, 16 8:04 AM
Installed update... started game over from beginning with new profile. Just finished the entire game including bonus chapter.. no tech issues/no problems at all. Have fun!
 
 
 posted in Dark Romance: Curse of Bluebeard Collector's Edition on Oct 21, 16 10:20 AM
installed update... did not work. Now I'm outside the house where I'm supposed to place the harpoon, however, there is no harpoon anywhere nor is it in my inventory. So, still cannot move forward. May try just staring over from the beginning.
 
 
 posted in Dark Romance: Curse of Bluebeard Collector's Edition on Oct 17, 16 9:54 AM
yes, me too... i put the rope and the harpoon on the crossbow. I shot it to the tree. Then, I had to pick up a stick and get another rock (2nd time) and now all I get is a close up of the tree... and it states "if I had a harpoon and rope, I could get to the other side". Well, I did that and I'm still not on the other side. Cannot continue playing. Want a refund as well if issue is not fixed.
 
 
I just started playing.. 10 minutes in and I LOVE this game. It's a buy for me already. Yes, the BIG mushroom is a little annoying but not that bad - I can ignore that. Off to play. Enjoy the big, beautiful graphics and wonderful story.
 
 
 posted in PuppetShow: Her Cruel Collection Collector's Edition on Sep 19, 16 4:13 PM
I had a bit of trouble with that also. Try putting it on the screen by itself. Then, pick it up and drag into on tho the wolf's body. that worked for me
 
 
 posted in Haunted Hotel: Silent Waters Collector's Edition on Sep 18, 16 8:31 AM
OK.. 2nd post. My map finally started working again. I saved Maggie and put her on the couch - now I have to fight the skeleton guy in Lucien's room. All of a sudden, the screen froze and nothing worked. I had to ctrl/alt/del to get out... tried to go back into game and play and now I cannot even get back in.. all I get is a black screen with the cursor. ???????????
UPDATE: I re-started my computer and was able to finish the game. I did not play the bonus chapter yet.
 
 
 posted in Haunted Hotel: Silent Waters Collector's Edition on Sep 17, 16 4:10 PM
Cursor lags for me as well.. and YES, I just discovered my map is no longer working as well. Windows 10. I've been doing things in the event hall and now I just made it into the restroom. Please fix
 
 
 posted in Dark Dimensions: Blade Master Collector's Edition on Jun 19, 16 8:30 AM
Just finished. Game was OK.. I was able to skip some puzzles (skip was at lower right). Not very long... finished full game including the bonus chapter in 4 hours.
 
 
 posted in Black Swan on Jun 1, 16 9:20 AM
Stuck as well.. I did get out of the game and it let me replay that HOS... however, at the end I had the ballerina and was stuck again,. said I had to click on the 1/2 eaten cookie which I already did. Cannot move on
 
 
I purchased the game.. just fnished with the game and the bonus chapter. no glitches at all for me... I did not have to use the skip button where other people did (that is where they got stuck).
 
 
 posted in Elly Cooper and the City of Antiquity on Dec 23, 15 7:04 AM
me too.. I was playing around with the nutcracker doll before I had the nut and the left arm fell off... it's not in my inventory. now I have the nut, but am unable to crack it. I'm stuck and cannot move on. I'm going to have to start over.
 
 
 posted in Secret of the Pendulum on Dec 16, 15 10:14 AM
all I remember is that one is in the dinosaur's mouth. good luck
 
 
 posted in Christmas Stories: Puss in Boots Collector's Edition on Dec 7, 15 3:12 PM
Windows 7 - yes, it cut off the cat's dialogue for me too in the beginning sections. The runes in the bonus game also disappeared for me... what I did is click in my inventory where they were pictured and then clicked on the screen where there are supposed to go and it worked. They showed back up. Just finished. While I really enjoyed this game, most of it ran "clunky", no smooth transitions from scene to scene. And I encountered the "floating cursor".
 
 
 posted in Red Riding Hood: Star-Crossed Lovers on Nov 30, 15 2:53 PM
pretty basic and simple fun... more HO than games. And, VERY VERY short game
 
 
 posted in Red Riding Hood: Star-Crossed Lovers on Nov 30, 15 2:51 PM
you have to place the sifter right in the middle of the lake on the middle nuggets. That worked for me
 
 
 posted in Beyond the Legend: Mysteries of Olympus on Nov 27, 15 10:23 AM
go back to the stairs where posideon is on his chariot... tie the thread around the 2 statues - statue on the right and left
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator