Posts created by RainbowExplorer

 
 
 posted in Sonya Collector's Edition on Sep 25, 11 2:28 AM
Fykomfei wrote:The hint system does not work. When I click the hint button, there there is a "pling", but no hints...can anyone help?


What are you trying to get "help" on, when you're clicking on the HINT button - a HOG item, directions as to where to take an item, what step to pursue next, etc.?!?! The more details you can give about EXACTLY what you're trying to get the HINT button to help you with, the more accurately we can answer your question.

In the meantime, have you been using your Strategy Guide for help and guidance? If you would prefer to use a more traditional Game Walkthrough, there is one available with the "Sonya SE Version" game, which can be reached by clicking on this link:
http://www.bigfishgames.com/blog/sonya-walkthrough/?npc=social&npv1=eng&npv2=fr&npv3=bfg&npv4=eng&npv5=sonyawt&npv6=20110923&npi=engfrbfgengsonyawt20110923 .

If the HINT button never works any time, for any situation, then you're probably experiencing a technical glitch. If that's the case, then you will need to contact the Customer Service staff via "Live Chat" (if you're a member) or by clicking on the GREEN ENVELOPE, to your right.

Best wishes to you!

Rainbow
 
 
 posted in Sonya Collector's Edition on Sep 25, 11 2:17 AM
kassjac wrote:I have exactly the same problem. Can you give me details on what to do about my driver, or however you fixed this?? Thanks.

Jackie


For technical questions regarding drivers, memory, errors, and other issues, just click on the GREEN ENVELOPE to your right. All of the answers are there and organized into related sections.

Best wishes!

Rainbow
 
 
 posted in Sonya Collector's Edition on Sep 25, 11 2:14 AM
kassjac wrote:He won't give me the crystal. I give him the meat and he just stares at me. The screen is not stuck. I can go in other directions and do other stuff. I just can't get him to cough up the crystal. HELP!

Kassjac


Place the meat on the ground directly in front of HER (she's a mom)! If that doesn't work, then you'll need to contact Customer Service either through "Live Chat" (if you are a member) or through the Green Envelope (to the right). This game continues to have multiple technical glitches in it, so you may be encountering one of the more common ones.

If you're having trouble using the Strategy Guide and/or would feel more comfortable using a more traditional Game Walkthrough, there is one available for the "Sonya SE Version" game. You can access it by going to this link:
http://www.bigfishgames.com/blog/sonya-walkthrough/?npc=social&npv1=eng&npv2=fr&npv3=bfg&npv4=eng&npv5=sonyawt&npv6=20110923&npi=engfrbfgengsonyawt20110923 .

Best wishes to you!

Rainbow
 
 
 posted in Sonya Collector's Edition on Sep 25, 11 2:08 AM
Have you checked your Strategy Guide to see if you've done everything you need to do to locate it (behind the fireplace in the Leader's Room)? If you're having trouble using the Strategy Guide, there is a more traditional Game Walkthrough available for the SE Version of the "Sonya" game. The link to it is here: http://www.bigfishgames.com/blog/sonya-walkthrough/?npc=social&npv1=eng&npv2=fr&npv3=bfg&npv4=eng&npv5=sonyawt&npv6=20110923&npi=engfrbfgengsonyawt20110923 .

If you have followed all of the steps correctly, yet a location or object is not doing what it is supposed to be doing, then you are probably encountering one of the many remaining technical glitches in this game. For those technical bugs, you will need to contact the "Live Chat" (if you're a member) or the Green Envelope Customer Service staff members, for help.

Hope you get this cleared up soon!

Rainbow
 
 
 posted in Sonya Collector's Edition on Sep 25, 11 2:00 AM
anteg wrote:I get stuck everytime I turn around! Cursor doesn't work right, and every time I go down into the well to retrieve the globe and the slate, the game crashes!

I'm real sorry I bought this game without a walkthrough. I didn't realize it didn't have one!

Please, can we get a walkthrough????


There are MANY technical glitches that persist with this game. If you would like to use a traditional walkthrough, there is one available via the SE Edition of the Sonya game (at this link: http://www.bigfishgames.com/blog/sonya-walkthrough/?npc=social&npv1=eng&npv2=fr&npv3=bfg&npv4=eng&npv5=sonyawt&npv6=20110923&npi=engfrbfgengsonyawt20110923 ).

Generally, I've found that the cursors provided by many game developers don't work well on my computers. This may be the case for you, as well. So, try turning off the specialized cursor, in the "Options Section", to see if that will make your game playing smoother. Any additional technical issues need to be brought to the attention of the "Live Chat" or Green Envelope Customer Service Staff. They can help you sort out if it's a technical problem or a user problem.

Best wishes to you!

Rainbow
 
 
 posted in Sonya Collector's Edition on Sep 25, 11 1:50 AM
This is just one of many technical glitches this CE Version of the game has got going on with it. They have yet to fix many of the serious bugs in this game. You might find that you are more successful when playing the SE Version of the game. If you haven't already bought the CE Version, I'd encourage you to try the SE Version, to see if it works better for you (it does for me, so I returned the CE Version, got my money back, then used a free coupon to get the SE Version). If you've already bought the CE Version, then you'll need to contact the Customer Service staff (preferably via "Live Chat" - if you're a member, or via the Green Envelope, if you're not a member), to get technical assistance from them.

Best wishes to you!

Rainbow
 
 
 posted in Sonya Collector's Edition on Sep 25, 11 1:32 AM
I never WAS able to get the CE Version of "Sonya" to work for me, after I bought it. It repeatedly got stuck at the foggy red bridge, despite every tip and suggestion the BFG Customer Service staff could come up with. Thus, I got my money refunded.

Once the SE Version came out, I didn't have ANY trouble playing IT at all! This is the second or third time that this kind of scenario has happened for me - I can't get the CE Version to play correctly at all (lots of bugs), but the SE Version plays just fine. However, I HATE the ending of the SE Version and wish I could have played the Bonus Game material from the CE Version. To me, the SE Version's ending is sloppy, abrupt, and appears thrown together without much thought or care. What a letdown, after all I've been through, with this game!

Rainbow
 
 
 posted in Sonya Collector's Edition on Sep 25, 11 1:20 AM
To me, it just adds to the drudgery of a game - the endless "fetch & carry", without any real purpose to any of it - except to drag everything out, endlessly and needlessly. I was so annoyed that we couldn't use the water faucet in the kitchen, rather had to climb out the window, climb in the bathroom window (to get the water there), then climb back out the bathroom window, then climb back into the kitchen, I was ready to CHOKE the developers! That kind of nonsense is pointless and irritating. It takes away from the pleasure of a game and turns it into "busy work".

As far as I know, no regular computer game player PLAYS GAMES, because they don't already have enough "busy work" or "meaningless tasks", in their lives! Most of us prefer to feel like we're actually achieving something, when we're playing a game, not just challenging ourselves to see exactly how INEFFICIENT one person can be, in any given gaming situation! My belief is that many game developers really don't believe that most computer gamers are very intelligent - thus, they don't think we'll notice their obvious ploys. My experience tells me, however, that they are DEAD WRONG and that we've been onto their manipulative tricks, for a longgggggg time!

Rainbow
 
 
 posted in Awakening: The Goblin Kingdom Collector's Edition on Sep 25, 11 12:54 AM
volleyheads wrote:Has anyone figured out how to load the program yet. I did an hour long download after purchase and it's back to Trial. Can't seem to install.


Hi Volleyheads,

The problem you are describing is a common one that dozens of us are having with this game. The developers, Boomzap, as well as BFG Customer Service, are well aware that many of us can't even sign into the game, let alone play it, as it automatically sends us back to the Game Manager, every time we attempt to play it.

It is one of the glitches that they are working on fixing for us, though it's completely unclear just how long it will be before all of the major issues will be fixed. The problem isn't with your computer. It is with the game, unfortunately. Thus, we're all practicing our "patience" skills! LOL
 
 
 posted in Awakening: The Goblin Kingdom Collector's Edition on Sep 25, 11 12:50 AM
Elfinne wrote:I have purchase this game CE and from start I can't even click on the items I need to click on. I have tried ways but of no use. No matter how i click, i cant get the items. I got a hard time licking to feed the dragon. When able to i was relief as finally able to continue the game and to my horror after moons puzzle on the panel to unlock the generator, I got stuck as being not able to click on the items i am suppose to get inside and whenever i backout and back in again, it shows 2 panel with moon puzzle with one of them unlocking as i go into the screen and still the items inside is as much as dead to get. I have try to uninstall and install a trial version, try using custom cursor, reload and reload the game still clicking more then 30 time on an item does no use.

I am not able to play in window mode as it says my resolution is too small. I am using win xp pro.i dun have problems with the other games i bought frm bfg.

Is there any fix the bug version for this games as i really love the previous 2 edition.

I cant find anyways to get the game to go on as i am stucKK!!


Hi Elfinne,

I just want you to know that most of the problems you are having are the same ones that MANY other game players are having with this game here at BFG . The game developer, Boomzap, is working hard to make a BIG FIX for this game, as it has many major technical glitches. No one knows yet, when the BIG FIX will be finished and ready for us to try out. Please contact the Customer Service staff, via "Live Chat" or the green envelope (on the right), and let them know about the problems you are having. Best wishes to you!

Rainbow
 
 
 posted in Hanging Gardens of Babylon on Sep 25, 11 12:41 AM
Well, this demo trial was an EXTREMELY short one, for me. The game shows a short introductory cutscene, explaining about the history of the Babylonian Hanging Gardens. The first time it showed this "cutscene" to me, it was very informative. Then, it somehow "relooped itself" into playing the exact same "cutscene" again, only this time it was "flashing" the scene, really rapidly - so fast and bright, that if I had had a seizure disorder, it might have triggered a seizure!

When it finally got to the place where you can sign in your name, I did so. However, when I attempted to click on the "Options", "Exit", or "Play" sections, they kept flickering so fast, that my cursor got completely lost in the fray. Thus, I ended up having to "soft boot" my computer, to get the game to shutdown. Needless to say, I won't be buying this game!

Rainbow
 
 
 posted in The Seawise Chronicles: Untamed Legacy on Sep 25, 11 12:19 AM
Hi All!

Just a friendly word of advice, for those of you considering buying this DD game, today. This is a game with a longgggggg history of multiple glitches, problems, and technical "fixes". Despite all of that, many people are STILL unable to play this game through to completion. Though most people DO demo trial all games before they purchase them, this is one where all potential buyers will absolutely want to do so. The likelihood of you having technical glitches is HIGH and most people want to know about this BEFORE they buy the game, rather than afterwards (in my experience).

Just a cautionary word that I hope will help!

Best wishes!

Rainbow
 
 
 posted in The Seawise Chronicles: Untamed Legacy on Sep 25, 11 12:13 AM
This game tends to be full of glitches of all types, despite numerous "fixes" having been created for it. I had to work with Customer Service for weeks, on this game, as the Symbol/Rune game, in the Cyclop's Cave wouldn't work for me and was not skippable, so I could never get beyond it. There had been several problems, prior to that one, but that was, ultimately, the one that neither Customer Service, nor I, could ever resolve. Thus, this game remains permanently unfinished, for me.

Rainbow
 
 
 posted in Sonya on Sep 24, 11 11:59 PM
For those of you having cursor problems, I have learned to nearly always choose NOT to use the game's cursor, but to turn it off (in the Options Section). Very often, the elaborate, beautiful game cursors don't work well or with as much precision, as my standard, plain Windows cursor does. Sometimes, this ONE CHANGE is enough to make the whole game more cooperative. I can't tell you why, as my computer knowledge is too primitive. I just know it's improved my ability to play many games here at .

Rainbow
 
 
 posted in Sonya on Sep 24, 11 11:45 PM
SPOILERS: I bought this game in the CE Version, over a month ago. Sadly, it was so full of bugs then, that I couldn't get past the red fog-covered bridge scene, no matter what the Customer Service staff had me try. After a series of e-mails back and forth, we finally gave up on trying to get it to work, so my money was refunded.

Since I had plenty of free coupons available, I decided to try buying the SE Version. It played perfectly, without any problems at all! This is the second or third time this has happened to me - where the CE Version won't play correctly, but the SE Version will. Unfortunately, though the game was BEAUTIFUL and had LOTS of potential, I, too, found the story to drag and to wander around without any clear sense of direction, much of the time. So many questions were raised about who the "Dark Lord" and "Bandit Brothers" were, that were never answered, and the machinery inside of the "Dark Lord's" Castle was so convoluted and confusing, most of what I did there was just click on the "hint" button, over and over, to tell me what to do next.

Very little could be deduced intuitively or logically. Why the Bandit Brothers killed one of their own, was never addressed, nor why they continued to work or live together, if they really didn't trust each other that much, was unknown. Telling us to "skate right" across the mechanical room's floor was an impossibility (one can only skate LEFT there, to get to the electrical box!), nor was it ever clear why one needed to skate, at all?!?!?

I never understood why the seasons changed in the fountain courtyard area, nor why Sonya couldn't go home via the portals she came through. The ending was the worst part of the game, IMHO. It was so abrupt and unfocused, it made it obvious, to me, that that ending was just "thrown together", while the genuine (original) ending must have been the one included in the CE Version (which I was never able to see/play).

What was the point of having the dragon in the game? I thought we'd return there, at some point, since the wolf crystal allowing entrance, was left behind for us to re-enter. Why did the dragon HAVE the wolf pups, in the first place???!?!? Why was the blue mirror broken? There were so many disconnected objects, pieces, places, and events, it was difficult to follow several sections of the story line.

Obviously, they plan on making a sequel. I hope it's better than the first!
 
 
 posted in Urban Legends: The Maze on Sep 18, 11 7:31 AM
Audreyfavre wrote:Gregs Girl,
Thank you so much. I was having the same problem as a lot of others...getting the trial expired message and then after two uninstalls and reinstalls never getting out of the game mgr.
Installing the old 3.0 version worked like a charm for me. I played a few minutes, then quit and went back in to make sure it took me to where I left off. It did. So far, so good.
Oh, and I read something very interesting while in the "announcements" forum. Anyone who wants to participate in the BF quest to help figure out what's wrong with their new game mgr. can receive 10 game credits! I haven't had any problems before now, but for those who have, this sounds like a great deal. Check it out.
Audrey


Usually, I'm one of the FIRST people to have problems with playing a game, probably because I have an older computer, though everything on it (in terms of drivers and updates, is current). However, I downloaded and played this demo trial, earlier this morning, without any trouble. Having been down the repeated roadway full of gaming troubles, though, I'll be willing to bet that if I were to buy this game, today, it wouldn't work any better, for me, than it has for several others who played the demo fine, only to have problems AFTER they bought it. That's a familiar experience, for me.

Learning that BFG is asking for help in sorting out these ongoing gaming issues is an encouragement, to me. I will happily volunteer to work on that project with them. I don't MIND being a Beta Tester and have done it a handful of times.

However, I become resentful when I am FORCED into the position of "informal Beta Tester", by purchasing a game filled with developer-known glitches and/or poorly Beta Tested games, then have to spend valuable resources, including DOZENS of hours of my time, trying to get my new game to actually PLAY! If I'm going to BE a Beta Tester, I want to take on that role with my full KNOWLEDGE AND CONSENT!

Thus, I won't be buying this game, this weekend, as I don't trust it to continue to work correctly for me. Instead, I'm off to volunteer to help figure out WTF is going on with the Game Manager and recent CE Version of games around here lately!

Shalom to all!

Rainbow
 
 
 posted in Awakening: The Goblin Kingdom Collector's Edition on Sep 10, 11 8:24 AM
I've done everything just short of "dancing on the head of a pin", trying to demo trial this game. Customer Service is pretty much out of ideas as to how to get the game to play for me. The BFG and Boomzap logos are displayed (with the music playing), then the loading bar fills all the way across the screen, then I'm instantly taken back to the Game Manager, without ever being able to even sign in my name.

It took me more than 30 minutes, tonight, to finally even be able to watch the mini-video of the game, that is double-posted on its description page. The video system has been broken for months and Customer Service tells me they have no clue if or when they will ever be able to fix it. It's hard to be patient, when I don't know if I'll ever be able to play this game, or not.

During the CE version sale, I bought a bunch of CE version game and didn't have any trouble with any of them, so my machine isn't the problem. It's been checked up one side and down the other and all my settings are where they are supposed to be, according to Customer Service. The earlier two sequels didn't seem to have so many technical glitches with them. I can't help wondering why this one is...

Rainbow
 
 
 posted in Sonya Collector's Edition on Aug 29, 11 12:20 PM
rbusran wrote:Where is the rope ladder in the man's tree house??
The hint says "pull down the rope ladder with a cane". Where is the rope ladder? The hatch in the room near the man on the bed says "I need a key"?
The hint is confusing !!! please help


There's a "Tree Lookout/Workspace" in the tree directly in front of the Bridge covered with red smoke/fog. There are several tasks that will need to be done in that "Tree Space", so it can get confusing, trying to figure out which "Tree Location", the Walkthrough is refering to. The Rope Ladder dangles part-way down from the tree, but is too short for Sonya to reach, until she pulls it all the way down with the cane she gets that is lying on the bench, in front of the Dwarf's Tree House.

Best wishes!

Rainbow
 
 
 posted in Sonya Collector's Edition on Aug 29, 11 11:18 AM
jagdhund wrote:I just read the other postings and I won't even reach the scenes which are talked from. After updating and new installing the game I tried to play with a new profil - but it ALWAYS freezes in the scene with using the blue orb. If there are problems in the first chapter, I won't even try the following .... though the game is running. First time I regret having bought a game.

PS: I donit like the new game manager too - the older one looked mor sympathical.


I've had repeated troubles with the red portal orb. When will the orb problems be repaired/their "glitches" fixed? There have been several gamers here with them.

Rainbow
 
 
 posted in Sonya Collector's Edition on Aug 29, 11 11:16 AM
There's nothing in the new build that address any of the portal balls that don't act correctly. When will those glitches be repaired?


Rainbow
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator