Posts created by MLC60

 
 
 posted in Sharpe Investigations: Death on the Seine on Jul 15, 14 8:06 AM
[Removed by Moderator] I thought this was a rather pleasant little game. I admit items tended to be difficult to find in the junk piles with my 60-something eyes, but it was refreshing to have human bad guys instead of witches, warlocks and aliens for a change. No animal helper was also a plus!
 
 
 posted in Jewel Match IV on Jun 19, 14 1:35 PM
I totally agree! I tried uninstalling and reinstalling, and it was still lousy. I hate games that won't let you move at your own pace, but have to "help" you by showing you moves. That just makes me nervous, and then I yell at my computer.
 
 
I just did the mini game with the four element spheres. After I completed the four paths, it just sat there and did nothing! I finally had to skip it. There were others I had to skip for the same reason, but I can't remember what they were (senior moment). It is most frustrating. MLC60
 
 
 posted in Origins: Elders of Time on Mar 25, 14 2:59 PM
My guess is that there's a CE of this game, and you get the achievements with that version of the game. That's the impression I got, anyway. MLC60
 
 
The game keep saying "activating", so I went to do something else while it was making up its mind. When I came back, it said my trial had expired, and I never even got it to finish downloading! MLC60
 
 
 posted in Echoes of Sorrow II on Feb 3, 14 4:51 AM
I was playing the marble game and was moving the inner ring around to fill it with a green marble when all of the green marbles disappeared! If this is going to be another game like Cruel Collections that I can't finish, there's no way I will buy it, with or without a PCC! MLC60
 
 
 posted in Undiscovered on Jan 28, 14 7:53 AM
When I played the demo, it let me go at a nice, leisurely, senior-citizen pace; however, after I got it with a PCC, it changed to this aggravating monster that gobbles up everything you've done. It is most frustrating! There is a mode called Zen that is just M3 at a leisurely pace, but I only played to Level 3 of it because it bored me out of my mind. Maybe I'm too hard to please. MLC60
 
 
 posted in Shadow Shelter on Jan 22, 14 6:19 AM
I have complete the game, too, thanks to a little help from my friends here in the forum. It's a good game that really makes you think. After I discovered the jump map in the top right corner, it was a little easier, but not much. MLC60
 
 
 posted in Shadow Shelter on Jan 21, 14 7:55 AM
Is there something you have to do before it will let you do this part? I've tried pulling the lever, clicking on the dial, trying to change the ugliness with the straight razor, and I can get nothing to work. Help, please! MLC60
 
 
 posted in Cruel Collections: The Any Wish Hotel on Jan 10, 14 6:30 AM
Use it to sew up the magician's hat. Does anyone know where to get the other flag? MLC60
 
 
 posted in Cruel Collections: The Any Wish Hotel on Jan 8, 14 1:19 PM
The telescope just gives you the time on the clock. You have to find the wench handle to get the kite. MLC60
 
 
 posted in Cruel Collections: The Any Wish Hotel on Jan 8, 14 12:55 PM
You have to get the paintbrush out of the dried up paint on the window cleaner's device by the statue with the fishing rod. In order to get the paintbrush, you have to get the solvent from the room where you put the lantern. I don't remember what you had to put the solvent in. Hope this helps. MLC60
 
 
 posted in The Fog on Dec 13, 13 8:00 AM
Yay!!! I have finished The Fog!! I was tempted to give up and delete it several times, but kept coming back to the forum for guidance and finally FINISHED. I am so proud of myself, as my sister says! MLC60
 
 
 posted in Crystals of Time on Dec 3, 13 5:21 PM
Hurrah! I have finished the game! I'm so proud of myself because several times I started to just call it a bad decision and uninstall it. It gives you such a sense of accomplishment when you finish a difficult game!
 
 
 posted in Treasure of the Caribbean Seas on Nov 11, 13 4:17 AM
And items are hard to see! The keys in the library are teeny, tiny. I finally gave up after finding 7 of the 8 keys because my eyes were beginning to hurt.
 
 
 posted in Revived Legends: Road of the Kings Collector's Edition on Nov 2, 13 11:00 AM
I enjoyed this game very much. My one complaint is the repeat the colors, notes, whatever they were, game. As you can see, my 60-something memory is not real good, so I get frustrated with that type of mini-game. On the whole, however, an excellent game. Thanks, Blam!
 
 
 posted in Call of the Ages on Oct 23, 13 6:57 AM
This is the gripe I have with most M3 games. When I check "relaxed" mode, I mean I want to move at my own pace, which is senior citizen pace. I hate the "sand" which eats up all my squares I've already uncovered. It makes my nerves raw and makes me yell at my computer. I end up regretting wasting any time on the M3 game at all and delete it before I have gotten very far into the game. If I wanted to be frustrated and aggravated, I'd play the games on Facebook. I wish the sand had shown up earlier in the game when I was demoing it, and I wouldn't have wasted a PCC on it.
 
 
 posted in Tales of Lagoona 2: Peril at Poseidon Park on Oct 8, 13 6:29 AM
IMO this wouldn't be a bad little game if you could move at your own pace, but, like so many M3 games, it has to "help" you out if you don't move fast enough to suit it. If there is anything I can't stand, it is a bossy game. If I could've seen a way to turn off the annoying "help", I would've gotten this game with a PCC.
 
 
 posted in Questerium: Sinister Trinity on Oct 2, 13 8:11 AM
There's an electrical power box on a pole beside an electrical fence. You have to shoot the power box with the gun in order to go forward. This is after you fix the subway car and ride down the tunnel. Hope this helps.
 
 
As a Southerner, I'm tired of that dead horse of the un-Civil War being beaten. This seems like a trite old theme, with too many HO scenes. Maybe it's just my computer, but the movement is slow and jerky and doesn't seem to have progressed any since the last Midnight Mysteries game. I won't be purchasing, even on sale. MLC60
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator