Posts created by moonweaver

 
 
 posted in Nancy Drew: Ransom of the Seven Ships on Jun 28, 11 7:57 PM
Another note: I also have trouble with the games or puzzles in Nancy Drew that require quickness and dexterity. For instance, in this game, it's the throwing game with the monkies that gave me trouble. But since I needed to win at least one, in order to get a certain prize, I just kept playing it over and over until I finally won.

Another good thing about ND games: you can never really die. The game keeps giving you a second chance.

I have never played as a Senior Detective, so I don't know what that's like; i.e., if you get any of the help that I had as a Junior.
 
 
 posted in Nancy Drew: Ransom of the Seven Ships on Jun 28, 11 7:52 PM
I also have played a lot of ND games, though not all of them. I enjoyed this one, but I always have to refer to hints or a walkthrough to solve some of the puzzles. I like Universal Hint Systems the best, because you get only as much help as you want, without spoiling the whole thing.

The hardest puzzle in this game for me was the hourglasses in the Blue Hole. Even after I had the hints that told me what to do, the doing of it in exactly the correct amount of time was difficult for me. But I finally did it. I finished the game a couple of nights ago, and got Nancy and Bess out, and so ended the game. But then I went back to a previous saved point, and found the treasure (again I used the hints), and then got out again. Now I'm trying to find all the bottles, and am using hints to try to locate them. If I can get all of them, I can find the Easter Eggs. I don't usually bother with those, but I thought it would be fun this time.

My advice to anyone playing Nancy Drew for the first time is to save your game often. Also, you may have to make some notes of your own, as Nancy doesn't write all the details in her journal. If you play as Junior Detective, you have the Journal and Nancy's checklist to help you.
 
 
 posted in Syberia on Jun 2, 11 8:37 PM
I finally finished the game! Again, I say I never could have done it without a walkthrough, and even then, I sometimes turned the wrong way. Sometimes if they said Right or Left, I wasn't sure if they meant my R or L, or Kate's. I did try to go it on my own sometimes. For instance, I figured out by myself how to get the recipe for Helena's cocktail. But the information was given so fast, and wasn't written in Kate's notebook, and I couldn't write fast enough, so I had to get the full recipe from the walkthrough. I would have had to consult it anyway, because I never would have figured out how to turn the crystallized honey into a liquid.

SPOILER ALERT:

I didn't even know there was a Jacuzzi in the hotel, and it probably wouldn't have occurred to me to use it for that purpose.
 
 
 posted in Syberia on May 26, 11 8:46 PM
Well, after I downloaded for the third time, and was finally able to save my game, I was much happier. Without a walkthrough, I would never be able to play it. Some scenes are so dark, I overlooked clues until I consulted the walkthrough. For instance: SPOILER AHEAD

[color=#ffffff]In the V. house, when I went into the dark corner, I could not see the lightbulb, which I had to turn on in order to make Momo appear. Also, I would never have known where the mammoth picture was without the walkthrough.
 
 
 posted in Nancy Drew: Warnings at Waverly Academy on May 21, 11 1:24 AM
Well, I finally finished the game. That furnace lever puzzle gave me fits! I consulted two different walkthroughs, and still had to try several times before i got it right.

The end game wasn't as scary as I had thought it would be. I got through it without having to use a Second Chance.

I don't think I'll play any more Nancy Drew games for a while. One thing that bothers me about them is that every one includes a situation where you have to use fast clicking skills, and that isn't easy for me. In this game, I never could beat Leela in darts. I did beat her once in air hockey, but then I couldn't do it when I needed to beat her a second time. Finally, she took pity on me, and gave me what I had asked for anyway.

But there is no skipping of puzzles in any Nancy Drew game; I wish they would give us a chance once in a while.
 
 
 posted in Nancy Drew: Warnings at Waverly Academy on May 20, 11 12:41 AM
Like several others, I had trouble climbing the tree. I knew I was supposed to follow the squirrel, but he moved so fast, and my mind is like a sieve. I must have fallen out ot that tree at least 20 times! I was literally talking to myself, but I kept plugging away, and finally I made it.

Other than that, the scariest thing I've done so far was sneaking out at night to get into the locked classroom. But I didn't get caught; I just kept moving my mouse around whenever I heard Paige's voice, until I saw the green outline of a crouching Nancy. Then I clicked on the outline, and I was ok. But I had to do it quite a few times before I finally reached the classroom. Once inside, there was no problem. I thought I would have the same trouble getting back to my room, but the game took me back there automatically after I took the photos of the puzzle and headed toward the door. That was a relief!

I have peeked at part of the ending on Universal Hint Systems, so I know there is a very scary part yet to come. But I know what to do to combat it, and the game always gives you second chances, anyway, if Nancy gets caught or killed.
 
 
 posted in Nancy Drew: Warnings at Waverly Academy on May 20, 11 12:32 AM
rubyred66 wrote:I can't find the library


If you haven't already found it, here's how: (I had trouble with this, too, and consulted a walk-through to find it) After you exit the snack bar, go straight, then turn left at the first hallway. Go straight again, and before you reach the stairway, look left and see double doors. These are the library doors.
 
 
 posted in Dark Parables: The Exiled Prince on Apr 20, 11 12:28 AM
Finally! I finished the game tonight, after many hours of playing. Of course, I'm slow, and do a lot of backtracking, but still, this was a very long game, and new areas opening up kept surprising me. So, at the end, it automatically started me over in Hard Mode, but now that I got through that door that I couldn't open in regular mode, I think I'll take a break from it and play something else. Then I can come back to it with fresh eyes. I love these Dark Parable games!
 
 
 posted in Dark Parables: The Exiled Prince on Apr 19, 11 1:40 AM
Well, I had already checked the walkthrough a couple of times, and didn't find what I was looking for, though I only checked up to the point I had reached. So I started over with a new player name, and this time I paid more attention to the map and the tips it gave me. Turns out I had missed a couple of Hidden Object scenes, so finally when I got to the greenhouse, I had what I needed to open the side door, which led to a lot of other locations. So I think I'm on track now, though I have reached a point where I'm not sure what to do next, so I might check out the walkthrough again. I'm glad I started over; it's a pain, but I never would have progressed without doing it.
 
 
 posted in Dark Parables: The Exiled Prince on Apr 17, 11 7:34 PM
I am stuck in Regular Mode of The Exiled Prince. The previous posts say that you can't get the Frog Prince crown or the Secret Tree disc until the Hard Mode. But I have been going around in circles, and have done everything I could find to do, except opening the Frog Prince door in the cave, and finding the secret passageway in the greenhouse, which I guess I can't do until the Hard Mode. The Cottage key doesn't work on Snow White's cottage; I guess it fits the other cottage that is in the Forest, but the game won't let me go back to the Forest. Oh, and also, I never found an axe or other tool that would clear away the prickly vines in the cave, so maybe that's what I need to do. I wonder if it appeared in a fractured object scene, and I failed to click on it, in which case, I probably have to start the game over. Any ideas from anyone? I want to finish Regular Mode.
 
 
 posted in Treasure Seekers: The Time Has Come on Feb 23, 11 9:15 PM


I played for a couple of hours after I downloaded it, and it worked fine. I saved the game and exited, and the next day when I went back to it, I kept getting the access violation notice. I redownloaded three times, though I forgot to uninstall it the first time. But I did uninstall and reinstall twice, and still got the error notice. Also, I restarted my computer each time. Anyway, finally I went to tech Help, and saw that one solution would be closing my virus protection software temporarily. I decided to try that first, and it worked. I don't like doing it; it has risks, plus it's inconvenient. But at least I can play the game. My computer is less than a month old, so I figured all my drivers, etc. were already up to date. If they were not, then the other suggestion was to update them all.

It's too bad, though, that any action was necessary.
 
 
 posted in Virtual Villagers: New Believers on Feb 18, 11 9:09 PM
SPOILER ALERT!


I don't remember how to write something so that it doesn't show, but I did want to say that I don't think my hand statue problem was necessarily a glitch. Later on in the game, I achieved Level 3 in:


SCROLL DOWN














Devotion

After that, I tried putting my Master Builder on the statue, and within about half an hour on fast speed, the statue was finished.






 
 
 posted in Virtual Villagers: New Believers on Feb 14, 11 12:26 AM
I finally got a Master builder, and put him to work on finishing the hand statue; then I needed builders to tear down the Rainbow totem, so I pulled him off the statue. When I put him back on the statue, it said I needed more tech, but I already have Level 3. I don't know if this is a glitch or not. The statue was about 25% finished before, but now it shows nothing, and I don't know how to proceed.
 
 
 posted in Virtual Villagers: New Believers on Feb 13, 11 3:13 PM
Jarrow,

Same thing happened to me!
 
 
 posted in Virtual Villagers: New Believers on Feb 11, 11 11:03 PM
Aha! I had figured out that it was lab items that were worth tech points, and now I am getting them, but didn't put it together that it was after I destroyed the knowing totem. Thanks, Snape!
 
 
 posted in Virtual Villagers: New Believers on Feb 10, 11 7:51 PM
I was beginning to think that this game, unlike its predecessors, did not give tech points for children collecting duplicate artifacts, because, though I only have one child now, no matter how many duplicates she collects, I gain no tech points. So, maybe there's a glitch in my game. I wonder if I should redownload?
 
 
 posted in The Secret Legacy: A Kate Brooks Adventure on Feb 10, 11 3:53 PM
I also could not pick up the bat. So, since it was the last object in the scene, and I couldn't progress without it, I deleted the demo after 15 minutes. I wasn't impressed anyway. Objects were hard to see, scenes were sometimes too dark (tho I did find a lamp for the 2nd room; still very dark).
 
 
How soon is the SE coming out? I really like all the TS games, but can't afford the Collector's Edition.

I just got my monthly game credit, and would like to use it on this game, but maybe I'll have to wait till March.
 
 
 posted in Awakening: Moonfell Wood on Jan 13, 11 2:44 AM
What quarlesqueen said! I loved this game, and it had such a light-hearted, uplifting atmosphere. Finished it tonight; it took me 11 hours, which is probably at least twice as long as it would take most fishies. I play very slowly. Used a lot of hints, though I played the casual version. More like this, please!
 
 
 posted in Lost in Time: The Clockwork Tower on Jan 7, 11 1:33 AM
I loved the game, even though I used a lot of hints and consulted the walkthrough quite a few times......right until the end. But I cannot do the final task: set all the clocks at 12. Even after consulting the walkthrough, and watching the videos of how to solve the clocks, (trying to write down every move), I just can't do it. And it's the only puzzle in the game that you can't skip! So I won't be able to see the ending; I'm disappointed. I just never have been good at the puzzles where you have to move more than one ring or disc, and every time you touch it, it moves something else you already have put in the right place. Too bad!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator