Posts created by Jaguar2357

 
 
 posted in Myths of the World: Black Rose Collector's Edition on Nov 1, 14 1:03 PM
Thank you. It explains a lot.
 
 
 posted in Myths of the World: Black Rose Collector's Edition on Oct 29, 14 9:02 PM
Actually, all you ever needed to do is go to the last section in the Strategy Guide - it shows you where all the collectables and morphs are, and exists in every CE game guide. Except for games that have additional "mystery" collectables.
 
 
 posted in Myths of the World: Black Rose Collector's Edition on Oct 27, 14 11:13 PM
Me too. Neither I nor the Guide ever saw one.
 
 
 posted in Shrouded Tales: The Spellbound Land on Oct 17, 14 1:16 PM
I could not find out how to start playing it. If I clicked a pink area, all the dice stayed question marks. If I click a blue area, it is "too far away". There are no other visible controls. And the walkthrough is completely worthless on this, it just says, "Solution (E1)." with no picture whatsoever to refer to.

Does anyone know how this works?
 
 
Valkara wrote:Windows 8.

The music won't mute. The map in the bonus section doesn't work right. Screens are slow to load. I can't access one of the Museum areas for a world I did so explore. And near the end of the game I got a cryptic note that is some kind of technical code.

I am NOT pleased.


Me too. The first museum refuses to open to me for any reason, and I'm all the way into the bonus chapter. Extremely frustrating, as this would have been a favorite game of mine based on story, graphics, complexity and puzzles. This is one they really need to fix simply because it is worth the effort.

Also, I absolutely cannot enter the boudoir thru the menu available when reading the notebook that is completely blocked - "your harlequin must open the boudoir" - only if I catch the popup when I find a mask can I get in. And that popup is very finicky about exactly where I click and very quick to disappear.

All these lovely extras are not fun but full of stress just trying to get them to work. Not good.

I have a Windows 7 64 bit laptop.
 
 
You referring to "both" sticks had me looking for the second one. You must attach the handle you found separately first, only then does the handle that came with the lens attach. Extremely frustrating.
 
 
 posted in Dark Parables: Ballad of Rapunzel Collector's Edition on Jul 30, 14 5:22 PM
how do you find the crystal?
 
 
 posted in Dark Parables: Ballad of Rapunzel on Jul 28, 14 3:56 PM
I love BT games precisely because they make intellectual challenge beautiful. What's with being unable to like anything that is not gory?
 
 
 posted in Reflections of Life: Tree of Dreams on Jul 24, 14 11:03 AM
There is a walkthrough for Reflections of Life: Tree of Dreams at
http://www.bigfishgames.com/blog/walkthrough/reflections-of-life-tree-of-dreams-strategy-guide-hints-cheats-codes-tips-tricks/
 
 
 posted in Off the Record: The Italian Affair Collector's Edition on Jun 28, 14 1:02 PM
all the pictures you click when they run the credits
 
 
Can anyone say if the bonus chapter is needed to finish the story? Is it long and good enough to be worthy of CE?

Thank you in advance.
 
 
 posted in Magic Encyclopedia on Feb 23, 14 6:31 PM
You are in the Magic Encyclopedia forum - find forum for midnight castle
 
 
 posted in Alex Hunter: Lord of the Mind on Feb 11, 14 12:43 PM
It does, in that doing more than one hadn't occurred to me.

One question (not strategic) lingers - why did they think root vegetables were similar to a vine fruit like any squash? Oh, well, only the devs know that one.
 
 
 posted in Alex Hunter: Lord of the Mind on Feb 10, 14 6:50 PM
I put in the missing tile, and found all but the last connected symbol - at least they all remained depressed and let me move to the next. But I can't find what pairs with the pumpkin - and the built-in walkthrough is no help at all, it just shows the panel before putting in the pumpkin and tells me to solve the puzzle. So what order do these go in?
 
 
 posted in Whispered Secrets: Into the Beyond on Jan 6, 14 9:23 AM
They didn't mention it in the stickied posts that start the forum, but there is a walkthrough at http://www.bigfishgames.com/blog/walkthrough/whispered-secrets-into-the-beyond-walkthrough/
 
 
 posted in Detective Quest: The Crystal Slipper on Dec 27, 13 11:43 AM
Thank you, Rumbitothecore. It's very rare for Margie B. to miss something big - I really like her walkthroughs. But when the helpful icon malfunctioned she assumed they didn't count. This is very helpful.
 
 
 posted in Cursery: The Crooked Man and the Crooked Cat on Dec 10, 13 1:51 PM
Definitely dark and creepy, but it does NOT have ghosts suddenly filling the whole screen and screaming in your face. That kind of ghoulish stuff I can't stomach.

I believe the Bonus chapter, as in the other Blue Tea games, is its own short story. This story is finished in the SE. But the morphing objects are also turned off. The token collection is kept, whenever you finish a puzzle.
 
 
 posted in World Mosaics 7 on Oct 9, 13 11:37 AM
My only computer is a pc laptop that uses a touchpad, not a mouse. Their instructions for canceling a mistaken mark is to press both buttons on the mouse. I have tried that on the 2 buttons below my touchpad, and it does not function. I tried variations, including the right-button-plus-click-on-pad and both buttons held while clicking on pad. Nothing works.

Is it just the touchpad, or are mouse users also experiencing this problem?
 
 
 posted in Reveries: Sisterly Love Collector's Edition on Jun 9, 13 12:25 PM
Ahh - yes I did the sky, but I didn't think about eyes. thanks.
 
 
 posted in Reveries: Sisterly Love Collector's Edition on Jun 8, 13 3:51 PM
I can't make anything work, I have done all the Strategy Guide wanted in the bonus game, up through using the pestle to get the smoke gem on the bridge. The SG says at this point to apply it to the smoke gem in the amulet to charge it. I'm doing that, and nothing at all is happening, except to tell me the amulet doesn't work because of the Harpy.

How do I get past this point?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator