Posts created by barbaralbb

 
 
Thanks, Bella. You may be right.

Trophies and morphing objects are fun but I never earn (or find) them all, so they don't really make or break a game for me. Since I never play on Advanced mode, sparkles aren't an issue either. I just like the games to be interesting. I think I've purchase almost every CE game that has come out - some great/some not so great/some real stinkers! Don't care a thing about the "extra" stuff except for the bonus chapter, but that's just me.....

I do agree that the interactive map is a nice touch, esp when the game moves over a large area. What does Casual Gran usually say, she "needs her sneakers...."? An interactive map is always appreciated and that would have been a nice (CE worthy) inclusion to this game.

I sometimes feel that there are those in the forum who have a personal knowledge of a particular game mfg and that they may have been involved in discussions about how to improve a genre or format.... and, when that doesn't happen, there is disappointment. Or, perhaps, they feel that comments in the forums should be "listened" to, as a prudent business practice - I absolutely agree with that!

I've been using these games for a couple of years to keep bordeom at bay, while recovering from some medical things. So, I'll just keep plodding along..... pretty okay with anything that strikes my fancy.

Is this game CE worthy or not CE worthy - we'll that does have to be a personal opinion and I decided that, for me, this game was.

As I said, earlier - we all like different games and have different expectations and that keeps BFG in business. For that I'm very grateful!
 
 
I don't get it..... This ERS game is no better (or worse) that most of those that have come out in the past several weeks. It certainly makes more sense than the silly game about the mechanical spiders! Talk about a story that was impossible (non-sensical) to follow....

To tell the truth, I care much less about the story, music, wide screen, etc, etc, etc, than I do about the game play.

Can I figure out where to go next (within a reasonable time)? If there are HdOj scenes, do they make sense within the context of the game (i.e. no TV's in the 1800's)? Are hints adequate and helpful (well, honestly, this game isn't stellar in that regard)? Does the SE keep my place (I hate it when the darn thing returns to the beginning when I exit)? Does it move logicaly from scene to scene/area to area? Are the scenes nice to look at with well done art work? Does it hold my interest? Am I likely to play it again? In almost all of those area, this game is fine for me. So, I bought it.

I know we all have different expectations. But, darn, I found the stuff being heaped on ERS for this game pretty surprising. Almost didn't try it, based on the reviews, and that would have been a shame 'cause it's a good one.

So, I guess the moral of my story is...., trust the judgement of those whose opinions you respect but try things for yourself - you just might be surprised.

Happy gaming to all the fishies in the pond. Liking different things is what keeps BFG in business!
 
 
 posted in Hidden Mysteries®: Gates of Graceland® on Oct 13, 12 2:31 PM
I'm sorry - I just find this game a bit creepy..... And this from a person who enjoys all the haunted house, evil doctors/hospitals, vampires, plagues, etc, etc.....

I would just get into the game when up would pop a video of Elvis or a figure of Elvis and it just creeped me out. Guess I like my games on the fantasy side and not based on real things. Same sort of thing happened to me with some of the Titanic games.., just could not get past the "reality" of the situation.

Well, that's just me and I wish happy gaming to all fishies who liked the game!

 
 
 posted in Adelantado Trilogy: Book One on Oct 4, 12 8:00 AM
I understand what the earlier reviewers are saying. As I proceed through the game, now at Part 2, Chapter 5 - am finding myself starting to take it a little too seriously. Makes me sorry to have to build a woodcutter house to clear cut the forest or build a sawmill on the top of a pyramid or beside a totem or outside the village Elders house....., but isn't that pretty much how it happened? And then I have to bash the Cavemen who clearly don't want "us" or the "Indians" on the land - makes them pretty smart.

Then I remember, it's a GAME and nobody is being displaced. No different than one with "Kids in peril" or "lost husband/uncle/grandfather/etc". Guess the developers have actually done a good job if I'm so engaged in the game that I start to feel for the characters.

And, I've gotta say, I love this game! Some of the things you've all mentioned are the very things I love: love the big, ever expanding game area; love that I don't know everything that I'll ultimately need; love that I get someplace and have no clue what to do next; love that I need certain levels of strength/speed/oratory to talk to characters; love that the little people just go about their jobs and i don't have to make them harvest/dig/chop/bake - I just tools/houses/food/jobs available and off they go! I find this game addictive and have been working on levels all week.

Do wish that Don Deigo had a horse! Maybe in the next one....
Do wish that there was a save option, within the level!!!
****edited for spelling****
 
 
Here I am, again, well and truly stuck. In the Russian city, in the school, in the basement, there is a girl shadow. I am supposed to give her the "bubbles" - I only have one bubble and she won't take it. Have looked through the SG and don't find another bubble to hidden.... (is there any where else in the world that I could write that sentence and not have people laugh!)

So - any bubble hints? Is there another one, somewhere? Is there a specific place to on the shadow for placement? Since I can't get through this section, I can't get the nippers, and I can't free the guy behind the screening....

Am hopeful that some fishies are still out there working on this game.
 
 
 posted in Astral Towers on Sep 26, 12 12:06 PM
Usually cbtx and I agree on games, but not in this case. It's just not my genre - reminds me of the card "war" games my kids used to play... and they loved them!

For fans of that type of game, this would be perfect option.

Happy gaming, fishies! I'll just wait to see what we get, tomorrow.
 
 
Finished the game and bonus chapter - LOVED THEM! Nicely done Blue Tea games.

Now, just a word about the Red Riding Hood ladies..... Those thigh high leather boots - can you say "chaffing"? And running around the forest in high heels and bare midriffs, seriously? Turned ankles and scratches - there should have been a "first aid" puzzle section.

The game was developed for serious players but the female characters were drawn for teenage boys..... who are most unlikely to be playing this game, don't you think?

I really prefer the lead character in the Margrave series - she looks like a real person rather than a caracature. The one male in the game looked pretty normal and was dressed appropriately for running around the forest - heavy cloak, long pants, and sensible boots.

Gotta say, through, I did get a laugh out of the overturned carriage, in the opening scene - great "send up" of all the games that start with a speeding/crashed cars!

 
 
Nope, no joy with the uninstall/reinstall. Still have both curtains and the game tells me I don't have enough.....

Looks like my only option is to start a new profile and play through to the bonus chapter again. Not really happy about that, , especially since Rachrenee had the same problem. Phooey!
 
 
That's a good thought, WilJul. The doll may have been an item for the last scene then the need for it was removed. That way we're left with the doll and no place to use it.... Ah, well, just another mystery of programming.

 
 
Thanks, WilJul - I did consider that.... but then I'd have to start the whole game over and that's pretty unappealing. It was an okay game but played VERY slowly (speed wise) and was a pretty slow game (plot wise).

The way the items worked for you sounds like what I expected, but mine apparently "glitched" at that point.
***edited for spelling***

***edited again for "Duh"***
Well, of course I could uninstall/reinstall and that does not require a new profile, does it.... Sorry, I have not had my 2nd cup of coffee and my brain wasn't awake. I will try that, as I should have done when if first happened. I'll let you know if it works.
 
 
 posted in Adelantado Trilogy: Book One on Sep 18, 12 8:05 PM
What a seriously amazing effort!

I stand in awe that you finished all these levels and that you were able to make these videos/texts to help those of us who could use a "boost"

The TM games aren't usually my forte, but this one intriqued me and I used one of my coupons to buy it. Found myself seriously out of my depth but did manage to do the first three chapters of part 1. In Chapter 4, I could not find the darn oratory stone and ran out of time.... Also spent way too much time chopping down bushes, in case there was something there (which there usually was not).

My kids tease me about using walkthroughs, but why not, if it helps me understand the time management? I used tips and tricks and experience in my work - why on earth would I not use them here? Again, thanks from a very grateful fishie!!!

****edited to add comments 10/4/12****
sipason - you are amazing! I have used both the video and text information at your site and you've saved my sanity.... seriously With your detailed information I've made it to Chapter 2, Level 5. Even completed a couple of levels "on my own" now that I understand the logic of the game. It's like no TM game I ever saw, as those usually bore me to tears after the first few levels. This one is like the ultimate HdOb, TM, Adventure game. I LOVE IT!
And I still stand in awe of the resource that you made available for us to use!!! You are the best fish, ever!
 
 
I was surprised when the whole "Puritans as the bad guys" came up... But, you have to admit that they, in real life, left some pretty bad actions in their record. One wants to think that everyone in their possible past was kind, careful, patient, moral, ethical and never treated anyone badly. Unfortuntely, that is seldom the case.

Since this is simply a game with made-up Cyclops, etc...., well I just figured makebelieve is makebelieve and moved on with it.

We each have our "trigger" points in games - some hate the vampires, ghosts, mental hospital settings, others hate the whole "crashed car" and missing male relative storyline, more hate the spider/bug/bat stuff. Personally, I hate it when tools or items are mislabled or used incorrectly as that makes me what to scream.

We can now add Puritans to the list and it's a completely valid concern - it just isn't one of my triggers.

***Edited for spelling***
 
 
Well, I finished the game and started the Bonus Chapter. Haven't gotten very far as I can't get the "curtain as a rope" function to work. Went back through the SG and have not missed any items so, I'm stuck.

Possible Spoiler:
Took the curtains from the window of the loom room (which by the way isn't the correct loom for a tapestry, but oh well.... ). Took one, then the other, and they both went into my inventory. SG seems to indicate that I should add each curtain to the pillar, one at a time. That isn't possible as clicking on one picks-up both from the inventory. Now I have two curtains tied to the pillar and still Edwina is telling me that it isn't long enough.... SG doesn't mention anything else to add to the rope, and now I'm stuck with no way through the window and into the Monk's cell, below....

Any suggestions and/or tips would be very much appreciated.....
 
 
Thanks, DL Oz... at least I know I'm not the only "fish" in the pond with this problem!
 
 
It always makes me little concerned when I end the game and still have items left...

Did use the staff, at the beginning, so guess it makes sense but the Doll....? Got that as my last item at the end of the next to the last scene (The Wedding). Never saw a place to use it, then thought - maybe it was part of the Bonus Chapter. But, no, that starts out with completely different items.

Anybody find a use for either of these items at the end of the game? Did I miss something and still finish?
 
 
 posted in Alchemy Mysteries: Prague Legends on Sep 7, 12 1:01 PM
Well, duh! Check the Journal - something I almost never do.... Thought I'd tried every possible combination but, clearly, I'd missed one!

Knew if I looked in the forum, there would be an answer..., and there was.

Thanks Valdy, et al - I'm liking this game. It's odd and quirky - just what I need for a quiet Friday afternoon! And, next time I'm stuck (and there WILL be a next time) I'll check the Journal....

******************
edited for spelling
 
 
I like it - have played 1/2 of demo (got through the puzzle with the bricks) and I like it. It is different and, at first, I thought there was that whole "move around the room from side to side" thing and that always makes me dizzy.... but it was only a little and didn't really bother me.

I have to agree that the girl nodding her head is annoying, but I can ignore her.

Accumulated 6 hints and only had to use 1 so that's better than I expected, based on the reviews.

Really like that the SG is "inside" the game - no exiting to the menu. It opens/closes easily and has clear information.

Do wish there was a map..... but navigation hasn't been a problem, at least 30 min into the game - may get more complex as I progress.

Overall, it's been fun and different. I'm good with that! Thanks developers,

***********************************************************************
I have one gripe (and don't think its a spoiler): when you enter the garage, there is a loom. The warp threads seem go over the beater.... and, friends, it just doesn't work that way! These games never get weaving and spinning right - wish they'd just leave those things out, it they don't understand them. Sort of like having to look for a wrench in a HObj game and the actual item is a pair of pliers... completely wrong!

Okay, ranting time is up and I'm off the buy this game - I continue to be a CE junkie!
 
 
Is it just me or is the Strategy Guide really hard to get to..... The only way I've found is to exit to Menu and select Info on the main screen. That's really ackward and I'm wondering if I'm missing something within the game. Sometimes the tab for the SG is in an odd place within the playing screen, but I've looked and come up empty.

If this is the only access to the SG, it's a pretty big error. Overall, I'm liking the game, but am a bit "under the weather" and not at my most clever... SG is a nice option, if it's accessible.

**********(edited for non-functioning brain)********************
Never Mind - It was just me and my "feeling poorly" brain not working at any kind of maximum efficiency. SG access is in the upper left corner - duh!

Sorry for the unnecessary posting.
 
 
 posted in 1 Moment of Time: Silentville on Jul 4, 12 6:35 PM
Well, DUH!!!! Turn on the steam, click on all the tiles, turn off the steam, zoom to the safe.

I'd been clicking on tiles with the steam off and was pretty frustrated and hints were no help (walkthrough wasn't clear, to me, on this point either). Got it now and ready to enter the code....

Thanks, fishies - as always you are the BEST
 
 
 posted in Katy and Bob: Way Back Home on Jun 17, 12 7:51 AM
Have downloaded twice and both time games has failed the Install.

So.o.o.o....., that's it for me.

Edit/Update:
Well, for some reason I tried again (call me an optimist) and this time it installed. Off to try and play and see if it works.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator