Posts created by Pleiadestar

 
 
 posted in Route 66 on Oct 6, 09 10:05 AM
Downloaded it ... finished the whole game with 8 minutes to spare - the only reason I had only 8 minutes left was because I kept playing the mini-games! If I hadn't it would have probably only took me about a half hour or so. No reason to purchase this game - too bad too because it had a great premise - just a lousy reality.
 
 
 posted in Hidden World of Art 2: Undercover Art Agent on Oct 4, 09 9:29 AM
I downloaded this game yesterday. I tried to play it today. It took ELEVEN minutes to get off the main screen and into the game. Trying to type my name in was a sad sad joke. Then I tried to go to options and turn off the special cursors...that took up the rest of the 11 minutes. When I download a game with the intention of purchasing it - IF I like the game...having problems from the get-go is NOT a way of grabbing my attention and making me want the game!

Not for nothing...I have a 9 month old EMachines computer with a 2.4 GHz AMD processor, 3 gigs of RAM. I have Nvidia GEForce video card. I run nothing while I am playing a downloadable game. I do routine maintenance on my computer every few days. There is NO reason why this game took 11 precious minutes of my trial time to load and run.

This will NOT be a purchase for me.
 
 
 posted in Vampire Saga: Pandora's Box on Sep 27, 09 5:41 PM
downloaded the game this afternoon. tried playing it this evening. got about 6 minutes in when my cursor disappeared. game was running semi-slowly prior to that. when i tried to close the game via task manager the game kept popping back up like it WAS the vampire and didnt want to die.

This will NOT be a purchase for me.
 
 
 posted in Save Our Spirit on Sep 27, 09 5:17 PM
Donick2 wrote:Just wondering if you moderaters there actually read these ashave noticed you never comment when customers are unhappy but still glad enough to take our money

Don't get me wrong I am loyal to BF have been member over 2 years & still buy many games & will continue to do so & always get excellent help from customer dept but you moderaters jump on people quick enough if we make a mistake & do something wrong but would be nice to see you comment when we not happy with you too except to say thanks for being patient


Donick...did you not read thru the posts before you commented? Two or three DIFFERENT mods have been responding to the complaint, saying that it is being worked on....sheesh!
 
 
 posted in Relic Hunt on Sep 12, 09 3:56 PM
What a horrendous waste of time. Don't bother buying this game...you will finish the entire thing with time to spare during the demo!

And I have to "brake" the light spots? Sheesh who wrote this crap?
 
 
 posted in Steve the Sheriff 2: The Case of the Missing Thing ™ on Sep 11, 09 10:10 PM
I think the Steve games are very cute. But very easy! I bought it yesterday afternoon and was finished with it in under 3 hours. Good thing I only pay $6.99 for my games!

I could have done without the sitting at the table after every completed room getting tips from the wife and kid tho - that got a little annoying.
 
 
 posted in Drawn: The Painted Tower ™ on Sep 9, 09 5:32 PM
The game is interesting the graphics are outrageous HOWEVER!!

I highly dislike the fact that once I found the window pieces and placed them I was FORCED to sit thru a montage of pictures and sounds that brought me to the purchase now page. I was NOT finished with my hour - I had NOT made up my mind. I started the game again, clicked on the witch doctor painting that I had already cleaned and guess what? Yup, I wound up going thru the montage and purchase screen again - this wasted a total of 4 minutes of my "free play".

I am seriously thinking of NOT PURCHASING this game due to the ripoff nature of the thing.
 
 
 posted in Princess Isabella: A Witch's Curse on Aug 24, 09 8:42 AM
It was a pretty good game but definitely not long enough. I zipped thru it in less than 2 hours...to me that is a waste of money.
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on May 18, 09 3:20 PM
Hiya Margie welcome to the pond!!

Here's a question for ya - I am on the second playthrough of the game ( yeah I finished it already!) and I can't seem to locate the final blade for the windmill. Its definitely NOT where it once was LOL. I have clicked ALL over both the garden page and the front of the Herbalists house and its like no where to be found. Any suggestions?
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on May 14, 09 10:53 PM
ITS OUT THERE ALREADY!!! If you go to Playfirst.com the game is available for downloading. WHY OH WHY isnt it here?????
 
 
 posted in Mystery Case Files: Ravenhearst ™ on May 13, 09 5:45 AM
Honey there is no such thing as a temporary key. You get 1 hour trial and then you have to PAY for the game if you want to keep it.
 
 
 posted in The Princess Bride on May 12, 09 11:40 AM
I am having the same problem with the carrot...i cant seem to find it anywhere and I have been through ALL the intros and outros...any suggestions?
 
 
 posted in The Princess Bride on May 12, 09 11:39 AM
Woohoo!! It only took since February but I finally was able to reinstall the game and play it! (its now MAY) I guess patience IS a virtue!
 
 
 posted in The Princess Bride on Feb 25, 09 1:42 PM
back when the game first came out I downloaded it and played it and loved it. THEN my puter crashed and I got a new one loaded with <ugh> vista....i cannot redownload the game because nortons 2009 says it has a trojan...I have contacted nortons and they don't "get" it. I told them it was a false positive and they said that bigfish has to contact them. I still cant install the game. I disabled nortons (actually I uninstalled it) - downloaded and installed the game and as soon as I reinstalled nortons it disabled the game again. THIS IS SOOOOOO FRUSTRATING!!!
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Dec 21, 08 5:35 AM
Thanks Flounder. Actually I do have a problem. I made it all the way to Blackbeard's Cave. Found the path to the treasure, but I can't find the blue gem in the cave to be able to complete the game. HELP!!!
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Dec 20, 08 4:50 PM
prpldva wrote:
ivillagegrinch wrote:
DIGITALIMAGER wrote:is there a glitch in this game have been in library hitting all books and cannot get any kind of action. can anyone help have hit the 5th book in section D-12 nothing.


Ditto!! This is pretty dang frustrating because I have scissors, and I have the action symbols over the computer screen and the bookholder...but I can't get the map book.


Use the computer to search for map book...




Type PARIS on your computer keyboard and then hit search on the onscreen computer
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Dec 20, 08 4:47 PM
coffeesandy wrote:please help

what do i have to do about that scarab beetles
i'm really stuck there
thanks




Smack em in their little butts with the hammer LOL
 
 
 posted in Dracula Origin on Dec 19, 08 4:54 PM
Scrape?? What do you use to scrape with? Ive been all over the cemetary and havent found a thing!
 
 
 posted in Dracula Origin on Dec 18, 08 5:34 AM
By the way the best way to get from the dialogue/item/etc menu is to hit the esc key...just thought I'd let y'all know
 
 
 posted in Dracula Origin on Dec 18, 08 5:33 AM
Downloaded and Installed - waited thru 10 minutes of dialogue - and can't figger out how to get out of Mina's room <sigh>
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator