Posts created by suslev

 
 
 posted in Adelantado Trilogy: Book Two on Jul 1, 17 2:53 PM
I need fish to talk to the boat owner but can't get down to the level the fisherman is on no bridges work Help.
 
 
 posted in Ominous Objects: Lumina Camera Collector's Edition on Dec 24, 16 2:28 PM
I cannot place Mr Jenkins also I have tried 4 times the strategy guide says to place him by the red glow but it does not work is someone going to fix it I feel ripped off.
 
 
 posted in Haunted Hotel: Silent Waters Collector's Edition on Dec 22, 16 3:43 AM
Same issue no hos open when I get the book no batteries in the camera getting really sick of the quality of bfg.
 
 
 posted in Ominous Objects: Lumina Camera Collector's Edition on Nov 28, 16 11:55 PM
I am not able to get the cat pic to stay either someone help.
 
 
 posted in Gourmet Chef Challenge: Around the World on Nov 28, 16 3:30 AM
Figured it out flip uncooked pancakes not the brown ones and you can get the puzzle to work but beyond that it is a dumb game and am not continuing.
 
 
 posted in Haunted Hotel: Silent Waters Collector's Edition on Nov 21, 16 5:52 AM
just started this game all going well until I get the book no hos opens and then in says it needs an element I am assuming it is the lense for the camera have a flash light but no batteries cant get the sun icon to move on. The most frustrating game out of the gate ever.
 
 
 posted in Haunted Hotel: Silent Waters Collector's Edition on Nov 20, 16 1:31 PM
I just started the game got the flashlight steel rods lion icon and book but cant do anything past that. in the strategy guide it says when you open the book a hos happens not mine it needs an element which I think is the lense from the flashlight but can remove it bird needs food but have no way to get any.HELP.
 
 
 posted in Adelantado Trilogy: Book One on Jan 27, 15 3:37 AM
5 times and am ready to quit was too frustrating and time consuming. No fun.
 
 
 posted in Adelantado Trilogy: Book One on Jan 26, 15 6:55 PM
I have tried three times on this level and still get stuck on that stupid green skull really i have spent way to any hours on this game as you can not save your work ug.
 
 
 posted in Adelantado Trilogy: Book One on Jan 23, 15 12:11 AM
I am in level one and cannot find the tree shells. Help!
 
 
 posted in 2 Tasty on Jan 21, 15 9:02 AM
I have reached level 46 and the game seemed to end there are quite a few more buildings available and there are lots of recipes that still say locked so it seems unfinished. Am I really done or how do I continue? Is three another chapter to purchase?
 
 
 posted in Angelica Weaver: Catch Me When You Can on Jun 15, 14 2:20 PM
I completed the HOS although I did not notice how many spools I got after the Hos was completed, I went to the next page dressing the maniquin found three spools but only have five and have searched high and low for another one and cannot find the 6th, HELP.
 
 
 posted in Maestro: Music from the Void Collector's Edition on Feb 22, 14 2:06 AM
I am playing the HOS in Sthe tower at the base of the stairs. I found all the objects but the S. I have looked everywhere. Can anyone help very frustrated.
 
 
 posted in Midnight Mysteries 3: Devil on the Mississippi on Jun 30, 11 3:16 AM
I also am having trouble cleaning the floor on the boat with the broom. I have the right spot even the raven keeps chowing me where to put the broom but when I put the broom there it either freezes up or flips back to inventory. I am stuck and connot continue the game. Help!
 
 
I have looked right through my strategy guide no mention at all of a boat. I even went to the well the shed etc. cannot find a boat al all?????
 
 
I have started this game three times and move along well until i go to the front gate. I cannot find the club to open the bag there. Without that the game stops. I have tried the stategy guide and the diary and neither help. I must admit I have played several of these games and this one is not designed well and not a lot of fun. HELLLLLLLP!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator